Clicking noise from behind IP - 97 D90 - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old March 25th, 2006, 04:59 PM
Saito
Status: Offline
Dale
Member
 
Join Date: Mar 2006
Location: Reno, NV
Posts: 3
Clicking noise from behind IP - 97 D90

Hello all -

need some help - guys at the local LR shop say they don't know what it is. 1997 D90 NAS. 76k miles - driving down freeway and clicking noise started up - thought I had my turn signal on - nope - nor the emergency flashers - yet that is what it sounds like - coming from behind IP. If you pull the 30amp fuse under the eng compartment fuse box - clicking stops. this fuse "description" shows an open textbook like figure. Ckeck engine light was on several hundred miles prior ( slow responding o2 sensor - they just reset it the last two times in at the LR shop and has went several thousand miles without another "glitch")

Took out IP - there is a green box attached to upper upper portion IP housing. measures about 1" thick, 3 1/2 in wide - 5 in length. Has two wiring connector packs going to it - one with a green connector, the other appears grey. If you pull the green connector out - clicking inside box stops. - pulled both green and gray connector out as suggested by LR tech at local shop - he thought he had one several years ago and that is all he did to "fix" it. Did that - still has click noise.

He also thought it has something to do with an interia switch - but wasnt sure. Dont care to spend $100 per hour for guessing... at least not this time.

The shop manual I have does not mention anything about this part

Any ideas folks??

Thanks in advance!

Dale
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old March 25th, 2006, 11:40 PM
48vphantom's Avatar
48vphantom
Status: Offline
Jeff Hoien
1997 NAS D90
Member
 
Join Date: Aug 2004
Location: Redmond, WA
Posts: 96
Dale, check this out
jeff
Attached Files
File Type: doc Antitheft System.doc (28.0 KB, 211 views)
Reply With Quote
  #3  
Old March 26th, 2006, 01:38 PM
Cholla
Status: Offline
Jack Copass
97 D-90 SW
Member
 
Join Date: Oct 2004
Location: Yucca Valley, Ca. USA
Posts: 22
Hey Dale, I had this problem occur once during a heavy rain, and I think it got wet. It was this same Immobilization Control unit (alarm ECU). Sounds just like a turn signal clicking, as you said. Mine stopped after turning the key off, and letting it sit for a while. If that continues for you, I would replace it.

Jack
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old March 28th, 2006, 11:17 AM
Saito
Status: Offline
Dale
Member
 
Join Date: Mar 2006
Location: Reno, NV
Posts: 3
THanks!

Quote:
Originally Posted by 48vphantom
Dale, check this out
jeff

That's it!

thanks guys!

Follow-up Post:

Quote:
Originally Posted by Cholla
Hey Dale, I had this problem occur once during a heavy rain, and I think it got wet. It was this same Immobilization Control unit (alarm ECU). Sounds just like a turn signal clicking, as you said. Mine stopped after turning the key off, and letting it sit for a while. If that continues for you, I would replace it.

Jack
I think I will - according to the guys at the local LR dealership - my vehicle is not suppose to even have this item in it... but it is going to get a new one!

THanks

Dale
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
90, 97, 97 d90, d90

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
headers for '97 D90 mdmccallum Defender Technical Discussions 43 April 25th, 2005 10:23 AM
I've Got A 97 D90 Frame That was just Galvanized ksteven Defender Technical Discussions 21 March 24th, 2005 11:22 AM
OEM MAF sensor from '97 D90.... dmarchand For Sale - Parts 4 June 18th, 2004 06:49 AM
97 D90 maxing out at ~70mph?? vnrover Defender Technical Discussions 3 November 10th, 2003 02:14 PM
For Sale: '97 D90 ST-1791 Alpine White jwebster For Sale - Vehicles 0 September 30th, 2003 12:36 AM


All times are GMT -5. The time now is 12:58 PM.


Copyright