can't start, no fuel supply - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old January 24th, 2010, 11:24 AM
ditskovich's Avatar
ditskovich
Status: Offline
dmitry
Range Rover Sport 2013
Member
 
Join Date: Nov 2008
Location: Potomac, md, usa
Posts: 196
can't start, no fuel supply

So I put the car together, finally. And now it is time to start it. Sparks are there, but no fuel supply. Should I reset something, like Inertia switch? Any ideas, why it is not getting fuel?
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old January 24th, 2010, 11:37 AM
Davis's Avatar
Davis
Status: Offline
Chris Davis
94 NAS D90 6.2LS
Member
 
Join Date: Nov 2003
Location: Colorado
Posts: 2,501
Let's start easy--when you turn the ignition on, can you hear the fuel pump running? If no, then check the silver bosch relays by the passenger kick panel--one is for the fuel pump, one is for the ignition system. If you can hear your fuel pump, I would start by seeing if you are getting fuel at your fuel rail--if not, then probably your fuel filter. If you are, then probably your injectors. Good place to start.
Reply With Quote
  #3  
Old January 24th, 2010, 07:00 PM
cgalpin's Avatar
cgalpin
Status: Offline
Charles Galpin
'94 D90 ST, '63 SeriesIIA
Site Team
 
Join Date: Jan 2004
Location: South Riding, VA
Posts: 11,625
Registry
Man Dmitry you should have done this back when you had none of the body put on. It would be much easier to troubleshoot without it all in the way.

I don't have any better suggestions than these guys, but if you can't hear the fuel pump and you are sure the silver relays are good (or try new ones) then your probably going to need to drop the fuel tank and make sure you are getting voltage there, and if you are then the pump is bad (otherwise figure out why no voltage).
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
fuel, start

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
300 Tdi Egt Q?????? Buckon37s Defender Technical Discussions 37 July 11th, 2012 11:26 AM
YANST (Yet Another No Start Thread) - fuel pump circuit issues cgalpin Defender Technical Discussions 25 August 2nd, 2009 11:23 PM
Diagnosing Fuel Pump Issues hutch Defender Technical Discussions 40 May 21st, 2009 09:04 PM
95 won't start, possible fuel priming issue? jcasteel Defender Technical Discussions 1 March 15th, 2005 09:45 AM
Rats! Now my D90 won't start. No power to fuel pump jcasteel Defender Technical Discussions 8 March 15th, 2005 09:42 AM


All times are GMT -5. The time now is 08:43 PM.


Copyright