Can't get any power to my dash - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old January 8th, 2015, 01:29 PM
Sheffieldadz
Status: Offline
Adam
1992 defender 90
Member
 
Join Date: Jan 2015
Location: Sheffield
Posts: 5
Can't get any power to my dash

Hi guys, my mates been sorting a few things on my defender and now all of a sudden my defender has lost all power but yet the battery is charged I've checked all fuses, relays tried looking for inline fuses and just can't get any power even my alarm hasn't got power

There's no lights on the dash at all and my alarm hasn't got power to it either but yet my battery is fully charged it also got no power to the ignition so it won't start

My mate was only having a look at my indicators has when i indicated right both my front indicators came on then all of a sudden my power is lossed he has had the clocks out aswell but can't see anything wrong

Please can someone help thanks a lot

It's a defender 90 1992
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old January 8th, 2015, 01:31 PM
rijosho's Avatar
rijosho
Status: Offline
Joshua
1995 Black ST - Rhinolined edition
Research Assistant/Eagle Eyes
 
Join Date: Apr 2009
Location: NYC
Posts: 16,557
Registry
check ignition switch.
__________________
Quote:
I am talking purely from an aesthetics standpoint.
Reply With Quote
  #3  
Old January 8th, 2015, 01:32 PM
Red90's Avatar
Red90
Status: Offline
John B.
1991 Defender 90, 200TDI
Site Team
 
Join Date: Sep 2003
Location: Calgary
Posts: 9,226
Registry
Check the main ground and power cables from the battery and from the engine to the chassis.
__________________
Pissing people off on the "net" since 1983.

Land Rover. Turning owners into mechanics since 1948.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old January 8th, 2015, 01:41 PM
leastonce's Avatar
leastonce
Status: Offline
Jason England
D-90 White 95 SW #65
Site Team
 
Join Date: Jul 2009
Location: NYC
Posts: 6,078
Registry
Fuses in the engine bay?
__________________
Quote:
Soapy water / KY jelly, etc. is is basically a must. Yes, good idea to remove trim panels - only takes 5 more minutes to do so.
Car Camping Collective founding member and Chief Executive Officer
Cat Camping Collective founding member and Chief Executive Officer
Reply With Quote
  #5  
Old January 8th, 2015, 01:58 PM
Rocky's Avatar
Rocky
Status: Online
Chris
72 + D1 drivetrain
Member
 
Join Date: Sep 2006
Location: Colonies Aka Boston
Posts: 8,762
Your mate has caused you a bunch of trouble ain't he?

Maybe you should only give him the beer AFTER he's done the job, not before...
__________________
A friend of mine runs a land rover / range rover specialty repair shop. Based on his experience, they are capable of stopping anywhere, anytime, at any cost.

I don't know about the brakes, only their unreliability.
Reply With Quote
  #6  
Old January 8th, 2015, 02:33 PM
Sheffieldadz
Status: Offline
Adam
1992 defender 90
Member
 
Join Date: Jan 2015
Location: Sheffield
Posts: 5
I don't think it could be ignition because my alarm hasn't got power at all and it's not flashing,

I've checked the Earth straps and one was loose but there in poor condition also can anyone tell me how many Earth straps there is and were they should be connected

Thanks
Reply With Quote
  #7  
Old January 8th, 2015, 02:45 PM
rijosho's Avatar
rijosho
Status: Offline
Joshua
1995 Black ST - Rhinolined edition
Research Assistant/Eagle Eyes
 
Join Date: Apr 2009
Location: NYC
Posts: 16,557
Registry
Some alarms control power to the ignition. Is that what you have???
__________________
Quote:
I am talking purely from an aesthetics standpoint.
Reply With Quote
  #8  
Old January 8th, 2015, 03:51 PM
Sheffieldadz
Status: Offline
Adam
1992 defender 90
Member
 
Join Date: Jan 2015
Location: Sheffield
Posts: 5
Hi not sure on my alarm as it was already on the defender but that's not even flashing at all or working when I press the key fob, could the earth wire have come off on the alarm?
Reply With Quote
  #9  
Old January 8th, 2015, 06:00 PM
ron's Avatar
ron
Status: Offline
Ron
1994 NAS Defender 90
Member
 
Join Date: Oct 2003
Location: Harwichport MA
Posts: 5,364
ah is the battery dead? keep the jumpers on then try key.
__________________
no thanks whatever I tell you, you will low ball me
I would rather keep the parts in storage
good luck with your search
Reply With Quote
  #10  
Old January 8th, 2015, 07:02 PM
javelinadave
Status: Offline
-
-
Member
 
Join Date: Sep 2003
Location: -
Posts: 5,394
I hate alarms. Especially aftermarket, dealer installed alarms.
Reply With Quote
  #11  
Old January 8th, 2015, 07:16 PM
Ignotus
Status: Offline
gene
1960 109, w/200TDI
Member
 
Join Date: Sep 2012
Location: 3rd rock from the Sun
Posts: 401
Are both cables tight to the battery? Is the ground cable tight to engine or frame? The + cable should go to the starter is it tight? From there a brown wire goes to the ignition switch, is it tight? Get a test lamp and figure out where the power goes and doesn't go.......get a manual.......HTH
__________________
Gene
1960 109
1960 88 Ignotus
Blog;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
  #12  
Old January 9th, 2015, 08:12 AM
Sheffieldadz
Status: Offline
Adam
1992 defender 90
Member
 
Join Date: Jan 2015
Location: Sheffield
Posts: 5
my mates just played around with the auto watch alarm box and it all started working and now it's all just stopped again no power at all ��

Thanks everyone

My next problem is;

When I indicate right all my indicators come on like I have the hazzards on
Reply With Quote
  #13  
Old January 9th, 2015, 08:51 AM
rankar's Avatar
rankar
Status: Offline
Randy
97 SW #2236 (Maggie)
Member
 
Join Date: Aug 2013
Location: CT
Posts: 1,117
Registry
Do you have led turning lights?
Reply With Quote
  #14  
Old January 9th, 2015, 09:50 AM
Sheffieldadz
Status: Offline
Adam
1992 defender 90
Member
 
Join Date: Jan 2015
Location: Sheffield
Posts: 5
Yeh ive just put led indicators in well the bulbs
Reply With Quote
  #15  
Old January 9th, 2015, 10:29 AM
javelinadave
Status: Offline
-
-
Member
 
Join Date: Sep 2003
Location: -
Posts: 5,394
Quote:
Originally Posted by rankar View Post
Do you have led turning lights?
Quote:
Originally Posted by Sheffieldadz View Post
Yeh ive just put led indicators in well the bulbs
Switch them back and do a little searching regarding LED flashers.
Reply With Quote
  #16  
Old January 9th, 2015, 10:32 AM
rijosho's Avatar
rijosho
Status: Offline
Joshua
1995 Black ST - Rhinolined edition
Research Assistant/Eagle Eyes
 
Join Date: Apr 2009
Location: NYC
Posts: 16,557
Registry
Quote:
Originally Posted by Sheffieldadz View Post
my mates just played around with the auto watch alarm box and it all started working and now it's all just stopped again no power at all ��
So I was right?
__________________
Quote:
I am talking purely from an aesthetics standpoint.
Reply With Quote
  #17  
Old January 9th, 2015, 11:02 AM
rankar's Avatar
rankar
Status: Offline
Randy
97 SW #2236 (Maggie)
Member
 
Join Date: Aug 2013
Location: CT
Posts: 1,117
Registry
Yeah you were Josh. You da man.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
dash

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I get more power for freeway driving from my 3.9 V8 Jcwhancock Defender Technical Discussions 41 December 14th, 2014 04:50 PM
How do these get into the USA and get sold? Grover Misc. Chit-Chat 33 April 23rd, 2012 01:15 PM
Can it get any better! Mike Hippert Defender Technical Discussions 14 April 4th, 2005 04:32 PM
So, if you could get any accessory you wanted.... Hans Misc. Chit-Chat 18 February 17th, 2005 09:47 AM
???still can't get the trany unbolted from the engine???? kit Defender Technical Discussions 4 October 23rd, 2003 03:20 PM


All times are GMT -5. The time now is 08:44 AM.


Copyright