burning up coils - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old July 23rd, 2005, 03:50 PM
tmore
Status: Offline
Tom More
1995 D90
Member
 
Join Date: Apr 2004
Location: Littleton, CO
Posts: 104
burning up coils

I am on a two month stretch of ignition problems.. Iwas fighting a problem where my vehicle would randomly stall while driving.. It seems that new ignition module #2 did the trick.. My new problem is that my coil is generating a lot of heat and burning out.. Two coils in the last 5 weeks.. I had thought that the first one was defective and replaced with a new bosch.. last night I was parked with the engine not running but the ignition switch and sereo on for a couple of hours and smelled something burning.. Opened the hood and had a lava flow coming out of my smoldering coil.. put a spare coil in and it started up and ran fine but it still seems that the coil is getting way too hot.. in the last two months I have replaced the inition module, coil, plug wires, plugs, cap , rotor..

Any suggestions??
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old July 23rd, 2005, 04:27 PM
Hans's Avatar
Hans
Status: Offline
Hans Haase
The D-90.com Lab Rat
Member
 
Join Date: Oct 2003
Location: Long Island, NY
Posts: 2,381
I'd get a voltage meter in there and check that you aren't pushing too much into the ignition system..... your voltage regulator may have gone bad.

-Hans
__________________
My oil line fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
My 100k stopped odometer fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Brace for impact, I'm in a "modifying mood". Massive thread count inbound.
Reply With Quote
  #3  
Old July 23rd, 2005, 07:43 PM
tmore
Status: Offline
Tom More
1995 D90
Member
 
Join Date: Apr 2004
Location: Littleton, CO
Posts: 104
Checked the voltage and it is at about 12.4v.. seems to be about normal?
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
coil

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Safari Gard Progressive Coils SafariGard The Vendors Loft 2 March 8th, 2009 03:06 PM
Weird sparking around coils flynn23 Defender Technical Discussions 8 August 11th, 2008 11:13 AM
Question about burning smell michael15 Defender Technical Discussions 13 March 7th, 2006 01:30 PM
Weird burning smell in 5th gear? oldscratchggf Defender Technical Discussions 7 February 14th, 2006 09:09 AM
burning coolant mattdh Defender Technical Discussions 2 July 19th, 2005 05:29 PM


All times are GMT -5. The time now is 08:25 AM.


Copyright