Brief, dramatic power losses.....? Ignition switch problem - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old February 27th, 2011, 10:03 PM
Knife90
Status: Offline
john sabra
'94 Defender 90
Member
 
Join Date: Sep 2010
Location: austin, tx
Posts: 20
Brief, dramatic power losses.....? Ignition switch problem

hey guys,
I'm experiencing brief (1-2sec) power losses,, at around 2,500 rpm, in my '94. They are pretty severe sometimes, jerking me forward in the seat. Usually in lower gears, can be fixed with hard throttle pushing over 3000 rpm. No real correlation with outside temp, but more frequent during first 10 mins after startup.
Replaced fuel filter already, nom fix.
There was a thread in '09 on here talking about the ignition switch as possible cause for these 'hiccups'.
Is "P. Scharfe" still out there? Your post describes very similar symptoms, but there were no follow ups on it.
Thanks for anynadvice.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old February 27th, 2011, 10:14 PM
CDNRover's Avatar
CDNRover
Status: Offline
Jeff Labbé
110 Ex-Mod FFR 200tdi
Member
 
Join Date: Jul 2007
Location: Tewkesbury,Canada
Posts: 672
Registry
If it's any help, I had to replace my ignition switch. I do not think it might be the problem for you as once the power cuts on the switch the engine dies just like it would when switching off the key. If you experience pick up while flooring it, I would suggest looking for something else... But as your Defender might be a gas engine, maybe I'm mistaken.. (I have a 200tdi). Have you check the ignition system? leads, plugs etc.. ?
__________________
Younger, we pointed the lad I now became.
Reply With Quote
  #3  
Old February 28th, 2011, 01:37 PM
Knife90
Status: Offline
john sabra
'94 Defender 90
Member
 
Join Date: Sep 2010
Location: austin, tx
Posts: 20
i've checked that everything is "snug", which is the basic extent of my mechanical knowledge for engine electrical. maybe i should start by replacing all the plugs? or is there a diagnostic i could run?
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old February 28th, 2011, 01:41 PM
dchapman
Status: Offline
Daniel Chapman
1999 D1
Member
 
Join Date: May 2004
Location: VA
Posts: 759
Have the same issue. Suspecting the fuel pump as I also have other "issues" all fuel related. Had my head damn near hit the steering wheel a few times, lol. Makes you feel like a retard.
Reply With Quote
  #5  
Old February 28th, 2011, 01:49 PM
evilfij's Avatar
evilfij
Status: Offline
evilfij
I have never seen a rover in person
Member
 
Join Date: Oct 2003
Location: on the internet
Posts: 14,688
Is there water in your computer?
__________________
*not legal advice*
Reply With Quote
  #6  
Old February 28th, 2011, 02:05 PM
Knife90
Status: Offline
john sabra
'94 Defender 90
Member
 
Join Date: Sep 2010
Location: austin, tx
Posts: 20
shouldn't be any water there in the computer. its been dry as hell here in texas for months, and problem surfaces even after a week of dry days. has been ongoing for several months. should i pull it out anyway?
daniel... funny you say that about hitting the steering wheel! i think i actually did one time. my sons were in the jumpseats in the back and got thrown forward a bit too (sideways actually in the jumps). "Dad! What are you doing!! Cant you drive?!" yes, makes me feel like an idiot.
Reply With Quote
  #7  
Old February 28th, 2011, 02:41 PM
evilfij's Avatar
evilfij
Status: Offline
evilfij
I have never seen a rover in person
Member
 
Join Date: Oct 2003
Location: on the internet
Posts: 14,688
Can't hurt. Do you have a spare to try?
__________________
*not legal advice*
Reply With Quote
  #8  
Old February 28th, 2011, 03:04 PM
Knife90
Status: Offline
john sabra
'94 Defender 90
Member
 
Join Date: Sep 2010
Location: austin, tx
Posts: 20
no spare... i'm new to this game. is it hard to pull out the computer? i'm not even sure what part of that electrical wad is the actual 'computer'.
...on spares note, do you guys just acquire spares of things you think you might need, or have parts 90's sitting around? what do most guys do?
Reply With Quote
  #9  
Old February 28th, 2011, 03:27 PM
evilfij's Avatar
evilfij
Status: Offline
evilfij
I have never seen a rover in person
Member
 
Join Date: Oct 2003
Location: on the internet
Posts: 14,688
At one point in time I posted a list of what I carry in my truck. For starters: two silver relays, a cap, a rotor, a coil wire, an ignition module, a computer and a fuel filer will get you through a lot of issues.
__________________
*not legal advice*
Reply With Quote
  #10  
Old February 28th, 2011, 04:18 PM
Knife90
Status: Offline
john sabra
'94 Defender 90
Member
 
Join Date: Sep 2010
Location: austin, tx
Posts: 20
thanks, evilfij, i appreciate the list. i'm gonna start a new post just to get a survey of that. should be interesting.
Reply With Quote
  #11  
Old March 20th, 2011, 09:57 PM
dchapman
Status: Offline
Daniel Chapman
1999 D1
Member
 
Join Date: May 2004
Location: VA
Posts: 759
Fuel pump fixed my problem.
Reply With Quote
  #12  
Old March 21st, 2011, 02:55 PM
Roverchef's Avatar
Roverchef
Status: Offline
Jake K.
95 D90 SW
Member
 
Join Date: Jan 2010
Location: Deep in the Dirty South
Posts: 341
Can get it to do it every time at around 2500rpm's and then it doesn't do it if you push through it and get the rpm's up above that or below 2500rpm's? I would pull the alternator belt off with everything else still connected and drive it around and see if it still does it. The charging light will be on but that doesn't matter as long as you only go for a short drive. The alternator's on these rigs can cause havac when they start to go bad. The charging side of them still work but the diodes inside takes a poo! TEST: drive Rover till it does it and then pull the alternator belt and drive again and see if it went away.
Reply With Quote
  #13  
Old March 21st, 2011, 03:11 PM
leastonce's Avatar
leastonce
Status: Offline
Jason England
D-90 White 95 SW #65
Site Team
 
Join Date: Jul 2009
Location: NYC
Posts: 6,078
Registry
What codes do you have on the computer display ...
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
switch

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Removing Faulty Ignition Switch - It's STUCK rijosho Defender Technical Discussions 20 March 29th, 2017 12:54 PM
Switch/Wiring Question: Stereo Ignition Power Override nimbusnic Defender Technical Discussions 3 June 30th, 2008 01:05 AM
wiring of ignition switch mattdh Defender Technical Discussions 1 October 4th, 2006 01:50 PM
Ignition switch jorge Defender Technical Discussions 1 January 10th, 2005 01:12 PM
Ignition Power bjenk Defender Technical Discussions 9 November 22nd, 2004 07:20 PM


All times are GMT -5. The time now is 07:36 PM.


Copyright