Braking woes? - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old July 24th, 2013, 08:06 PM
tomaco1's Avatar
tomaco1
Status: Offline
T.mac
83 110
Member
 
Join Date: Oct 2007
Location: Long Island, New York
Posts: 3,693
Registry
Braking woes?

Drove my truck home today after 6 months in he shop. At first my brakes felt great, but as the 3 mile trip progressed the brakes began to drag more and more. When I got it in the drive way it would barely move. I left it for a few hours and when I came back the brakes seemed fine.
Any ideas?
I did f-around with the booster a bit, was wondering if that might be it.

On a side not, the truck no longer fits in the garage. Same shocks,cage, everything. Very annoying.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old July 24th, 2013, 08:13 PM
grnthng's Avatar
grnthng
Status: Offline
Luis A. Costa
'93 Range Rover County LWB
Member
 
Join Date: Jun 2008
Location: Kenilworth, N. J. 07033
Posts: 378
Seems like everybody is having brake woes.....I wish my problems were like yours!

Sounds like a seized caliper/s.....simply jack up a wheel a time, you'll have enough play in the drive train just to see which one is dragging! It happens when brakes are not used for awhile!
Reply With Quote
  #3  
Old July 24th, 2013, 08:42 PM
Bill Larson's Avatar
Bill Larson
Status: Offline
Bill Larson
97 D90 SW
Member
 
Join Date: Jul 2010
Location: AUS
Posts: 6,563
yeah that's kind of odd I've been noticing a handful having problems also...
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old July 24th, 2013, 08:46 PM
tomaco1's Avatar
tomaco1
Status: Offline
T.mac
83 110
Member
 
Join Date: Oct 2007
Location: Long Island, New York
Posts: 3,693
Registry
I don't thinks a caliper, because they all seemed to drag on the way home, and they all rolled freely after I let it sit.
Reply With Quote
  #5  
Old July 24th, 2013, 10:15 PM
CDNRover's Avatar
CDNRover
Status: Offline
Jeff Labbé
110 Ex-Mod FFR 200tdi
Member
 
Join Date: Jul 2007
Location: Tewkesbury,Canada
Posts: 672
Registry
Have you checked the booster?
__________________
Younger, we pointed the lad I now became.
Reply With Quote
  #6  
Old July 24th, 2013, 10:31 PM
honda50r's Avatar
honda50r
Status: Offline
Alex
1998 Discovery
Member
 
Join Date: Jun 2012
Location: East Tennessee
Posts: 149
Registry
Sounds like a leaky master losing pressure
Reply With Quote
  #7  
Old July 24th, 2013, 10:41 PM
Ren Ching's Avatar
Ren Ching
Status: Offline
Skinny Pete
'84 90 "Yamelo"/'88 RRC "Chewbacca"
Member
 
Join Date: Mar 2007
Location: Downtown
Posts: 4,696
Registry
back off the booster pushrod a little bit. Shop manual should give a setting for it.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
left pull when braking paulb Defender Technical Discussions 19 November 7th, 2017 09:21 PM
front end 'clunk' when braking.. jaherring Defender Technical Discussions 3 September 29th, 2005 12:04 PM
Non D90 tech question... Wobble while braking. jabber Defender Technical Discussions 5 August 30th, 2005 09:22 PM
Wow, more exhaust woes. Hans Misc. Chit-Chat 14 May 27th, 2005 02:08 PM
CDL woes ToaDisco Defender Technical Discussions 10 September 27th, 2004 06:10 PM


All times are GMT -5. The time now is 11:47 PM.


Copyright