brake & abs light on - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old March 27th, 2013, 11:59 AM
Baja 90
Status: Offline
Raul
97 D90, 94 RRC
Member
 
Join Date: Aug 2009
Location: Southern California
Posts: 101
brake & abs light on

Hi guys, changed the abs pump in the 94 RRC. The ABS and brake lights stay on. Pump/brakes are working fine. Any ideas? Is this common?
Thanks,
Raul
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old March 27th, 2013, 12:07 PM
o2batsea's Avatar
o2batsea
Status: Offline
Bill Adams
66 109 sw 94 lwb
Member
 
Join Date: Jul 2009
Location: kensington md
Posts: 6,501
Registry
ECU recorded an error. Duh, you know that. I am unsure whether simply unplugging power to the ECU for a while will clear the flash memory/error codes or not. Costs nothing, so worth a try. You'll have to reset the clock!
__________________
Bill Adams

1966 109 5 door wagon 300Tdi "spermaceti fueled"
1994 RRC LeWiB "ruining the air behind me"
1968 2A 88

All my troubles are Rover
Reply With Quote
  #3  
Old March 27th, 2013, 12:19 PM
Baja 90
Status: Offline
Raul
97 D90, 94 RRC
Member
 
Join Date: Aug 2009
Location: Southern California
Posts: 101
Quote:
Originally Posted by o2batsea View Post
ECU recorded an error. Duh, you know that. I am unsure whether simply unplugging power to the ECU for a while will clear the flash memory/error codes or not. Costs nothing, so worth a try. You'll have to reset the clock!
Thanks! I'll try that and let you know if it worked.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old March 27th, 2013, 12:20 PM
evilfij's Avatar
evilfij
Status: Offline
evilfij
I have never seen a rover in person
Member
 
Join Date: Oct 2003
Location: on the internet
Posts: 14,688
It should reset after a while by itself. You could have an actual fault with a wheel sensor or something too.
__________________
*not legal advice*
Reply With Quote
  #5  
Old March 27th, 2013, 12:26 PM
Baja 90
Status: Offline
Raul
97 D90, 94 RRC
Member
 
Join Date: Aug 2009
Location: Southern California
Posts: 101
Quote:
Originally Posted by evilfij View Post
It should reset after a while by itself. You could have an actual fault with a wheel sensor or something too.
If there was a fault it would give me a code right?
Reply With Quote
  #6  
Old March 28th, 2013, 09:04 PM
Baja 90
Status: Offline
Raul
97 D90, 94 RRC
Member
 
Join Date: Aug 2009
Location: Southern California
Posts: 101
No luck. Disconnected the ECU and the lights came on. Every once in a while they'll go off for a minute or so, but then right back on. I'm not getting a fault code.
Any ideas?
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
brake, ht

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
brake light switch snuffer Defender Technical Discussions 7 March 28th, 2006 07:02 AM
Tailgate, Tire Carrier, 3rd Brake light, rear bumper jabber For Sale - Parts 5 December 8th, 2005 02:10 AM
Help, brake light problem! Dfndr90 Defender Technical Discussions 5 July 11th, 2005 07:39 PM
tire carrier, 3rd brake light, and other stuff jabber For Sale - Parts 12 January 20th, 2005 03:06 PM
Brake light on after brake install wicks Defender Technical Discussions 6 October 13th, 2003 07:01 PM


All times are GMT -5. The time now is 06:37 AM.


Copyright