Blowing fuse on marker light Atlantic British harness - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old October 4th, 2014, 08:58 PM
Pwo
Status: Offline
Porter
94 NAS D90
Member
 
Join Date: Sep 2014
Location: york sc
Posts: 19
Blowing fuse on marker light Atlantic British harness

i installed the Alantic British trailer harness and the marker light fuse for the left side blew. All is good with the install. The marker lamp fuse is 7.5 amps and The trailer has 8 lamps on this circuit. I installed a 10 amp fuse to cover the added current and inrush and no more problem. Has anyone else run across this? 94 NAS D 90. Thanks
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old October 5th, 2014, 03:34 PM
Pwo
Status: Offline
Porter
94 NAS D90
Member
 
Join Date: Sep 2014
Location: york sc
Posts: 19
Question

Bump, anybody?
Reply With Quote
  #3  
Old October 5th, 2014, 03:38 PM
Red90's Avatar
Red90
Status: Online
John B.
1991 Defender 90, 200TDI
Site Team
 
Join Date: Sep 2003
Location: Calgary
Posts: 9,235
Registry
No but there is no way 7.5 amps is adequate for 8 normal lamps. You can check the wattage of the bulbs and figure his out.
__________________
Pissing people off on the "net" since 1983.

Land Rover. Turning owners into mechanics since 1948.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old October 5th, 2014, 07:14 PM
Pwo
Status: Offline
Porter
94 NAS D90
Member
 
Join Date: Sep 2014
Location: york sc
Posts: 19
Thanks I'll have to do the calculations, the wire appears to be 16 gage ,so 10 amps at 14 volts should be ok.
Reply With Quote
  #5  
Old October 5th, 2014, 08:26 PM
chuckc4
Status: Offline
chuck b
Registered User
 
Join Date: Dec 2004
Location: USA
Posts: 517
Deleted my reply because it was unhelpful after rethinking it.....


Quote:
Originally Posted by Pwo View Post
i installed the Alantic British trailer harness and the marker light fuse for the left side blew. All is good with the install. The marker lamp fuse is 7.5 amps and The trailer has 8 lamps on this circuit. I installed a 10 amp fuse to cover the added current and inrush and no more problem. Has anyone else run across this? 94 NAS D 90. Thanks
Reply With Quote
  #6  
Old October 5th, 2014, 08:39 PM
Pwo
Status: Offline
Porter
94 NAS D90
Member
 
Join Date: Sep 2014
Location: york sc
Posts: 19
Thanks Chuckc4
Grounds are not a problem. All lights are bright, this bass boat trailer has a lot of marker lights. My diesel f250 has no problem but domestic cars use the tail lights and brake lights left and right on the same circuit, un like the rover with circuits for left side and right side for marker lights, tail lights and head lights separate. I was curious if anyone else had to increase the amp rate on this fuse with this setup.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
ht, wing

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installed Alantic British trailer harness and blowing fuse Pwo For Sale - Vehicles 0 October 4th, 2014 08:50 PM
Atlantic British/British Pacific Merger brn24whl The Vendors Loft 93 May 23rd, 2013 04:39 PM
60amp accessory fuse B blowing in main fuse box owen Defender Technical Discussions 5 March 31st, 2013 09:18 AM


All times are GMT -5. The time now is 04:13 PM.


Copyright