Bad noise - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old March 7th, 2010, 02:19 PM
Jpayne's Avatar
Jpayne
Status: Offline
Jeff Payne
'83 110 3 Door
Member
 
Join Date: Aug 2009
Location: Albuquerque, NM
Posts: 1,393
Registry
Bad noise

So lately when I come to a stop I hear a grinding noise in the front of the truck. It happens when I have the clutch in, and doesn't matter if I have the brakes on or not, but only occurs at a few MPH and only after the truck warms up a bit. It happens with a pretty rapid frequency, like it has something to do with the speed of the driveshaft or differential rather than the wheels. Any one else have this problem at some point in time? I might park it till I figure this out.

Thanks!
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old March 7th, 2010, 03:44 PM
Hans's Avatar
Hans
Status: Offline
Hans Haase
The D-90.com Lab Rat
Member
 
Join Date: Oct 2003
Location: Long Island, NY
Posts: 2,381
My parking brake drum has been doing that on and off for years. Took me a LONG time to find it, I initially started with pulling CV joints and all the front end stuff.

-Hans
__________________
My oil line fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
My 100k stopped odometer fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Brace for impact, I'm in a "modifying mood". Massive thread count inbound.
Reply With Quote
  #3  
Old March 7th, 2010, 08:41 PM
Jpayne's Avatar
Jpayne
Status: Offline
Jeff Payne
'83 110 3 Door
Member
 
Join Date: Aug 2009
Location: Albuquerque, NM
Posts: 1,393
Registry
I was ready to jack up the front end and start turning the wheels to see what was going on.

So what do you do about that, just change the brake pads on that drum?
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old March 7th, 2010, 10:33 PM
Hans's Avatar
Hans
Status: Offline
Hans Haase
The D-90.com Lab Rat
Member
 
Join Date: Oct 2003
Location: Long Island, NY
Posts: 2,381
Took it off, cleaned it up with a scotch bright pad, adjusted it, and put it back together.

-Hans
__________________
My oil line fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
My 100k stopped odometer fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Brace for impact, I'm in a "modifying mood". Massive thread count inbound.
Reply With Quote
  #5  
Old March 8th, 2010, 11:57 PM
Jpayne's Avatar
Jpayne
Status: Offline
Jeff Payne
'83 110 3 Door
Member
 
Join Date: Aug 2009
Location: Albuquerque, NM
Posts: 1,393
Registry
Ok thanks. It is getting worse and I'm pretty sure that drum is the culprit. When I was on my way home the truck was starting to shudder a bit at even higher speeds and felt really odd. I parked it and looked underneath and the drum was very hot and smoking. Bummer. I hope I didn't completely toast it.
Reply With Quote
  #6  
Old March 9th, 2010, 07:27 AM
Hans's Avatar
Hans
Status: Offline
Hans Haase
The D-90.com Lab Rat
Member
 
Join Date: Oct 2003
Location: Long Island, NY
Posts: 2,381
there isn't much too the whole assembly at all, not much to ruin other than the shoes.

-Hans
__________________
My oil line fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
My 100k stopped odometer fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Brace for impact, I'm in a "modifying mood". Massive thread count inbound.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help For Bad Handling...(I mean BAD!) Cube II Defender Technical Discussions 18 July 7th, 2006 09:07 AM
Curious knocking noise mikeslandrover Defender Technical Discussions 6 March 29th, 2005 06:09 PM
whistling noise from engine jstrong98 Defender Technical Discussions 2 December 14th, 2004 11:37 PM
Help! Bad noise out of right rear!! P1CR Defender Technical Discussions 14 March 2nd, 2004 09:29 AM
bad bad BAD noise rover4x4 Defender Technical Discussions 11 December 12th, 2003 12:44 AM

» Defender Registry

Toby

Willh

Camel

Camel 422
Add your Defender

All times are GMT -5. The time now is 04:10 PM.


Copyright