Auto Conversion Idle Help - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old November 24th, 2007, 05:44 PM
mpsteil
Status: Offline
Michael Steil
NAS 110#23,97 ST#665
Member
 
Join Date: Sep 2006
Location: Woodside,CA, USA
Posts: 675
Auto Conversion Idle Help

Anyone here do an auto conv and have idle problems. My 110 was converted to auto and it will die at startup somtimes or when you come to a stop sign. I read on ECR's website they mess with the ECU when they do there auto conv but I would not know where to start. Shifting is good and the problem is spuratic(sp?). I dont think the shop who did the job did not hook up the starter inhibit switch or the park safety switch. Any thoughts would help. The problem is not real bad just real annoying. Mike
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old November 24th, 2007, 06:32 PM
Andrew Vick
Status: Offline
Andrew Vick
95 D90
Member
 
Join Date: Feb 2004
Location: Basalt, USA
Posts: 437
May not be related, but sounds like the IAC (stepper motor). I wonder if it's not compensating for the bit more of load that always being in gear is putting on the motor.
Reply With Quote
  #3  
Old November 24th, 2007, 06:59 PM
mountainviewrover's Avatar
mountainviewrover
Status: Offline
MARK LECLAIR
95 Range Rover Classic
Member
 
Join Date: Mar 2006
Location: PLATTSBURGH,NY USA
Posts: 1,330
Registry
Michael, Maybe You Should Just Sell It To Me That Will Get Rid Of Your Problem All Together.
__________________
WHO OWN THE CHIEFS? OWNZZZ OWNZZZ
my e-mail:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old November 25th, 2007, 03:34 PM
dmarchand's Avatar
dmarchand
Status: Offline
David Marchand
'97 D90 SW Arles
Member
 
Join Date: Sep 2003
Location: New England
Posts: 2,862
Registry
I don't think the auto trans and your idle problem are related.

If this was recent work, get in there and check all connections to the stepper, ECU, etc.
Reply With Quote
  #5  
Old November 25th, 2007, 03:48 PM
mpsteil
Status: Offline
Michael Steil
NAS 110#23,97 ST#665
Member
 
Join Date: Sep 2006
Location: Woodside,CA, USA
Posts: 675
Mark, if I sell you my last Land Rover I might have to buy a mini van or a j**p and we all dont want that.

The work is not recent. The PO had the conversion done a few years back and he said the intermittent problem started after the auto was installed. I dont know what a stepper motor is but I will find out and check it. Thanks, Mike
Reply With Quote
  #6  
Old November 25th, 2007, 05:23 PM
landrovered's Avatar
landrovered
Status: Offline
S. Smith
72 Series III 109 Diesel
Member
 
Join Date: Jun 2007
Location: Under my truck!
Posts: 753
The idle on an automatic is higher to eliminate stalls when turning the torque converter while your foot is on the brake. I would guess that is what is reset in the ECU.
__________________
72 Series III 109 SW Diesel, 03 RR, 98 Porsche 986, 01 Porsche 986 3.6 L
Reply With Quote
  #7  
Old November 25th, 2007, 09:52 PM
PCRover's Avatar
PCRover
Status: Offline
Gary Young
'94 90ST -> SW
Member
 
Join Date: Feb 2005
Location: NorCal
Posts: 304
Mike, I will look in the wiring diagrams in the service manual and see if it shows some kind of connection from the shifter to the ECU. I believe the way it is supposed to work is when you put it in gear it raises the idle.

Follow-up Post:

It looks like the Auto Shifter is connected to the Multi Function ECU at C062-3 (BK,0.5).

Do you have any wires connected from the shifter to the harness?
__________________
Gary
Reply With Quote
  #8  
Old November 26th, 2007, 10:24 AM
ECR's Avatar
ECR
Status: Offline
East Coast Rover Co.
Just Defenders, nothing else.
D-90 Source Vendor
 
Join Date: May 2006
Location: Rockland, ME, USA
Posts: 4,614
Quote:
Originally Posted by mpsteil
Anyone here do an auto conv and have idle problems. My 110 was converted to auto and it will die at startup somtimes or when you come to a stop sign. I read on ECR's website they mess with the ECU when they do there auto conv but I would not know where to start. Shifting is good and the problem is spuratic(sp?). I dont think the shop who did the job did not hook up the starter inhibit switch or the park safety switch. Any thoughts would help. The problem is not real bad just real annoying. Mike

The park/ inhibit switch must be tied into the ECU. If it isn't done it will cause idle flair and such when shifting into Park and a low idle when in gear, like when you are at a stop light.
Hook the truck up to an Auto-Logic or other unit and in the settings you can see a window that indicates the gear. It either will or will not show a difference when the truck is put in gear. In the Auto-Logic it says "Drive" when in R or D and "Park" when in P or N. If you don't see this change that means the ECU still thinks is a 5 speed and its never gonna have 100% at idle or in gear.

Email me if you plan to do the work yourself and I'll tell you what to do to hook it up correctly.
That or take it back to the shop that did the work and tell them to complete the job.

This is the same thing that happens with the new AC systems, like the ones RN sells. The installers don't tie it into the ECU and then you'll get a low idle, or even a stall when the compressor kicks in. Then folks start messing with engine adjustments to try and "cure" it, when the problem was just the ECU not knowing when te AC was on in the first place.
__________________
Email:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

I do not check PMs. Call or email if you need something.

ECR is not a parts source. We are not in the mail order business.
Reply With Quote
  #9  
Old November 26th, 2007, 08:26 PM
mpsteil
Status: Offline
Michael Steil
NAS 110#23,97 ST#665
Member
 
Join Date: Sep 2006
Location: Woodside,CA, USA
Posts: 675
Thanks, Mike. I will email you. I am going to try and do it myself. I have access to an Auto logic. I tried the shop who did the work for the PO and they were less than happy to even talk about let alone fix it. I just wish you guys were on the west coast and not so far away.

Thanks again. Mike
Reply With Quote
  #10  
Old November 27th, 2007, 12:34 PM
azD90's Avatar
azD90
Status: Offline
Kevin Houseal
1994/D90
Member
 
Join Date: Sep 2004
Location: Fountain Hills, AZ. USA
Posts: 21
If not the stepper, I just read this...(fell under RRC tips, not sure the 90 is the same but it said v8s...)
http://www.roversnorth.com/web/downl...le-air-gap.pdf
Reply With Quote
  #11  
Old March 24th, 2008, 12:09 PM
phoenix37's Avatar
phoenix37
Status: Offline
john
97 D90 ST / 1957 S1 109/ 1983 LS110
Member
 
Join Date: Feb 2008
Location: Venice, CA/Yarmouth,ME
Posts: 5,787
Registry
Michael did this fix your problem? I also have 110 with a poor auto conversion and I have the same issues. The park safety swith especially with little kids and dogs running around is my biggest concern.
Reply With Quote
  #12  
Old March 26th, 2008, 12:05 AM
mpsteil
Status: Offline
Michael Steil
NAS 110#23,97 ST#665
Member
 
Join Date: Sep 2006
Location: Woodside,CA, USA
Posts: 675
I have not fixed the problem yet. Mike at ECR pushed me in the right direction but I have not really worked on the truck for awhile. My idle problem would come and go but now it seems it is getting worse so I will have to address it soon. I will post what I come up with once I start playing with it. Mike
Reply With Quote
  #13  
Old February 10th, 2010, 03:55 PM
BEIS's Avatar
BEIS
Status: Offline
RYAN BEIS
D110 Soft Top with full rollcage
Member
 
Join Date: Jul 2008
Location: Louisiana
Posts: 362
Registry
Sorry resurrecting a very old thread, but I am having the same issues with my automatic 110. Mike, did anything come of your situation? Thanks in advance!
__________________
-Ryan

Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
conversion, idle

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Arles Blue ST - $19,500 OBO Auto Conversion rijosho The Flea Market 29 January 20th, 2013 10:34 PM
93 D110 auto transmission conversion bcourtney Defender Technical Discussions 37 June 8th, 2007 08:37 PM
Fault Code 48/fast engine idle speed arbik Defender Technical Discussions 9 June 2nd, 2006 07:02 AM
fluctuating idle KeithElisa Defender Technical Discussions 15 May 31st, 2006 08:38 AM
Manual To Auto Conversion willtillery Defender Technical Discussions 2 September 22nd, 2004 10:12 PM


All times are GMT -5. The time now is 03:36 AM.


Copyright