Any ideas? Should I be worried? - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old May 5th, 2009, 10:01 AM
bharris's Avatar
bharris
Status: Offline
Brad Harris
1994 d90 300tdi "Nola"
Member
 
Join Date: Jan 2008
Location: Los Angeles, CA
Posts: 955
Any ideas? Should I be worried?

Alright I'm not really worried but I wonder if anyone here has any ideas as to why:

So first of all the indicator light for my emergency brake doesn't work... hasn't worked since I got it. You pull the emergency brake, it stops the truck but indicator light on the dash.

So I'm doing some moderate wheeling on the weekend and descending through a rock garden so I've got it in locked low and second gear when my brake light indicator flickers to life and comes on. I double checked the emergency brake to ensure it was not in fact pulled and continued my descent. I found that if I could accelerate on flat or slight uphills the light would go off again but any time I was working on a slow descent it would flicker to life again....

any ideas on where I'm getting a connection?
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old May 5th, 2009, 10:08 AM
Hoosier's Avatar
Hoosier
Status: Offline
Chris Hinkle
More than I need
Member
 
Join Date: Jun 2006
Location: Dallas, TX
Posts: 634
Not to worry, handbrake has a little switch which engages when you pull up on the handbrake. Check wires - either loose wire or bad switch.
Reply With Quote
  #3  
Old May 5th, 2009, 10:19 AM
JRW's Avatar
JRW
Status: Offline
John
94 D90 ST #1247
Member
 
Join Date: Jun 2008
Location: Flower Mound, TX
Posts: 253
I know I am stating the obvious, but it sounds like an electrical short. Looking at the wiring diagram it is a straight shot from the parking break switch to the light.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old May 5th, 2009, 10:19 AM
Monkeyboy

Guest
 
Posts: n/a
Check the fluid level in the master too.
Reply With Quote
  #5  
Old May 5th, 2009, 10:42 AM
ron's Avatar
ron
Status: Online
Ron
1994 NAS Defender 90
Member
 
Join Date: Oct 2003
Location: Harwichport MA
Posts: 5,369
second keith
Reply With Quote
  #6  
Old May 5th, 2009, 10:42 AM
pendy's Avatar
pendy
Status: Offline
jim pendleton
89'd90
Member
 
Join Date: Oct 2003
Location: andover, ks usa
Posts: 2,341
Quote:
Originally Posted by Monkeyboy
Check the fluid level in the master too.
Yes thats whats wrong
__________________
legend in my own mind

Advice is only as good as the person applying it--
Don't make me give you bad advice!

Lemons or lemonaide, whatever your taste provides.
Reply With Quote
  #7  
Old May 5th, 2009, 10:51 AM
evilfij's Avatar
evilfij
Status: Offline
evilfij
I have never seen a rover in person
Member
 
Join Date: Oct 2003
Location: on the internet
Posts: 14,688
Quote:
Originally Posted by pendy
Yes thats whats wrong
Also, not necessarily wrong. Depending on the angle it can trigger the light even if it is at an appropriate level. My lotus does this one turns.
__________________
*not legal advice*
Reply With Quote
  #8  
Old May 5th, 2009, 06:10 PM
PMKColorado's Avatar
PMKColorado
Status: Offline
Paul Koentges
'95 White D-90, #2625
Member
 
Join Date: Oct 2008
Location: Golden Colorado
Posts: 185
mine did the same thing...remove the boot at the brake lever (slides upward, carful not to tear) and you will see the wire/switch whick makes contact when you pull up on the handle. Mine was loose, I sprayed contact cleaner into the switch, pinched the wire connector for a tighter fit, and tightened the fastener...works.


good luck
Reply With Quote
  #9  
Old May 6th, 2009, 08:16 AM
btate
Status: Offline
Bryan Tate
d90
Member
 
Join Date: Aug 2004
Location: Wilmington, NC
Posts: 479
yeah, my mcclaren f1 does that around 190mph, kinda annoying
Reply With Quote
  #10  
Old May 6th, 2009, 10:21 AM
bharris's Avatar
bharris
Status: Offline
Brad Harris
1994 d90 300tdi "Nola"
Member
 
Join Date: Jan 2008
Location: Los Angeles, CA
Posts: 955
Quote:
Originally Posted by btate
yeah, my mcclaren f1 does that around 190mph, kinda annoying
when accelerating through 190, decelerating from 190 or just an indicator that you have now reached 190?
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bumper Sticker Ideas chris snell Misc. Chit-Chat 46 November 18th, 2005 08:02 AM
sway bar ideas redrover Defender Technical Discussions 10 October 1st, 2004 09:56 PM
Ideas on building a 110 draaronr Defender Technical Discussions 4 July 14th, 2004 09:59 PM
Windscreen ideas Mike Hippert Misc. Chit-Chat 40 July 9th, 2004 02:38 PM
CB mounting ideas flippedrover Defender Technical Discussions 21 March 29th, 2004 11:22 PM


All times are GMT -5. The time now is 09:24 AM.


Copyright