Another fuel pump not running issue - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old August 27th, 2012, 04:36 PM
aka rover's Avatar
aka rover
Status: Offline
ed angel
95 D90
Member
 
Join Date: Dec 2010
Location: Anchorage Alaska
Posts: 1,132
Registry
Another fuel pump not running issue

Hey guys

My 95 90 is not getting power to the fuel pump.

I have checked for power at fuel pump fuse and theres nothing there, I checked for power at the inertia switch nothing there. Im down to thinking that the ECU maybe done?

I have checked the relays and find power there and if I give ground to the blue wire which I believe is the wire the ECU gives ground to relay the fuel pump runs. The part im stumped at is why isnt there power KEY ON at the fuel pump fuse?

All this started after a month long hibernation while I was out of town, I disconeccted the battery as I allways due when I leave town to keep the battery from going dead from sterao memory wire.

PS I noticed while cranking motor over the tach jumps up to 3000 rpms while cranking! maybe the alt. doing this or grounds? I have checked and cleaned all I could find.

Im sure im missing something simple here, I can't find my rave CD so hopeing someone has an idea. All door buzzers and other key on accs. work just fine. its just the fuel pump voltage.

It has spark no fuel

Thanks Ed
__________________
95 D90 SW 4.6 ARBs 8274 37" BFGs Gigglepin twin motor 8274
94 D90 ST R380 constine green stock
85 D110 3.5 3 DR
67 NADA diesel tremec 4spd salisbury rear springs on front and a LOT MORE TO GO.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old August 27th, 2012, 05:24 PM
red&yellowrovers's Avatar
red&yellowrovers
Status: Offline
Joe Still
95 D90 NAS 3.9l ST AA Yellow #2719
Member
 
Join Date: Jul 2011
Location: Huntsville, AL
Posts: 86
I've been battling the same thing. Mine goes dead after 5 mins and won't start
(no fuel pump) for about 3 hrs.

I've sent my ecu off to have bench tested/repaired. Will let you know if that helps.

Based on other threads it seems the electrical connectors at the pump can also go bad so I'm tryign to pull the fuel tank to renew those connectorions. My pump was new 300 miles ago.

Good luck and stay in touch. js
Reply With Quote
  #3  
Old August 28th, 2012, 03:18 AM
aka rover's Avatar
aka rover
Status: Offline
ed angel
95 D90
Member
 
Join Date: Dec 2010
Location: Anchorage Alaska
Posts: 1,132
Registry
Thanks

Let me know if your ECU fixes your issues, Did your tach bounce while cranking.


Ed
__________________
95 D90 SW 4.6 ARBs 8274 37" BFGs Gigglepin twin motor 8274
94 D90 ST R380 constine green stock
85 D110 3.5 3 DR
67 NADA diesel tremec 4spd salisbury rear springs on front and a LOT MORE TO GO.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old August 28th, 2012, 09:27 AM
Tyler Wirken
Status: Offline
Tyler Wirken
1997 Defender 90 LE
Member
 
Join Date: May 2007
Location: Kansas City, Mo
Posts: 696
I am not an expert on 3.9 inner workings but it sounds like an ECU to me.

On my 1997 I know the ECU controls the grounds on lots of things so that leads me to believe that might be related.

What is weird though is the fact that there is no power to the fuse.
Reply With Quote
  #5  
Old August 28th, 2012, 02:56 PM
aka rover's Avatar
aka rover
Status: Offline
ed angel
95 D90
Member
 
Join Date: Dec 2010
Location: Anchorage Alaska
Posts: 1,132
Registry
Quote:
Originally Posted by Tyler Wirken View Post
I am not an expert on 3.9 inner workings but it sounds like an ECU to me.

On my 1997 I know the ECU controls the grounds on lots of things so that leads me to believe that might be related.

What is weird though is the fact that there is no power to the fuse.

Yea thats what I thought as well on the fuse, im trying to figure out where the fuse gets its power im still looking for a wire diagram. I have been busy on other projects and haven't given the 90 the attention. I was thinking the fuse power was switched power from the ignition switch, but unsure till I see a schematic.

Ed
__________________
95 D90 SW 4.6 ARBs 8274 37" BFGs Gigglepin twin motor 8274
94 D90 ST R380 constine green stock
85 D110 3.5 3 DR
67 NADA diesel tremec 4spd salisbury rear springs on front and a LOT MORE TO GO.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
  #6  
Old August 29th, 2012, 10:11 AM
rovertek's Avatar
rovertek
Status: Offline
chris
D130, 2001+99 p38
Member
 
Join Date: Jul 2012
Location: Long Island , New York
Posts: 500
Theres ignition power at the fuel pump relay..the ecu sends a signal to trip the relay which sends 12v to the fuel pump fuse and inertia switch....i went down the same road couple days ago ...found bad fuel pump relay...and cleaned all grounds ....if you come up with somthing else let us know
__________________
No Mall crawler here
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
fuel

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
td5 fuel pump in a 300tdi Muscat Defender Technical Discussions 11 April 8th, 2010 10:35 AM
Carter Fuel Pump steinhnj Defender Technical Discussions 3 October 7th, 2008 05:40 PM
Fuel Pump Fuse Blows all the Time now! thug1313 Defender Technical Discussions 9 March 2nd, 2006 07:55 PM
Fuel Pump noise Campbell Defender Technical Discussions 3 December 9th, 2004 10:08 AM
Fuel Pump / Sender 95 D-90 Nigel Buchan For Sale - Parts 1 November 20th, 2003 11:03 PM


All times are GMT -5. The time now is 02:58 PM.


Copyright