Alternator Problem? - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old May 3rd, 2012, 08:18 PM
hamiamham
Status: Offline
mike
97 D-90
Member
 
Join Date: Mar 2007
Location: New York City
Posts: 190
Alternator Problem?

I have a 1997 D-90. When I first start her up the red idiot light with the battery symbol in it lights up and typically stays on for several mins. During this time the tach doesn't work and - of course - the amps indicator is also dead. Any ideas? It always goes off after a period of time and I have not - till this point - had any issues starting the truck or anything.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old May 3rd, 2012, 08:48 PM
o2batsea's Avatar
o2batsea
Status: Offline
Bill Adams
66 109 sw 94 lwb
Member
 
Join Date: Jul 2009
Location: kensington md
Posts: 6,506
Registry
Have your battery load tested
__________________
Bill Adams

1966 109 5 door wagon 300Tdi "spermaceti fueled"
1994 RRC LeWiB "ruining the air behind me"
1968 2A 88

All my troubles are Rover
Reply With Quote
  #3  
Old May 3rd, 2012, 09:32 PM
Jymmiejamz's Avatar
Jymmiejamz
Status: Offline
Jimmy
1995 D90 SW #365
Member
 
Join Date: Sep 2010
Location: Brooklyn, NY
Posts: 3,468
Registry
Check the connections on the back of the alternator. I had the same issue on mine because the main power cable bolt from the alternator had fallen off creating a weak connection.
__________________
Car Camping Collective founding member and Treasurer
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old May 3rd, 2012, 10:46 PM
Rocky's Avatar
Rocky
Status: Offline
Chris
72 + D1 drivetrain
Member
 
Join Date: Sep 2006
Location: Colonies Aka Boston
Posts: 8,795
If connection is fine get a replacement alternator
__________________
A friend of mine runs a land rover / range rover specialty repair shop. Based on his experience, they are capable of stopping anywhere, anytime, at any cost.

I don't know about the brakes, only their unreliability.
Reply With Quote
  #5  
Old May 4th, 2012, 08:55 PM
hamiamham
Status: Offline
mike
97 D-90
Member
 
Join Date: Mar 2007
Location: New York City
Posts: 190
will try all of the above. thanks gents.
Reply With Quote
  #6  
Old May 5th, 2012, 05:30 AM
maleger
Status: Offline
Marc-Andre Leger
94D90 CDN#18 http://rover.leger.ca
Member
 
Join Date: May 2010
Location: Montreal, Quebec, Canada
Posts: 395
Registry
I had a similar problem with a loose pulley on the alternator.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
alternator

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 01:54 PM.


Copyright