Almost had electical fire..now what? - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old December 26th, 2009, 01:56 PM
Campbell's Avatar
Campbell
Status: Offline
Rich Campbell
06 LR3 01DII D90s sold
Member
 
Join Date: Oct 2003
Location: PA
Posts: 1,512
Registry
Almost had electical fire..now what?

I have a 97sw. A few days ago it started acting strange. My inside lights would swich on and off with the brake pedal. Just as I pulled in my garage it started acting even stranger. I turned the key off but the 90 stayed on. The brake lights also stayed on. Then white smoke started pouring out of the instrument panel in the sw where the rear wiper/reAr window defogger. I quicky pulled the power to the truck and pulled the instrament panel...there is a small off white box inside the panel that was melting and has some flames on it..the connectors are toast!! Had to snipp all the wires and remove the box. Got very!!!! Lucky on this one..
What the he'll is this and what do you guys think could have caused it?
Thanks
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old December 26th, 2009, 05:03 PM
Campbell's Avatar
Campbell
Status: Offline
Rich Campbell
06 LR3 01DII D90s sold
Member
 
Join Date: Oct 2003
Location: PA
Posts: 1,512
Registry
Box

No one knows what this box is that went to toast...I removed it and can still start the 90 but the brake lights are stuck on

Follow-up Post:

One other thing. I hooked up the battary again and the brake lights are on without hiring the pedal. Also when I press the pedal the warning lights come on and the auto trans lights.

Follow-up Post:

Sorry for all the typos.... Using my iPhone
Reply With Quote
  #3  
Old December 26th, 2009, 06:03 PM
JimC's Avatar
JimC
Status: Offline
Jim Cheney
NAS 110 #145
Site Team
 
Join Date: Sep 2003
Location: Stuttgart, Germany
Posts: 7,154
Registry
Its the multi function box or "courtesy computer" which controls the rear wiper delay and assorted other stuff. Should be easy to replace if you salvage the harness and splice it back in.
__________________
Jim Cheney

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old December 26th, 2009, 07:33 PM
Campbell's Avatar
Campbell
Status: Offline
Rich Campbell
06 LR3 01DII D90s sold
Member
 
Join Date: Oct 2003
Location: PA
Posts: 1,512
Registry
Thanks....any ideas to what could have caused it and why I'm having electrical issues now with the brake lights ect..

Follow-up Post:

Anyone have one for a 97...I would need the plugs also since they melted..Thanks again for the help..the thing actually lit on fire!
Reply With Quote
  #5  
Old December 26th, 2009, 07:34 PM
JimC's Avatar
JimC
Status: Offline
Jim Cheney
NAS 110 #145
Site Team
 
Join Date: Sep 2003
Location: Stuttgart, Germany
Posts: 7,154
Registry
I don't know a lot about the 97 set up - I assume it had a short, went bad, or otherwise failed. Multi function switches don't exactly have the same rep as oil lines...

Anyhow, that box controls a variety of things, and might share a ground with other switches. Just need to find a diagram and suss it out, or maybe a 97 guru will pipe up.
__________________
Jim Cheney

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
  #6  
Old December 26th, 2009, 07:46 PM
Campbell's Avatar
Campbell
Status: Offline
Rich Campbell
06 LR3 01DII D90s sold
Member
 
Join Date: Oct 2003
Location: PA
Posts: 1,512
Registry
Thanks Jim ...my harness is melted so not sure what the hell I'm going to do. I can't drive it because my brake litghs are stuck on..
Any help would be really appreciated...does anyone know where I could find one of these with the harness as well
Reply With Quote
  #7  
Old December 26th, 2009, 07:56 PM
evilfij's Avatar
evilfij
Status: Offline
evilfij
I have never seen a rover in person
Member
 
Join Date: Oct 2003
Location: on the internet
Posts: 14,688
If you unplug the brake light switch on the pedal does it make teh brake lights go out? There are a limited number of wires that control the brake lights

Frankly, this one is beyond what I have encountered. If it gets beyond what you can do, it is time to call in the big guns and get frank (www.roverrepairs.com who I think you have met) to work on it.
__________________
*not legal advice*
Reply With Quote
  #8  
Old December 26th, 2009, 08:11 PM
Campbell's Avatar
Campbell
Status: Offline
Rich Campbell
06 LR3 01DII D90s sold
Member
 
Join Date: Oct 2003
Location: PA
Posts: 1,512
Registry
Frank is great. I have used him a few times. I was hoping to try to fix this myself...if I can't that is where it is going. Does anyone even know where I can get this part??

Follow-up Post:

I also can't seem to find a list of the items this computer controls.
Reply With Quote
  #9  
Old December 26th, 2009, 08:20 PM
TDI Guy's Avatar
TDI Guy
Status: Offline
Randy
2015 LR4
D-90 Source Vendor
 
Join Date: Sep 2003
Location: NJ
Posts: 4,573
Registry
I think RDS HAS A NEW Harness if you need one
__________________
Legend in My Own Mind.
Reply With Quote
  #10  
Old December 26th, 2009, 08:49 PM
Campbell's Avatar
Campbell
Status: Offline
Rich Campbell
06 LR3 01DII D90s sold
Member
 
Join Date: Oct 2003
Location: PA
Posts: 1,512
Registry
Do you think I will need to replace the whole harness? Also does anyone know that this computers part number is?

Thanks again for all the help
Reply With Quote
  #11  
Old December 26th, 2009, 08:51 PM
evilfij's Avatar
evilfij
Status: Offline
evilfij
I have never seen a rover in person
Member
 
Join Date: Oct 2003
Location: on the internet
Posts: 14,688
Does it have a part number on it? IIRC someone else on here was looking for one. Alas, in my stash I do not [think] I have one.
__________________
*not legal advice*
Reply With Quote
  #12  
Old December 26th, 2009, 09:25 PM
Campbell's Avatar
Campbell
Status: Offline
Rich Campbell
06 LR3 01DII D90s sold
Member
 
Join Date: Oct 2003
Location: PA
Posts: 1,512
Registry
I can't see anything on it...it is toast. I will check again tomorrow.
Hopefully I can find one that was cut out with the harness ends. I can then just splice it in and be done with it...
I have to find the part number first.

Follow-up Post:

Based on the wiring dia. Someone posted in a previous post it looks like I need:
multi function ecu d130.
Can anyone help me confirm this and where to find it
Reply With Quote
  #13  
Old December 27th, 2009, 09:17 AM
junkyddog11's Avatar
junkyddog11
Status: Offline
oil soaked filter
95 RRC 300tdi
Member
 
Join Date: Mar 2006
Location: No. Berwick, Maine
Posts: 1,253
Might want to find out why the brake light s are still coming on before you start splicing.

I'd look at all the wiring in the rear of the tub and at the back lights. I've had several '97's with some really weird shit going on like massive radio interference with the brake lights, reverse lights that come on with the radio, shorted trailer wiring that burned wires all the way up to the dash, reverse light that burned wires all the way to the dash. All the results of shorted wires in the rear of tub, sometimes the trailer pigtail, sometimes just grommets that have fallen off and wires chaffed through.
__________________
Matt Browne


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
new expansion complete. Not only are we the only Rover shop in Eliot Maine...now we're also the biggest.

"Dedicated to the resurrection of junk through engineering?"
Reply With Quote
  #14  
Old December 27th, 2009, 10:22 AM
Campbell's Avatar
Campbell
Status: Offline
Rich Campbell
06 LR3 01DII D90s sold
Member
 
Join Date: Oct 2003
Location: PA
Posts: 1,512
Registry
Thanks for all the help... I will let you know how I make out!
Reply With Quote
  #15  
Old December 27th, 2009, 11:20 AM
woldd90's Avatar
woldd90
Status: Offline
Scott
1997 D90 ST #1444
Site Team
 
Join Date: Aug 2005
Location: Georgia
Posts: 5,329
I will check out the electrical manuals I have when I get back in town.
__________________
Scott

Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
fire

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Yet another engine fire chrisvonc Misc. Chit-Chat 80 August 30th, 2005 02:22 PM
NEED HELP starter fire!! steved90 Defender Technical Discussions 8 July 8th, 2005 04:33 PM
Fire Fighter Mike Hippert Misc. Chit-Chat 9 May 4th, 2005 01:15 PM
Fire Extigushers rover4x4 Defender Technical Discussions 20 March 18th, 2005 12:24 PM
Recommendation on a Fire Extinguisher - size, type, mounting, etc. COSteve Defender Technical Discussions 16 April 16th, 2004 02:21 AM


All times are GMT -5. The time now is 08:27 AM.


Copyright