AC stopped working. - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old September 22nd, 2010, 09:09 PM
TxEddie1111's Avatar
TxEddie1111
Status: Offline
Eddie
Discovery
Member
 
Join Date: Sep 2010
Location: Houston, Tx USA
Posts: 11
AC stopped working.

My AC just quit working when I stopped and then restarted after a store visit. It appears to be electrical. I dont see an "AC" fuse name labled in the box.
Any help would be appreciated.

Thanks!

Eddie
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old September 22nd, 2010, 11:02 PM
JFD's Avatar
JFD
Status: Offline
Julien Dalbin
05 Tdi 90
Member
 
Join Date: Mar 2005
Location: Dominican Republic
Posts: 1,888
stop cooling ? stop blowing ? can you hear the compressor clutch engaging ? you have to be a little more specific.
__________________
" Eventually everything connects - people, ideas, objects. The quality of the connections is the key to quality per se. "
- Charles Eames
Reply With Quote
  #3  
Old September 23rd, 2010, 08:09 AM
TxEddie1111's Avatar
TxEddie1111
Status: Offline
Eddie
Discovery
Member
 
Join Date: Sep 2010
Location: Houston, Tx USA
Posts: 11
JFD, thanks and you are right. There was simply "nothing" no clicks, sounds, nada.
AND, since I am in Houstonn and no AC is just not an option, late last night, I unscrewed the bracket where the two AC control switches are mounted and the "on/off, fan speed" switch had a wire that had come off the terminal; re-attached it and presto, AC again.

So I am good.

However, that particular wire terminal was "burnt" looking and a bit melted; obviously had heat to it. It didnt appear as though this just happened (dusty, etc) but posibly was happening over a long haul. Any thoughts? Normal? Problem brewing? Need replacing?

Thanks!

Eddie
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old September 23rd, 2010, 09:28 AM
Overlander's Avatar
Overlander
Status: Offline
mark kellgren
in between D's in an 04 D2
Member
 
Join Date: Mar 2006
Location: Charlotte, NC
Posts: 6,531
Registry
Quote:
Originally Posted by TxEddie1111 View Post
JFD, thanks and you are right. There was simply "nothing" no clicks, sounds, nada.
AND, since I am in Houstonn and no AC is just not an option, late last night, I unscrewed the bracket where the two AC control switches are mounted and the "on/off, fan speed" switch had a wire that had come off the terminal; re-attached it and presto, AC again.

So I am good.

However, that particular wire terminal was "burnt" looking and a bit melted; obviously had heat to it. It didnt appear as though this just happened (dusty, etc) but posibly was happening over a long haul. Any thoughts? Normal? Problem brewing? Need replacing?

Thanks!

Eddie
Our A/C system is heavily dependent on neg pwr resistance signals to control everything right. I have a bad connection throwing the A/C ECU off. I would replace that connector. pop it out, put a new end on it, and push back in.l
Reply With Quote
  #5  
Old September 23rd, 2010, 11:57 AM
JFD's Avatar
JFD
Status: Offline
Julien Dalbin
05 Tdi 90
Member
 
Join Date: Mar 2005
Location: Dominican Republic
Posts: 1,888
what he said and check your fuses for the right amps too.
__________________
" Eventually everything connects - people, ideas, objects. The quality of the connections is the key to quality per se. "
- Charles Eames
Reply With Quote
  #6  
Old September 23rd, 2010, 03:27 PM
TxEddie1111's Avatar
TxEddie1111
Status: Offline
Eddie
Discovery
Member
 
Join Date: Sep 2010
Location: Houston, Tx USA
Posts: 11
Awesome, thanks guys.

Eddie
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
ac

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
AC Compressor and Blower Just Stopped Raleigh D90 Defender Technical Discussions 8 September 3rd, 2013 03:58 AM
Indicators stopped working ... leastonce Defender Technical Discussions 1 November 2nd, 2009 10:25 AM
NAS 90 Used AC System early 95 working SafariHP The Vendors Loft 0 October 26th, 2009 08:36 AM
Complete working AC system off of a 1995 D90 evilfij For Sale - Parts 18 June 7th, 2009 09:06 PM
95 AC complete and working evilfij For Sale - Parts 7 October 4th, 2004 03:55 PM


All times are GMT -5. The time now is 05:41 AM.


Copyright