97 throwing P1178 code and tickig from behind the dash - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Join the Defender Source Community Today

Thread Tools
Old April 20th, 2015, 12:31 AM
Crash303's Avatar
Status: Offline
Josh Harris
97/ D90 ST #1190
Join Date: Apr 2009
Location: Jamul, CA, USA
Posts: 179
97 throwing P1178 code and tickig from behind the dash

So I'm having issues with my 97 NAS. It started a couples weeks ago, a day or two after offroading in wet and muddy conditions. It started with a ticking noise started behind the dash like I have my hazard lights on. The noise is on all time regardless of the ignition on or off. Also the check engine light came on with P1178 code. The truck started running very rough at idle, but ran okay speed. With the live feed from the code scanner I noticed the MAF sensor was not giving any feed.

So far I took a part the dash and found that the ticking is coming from the relay in the little green box behind speedo or 10AS immobilization module. I remove fuse 3 from the main fuse box in the engine compartment, which stop the ticking. Although now and then the truck will immobilize and will not start, but with a quick switch on the battery disconnect I can start the truck again. I have replaced the battery and the Mass Airflow sensor. I have checked and cleaned the main grounds throughout truck. I checked to see if the MAF connector had voltage and good ground. But I left it disconnected and the truck seems to be running okay and has not thrown a code yet.

If anyone has any other ideas it would be much appreciated.

When the F*%# did we get Ice cream!!!

"They are, in factory original condition, noisy, they leak water in from the top and oil out from underneath, you can never demist the windows in winter, they handle like scaffolding towers, and use more fuel than Beijing." Richard Hammond
Reply With Quote
Old April 20th, 2015, 06:17 AM
Status: Offline
1997 D90 SW
Join Date: May 2012
Location: NY
Posts: 298
I have that same ticking noise/green box issue but mine comes and goes every couple months - usually just turn the truck off and back on again and it stops - it does not stop if I just turn the truck off. Past searches on this site offered no fix and since it always stops with that trick - I haven't bothered to research further.

Would love to know as well what the permanent fix for it is.

No codes thrown BTW when it clicks.

Reply With Quote
Old April 20th, 2015, 06:41 AM
1of40's Avatar
Status: Offline
NAS 97SW & 83 One Ten Tdi
Join Date: Dec 2003
Location: Potomac Falls & Wintergreen, Virginia
Posts: 4,788
This is somewhat of a long shot but a shop in Bethesda Md called Independent Land Rover specialists seem to have dealt with some odd issues re customer 97NAS trucks. Might give them a call and ask for Dean. Nice guy and busy as hell but will stop to help if/when he can.

Reply With Quote

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

97, dash, wing

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
WTT: Tuffy and throwing in kevincdoyle Wanted 11 March 5th, 2014 02:10 PM
Code p1178 Campbell Defender Technical Discussions 4 September 15th, 2012 09:42 PM
Running rich without throwing codes vesparover Defender Technical Discussions 8 January 20th, 2009 04:05 PM
Code P1178 NashvilleRedD90 Defender Technical Discussions 1 July 2nd, 2007 11:56 AM
Throwing up - flu or the new Jeep Defender paulb Misc. Chit-Chat 15 October 22nd, 2006 10:12 PM

All times are GMT -5. The time now is 09:13 AM.