97 Starting problem - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Join the Defender Source Community Today

Thread Tools
Old May 18th, 2011, 12:03 PM
Campbell's Avatar
Status: Offline
Rich Campbell
06 LR3 01DII D90s sold
Join Date: Oct 2003
Location: PA
Posts: 1,514
97 Starting problem

Just wondering if this has happened to anyone else.

My 90 has trouble starting. It cranks but doesn't start all the time. more so when hot. New fuel pump has been installed. Also the front condensor fan isn't coming on. Bypassed the ecm and it came on so my mechanic thought it was the ECM.... but put a another ECM from a 96 Disco and the same problem is happening.

Any ideas?

Great place to buy Rover parts: www.europeanpartsllc.com
Reply With Quote
Old May 18th, 2011, 12:41 PM
evilfij's Avatar
Status: Offline
I have never seen a rover in person
Join Date: Oct 2003
Location: on the internet
Posts: 14,553
How about the coolant temp sensor? Does it start when you put your foot on the gas while cranking? Does it sputter and try to start? Do you smell raw fuel while/after cranking?


PS I will give you 12k for her as she sits.
*not legal advice*
Reply With Quote

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

97, start, starting

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting problem (occassionally) kolvedic Defender Technical Discussions 21 January 21st, 2012 11:12 AM
Intermittent Starting Problem 61rover Defender Technical Discussions 0 September 24th, 2010 12:50 PM
Hot starting problem that won't go away. lostindecoland Defender Technical Discussions 8 February 27th, 2010 10:53 PM
Help! Problem starting (95 SW) reaper99999 Defender Technical Discussions 8 March 2nd, 2006 07:22 PM
Odometer problem 97 jorge Defender Technical Discussions 3 November 19th, 2003 01:13 AM

All times are GMT -5. The time now is 11:11 AM.