'97 NAS turns over then stalls - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old January 24th, 2016, 04:48 PM
smob's Avatar
smob
Status: Offline
Steve
'97 Arles Blue SW #2131
Member
 
Join Date: Aug 2008
Location: Mclean, VA
Posts: 1,619
Registry
'97 NAS turns over then stalls

In the middle of the snow - sometimes turning the key will get the starter going, sometimes not.. when it does turn over, it holds the idle for 1-4 seconds, then dies. Fuel pump seems to be working (can hear it). Any ideas? Yes, I searched the forum and found very little that was 97 specific. Thanks.

Edit: sometimes power doesn't even go on when I turn the key, which might be another problem altogether. Blah.
__________________
"Land Rover = rolling mechanical failure. it is failing even as it sits in the driveway. get used to it. My 90 just had a failure as I was typing this."
-Ren Ching
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old January 24th, 2016, 04:52 PM
phoenix37's Avatar
phoenix37
Status: Online
john
97 D90 ST / 1957 S1 109/ 1983 LS110
Member
 
Join Date: Feb 2008
Location: Venice, CA/Yarmouth,ME
Posts: 5,789
Registry
its happened to me with my 95 LWB...some dry gas cleared it up... maybe clogged fuel filter or a pump on its last leg.
Reply With Quote
  #3  
Old January 24th, 2016, 04:56 PM
smob's Avatar
smob
Status: Offline
Steve
'97 Arles Blue SW #2131
Member
 
Join Date: Aug 2008
Location: Mclean, VA
Posts: 1,619
Registry
Quote:
Originally Posted by phoenix37 View Post
its happened to me with my 95 LWB...some dry gas cleared it up... maybe clogged fuel filter or a pump on its last leg.
Hmm.. Good idea. Pump was replaced recently but not filter. I'll try to get some new gas in it.
__________________
"Land Rover = rolling mechanical failure. it is failing even as it sits in the driveway. get used to it. My 90 just had a failure as I was typing this."
-Ren Ching
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old January 24th, 2016, 05:06 PM
genie90's Avatar
genie90
Status: Online
Jay Geaney
1994 D-90 ST #282
Member
 
Join Date: Oct 2010
Location: Little Rock, AR, USA
Posts: 814
Mine's a '94 but same symptoms and it was an ignition switch.

Good luck,
Jay
Reply With Quote
  #5  
Old January 24th, 2016, 07:32 PM
kevincdoyle's Avatar
kevincdoyle
Status: Offline
Kevin C. Doyle
1995 NAS D90 Coniston Green SW
Member
 
Join Date: Nov 2003
Location: Tulsa, OK USA
Posts: 864
Registry
Quote:
Originally Posted by genie90 View Post
Mine's a '94 but same symptoms and it was an ignition switch. Good luck, Jay
Second this...

------ Follow up post added January 25th, 2016 12:33 AM ------

Quote:
Originally Posted by kevincdoyle View Post
Second this...
Very easy, inexpensive fix...prolly needs to be done anyway...
__________________
Attributed to Shayne...

"I actually like to paint some of my smaller parts......"
Reply With Quote
  #6  
Old January 24th, 2016, 07:45 PM
smob's Avatar
smob
Status: Offline
Steve
'97 Arles Blue SW #2131
Member
 
Join Date: Aug 2008
Location: Mclean, VA
Posts: 1,619
Registry
Quote:
Originally Posted by kevincdoyle View Post


Very easy, inexpensive fix...prolly needs to be done anyway...
Got one on order from Trevor.. I have this odd feeling that when I left the truck idling for an hour in the snow, the heat (which is busted) heated up inside the dash and caused the burning that I smelled.. guessing that was from the ignition switch melting. I'll swap this in later in the week and whine again if it didn't work.
__________________
"Land Rover = rolling mechanical failure. it is failing even as it sits in the driveway. get used to it. My 90 just had a failure as I was typing this."
-Ren Ching
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
97, nas

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1986 17H Turns Over But Won't Start willhahn24 Defender Technical Discussions 0 September 13th, 2014 11:14 AM
300TDI stalls, then cable restarted in a minute Earlclue Defender Technical Discussions 0 December 6th, 2013 05:47 PM
RPMs die, then vehicle stalls at next light. sro Defender Technical Discussions 19 November 22nd, 2012 09:23 PM
Engine turns over when shutting off usadventureracing Defender Technical Discussions 4 June 24th, 2012 10:49 AM
Engine turns over but won't start bd90 Defender Technical Discussions 9 August 8th, 2008 12:22 PM


All times are GMT -5. The time now is 07:58 PM.


Copyright