'97 D90 Starting Problems - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old June 22nd, 2012, 03:58 AM
Architect
Status: Offline
David Crumley
NAS D90
Member
 
Join Date: Jan 2009
Location: Jackson, MS USA
Posts: 9
Exclamation '97 D90 Starting Problems

I own a '97 D90 with 60,000 miles. It's had trouble starting lately and there seems to be no pattern as to when it will or will not. Here's what I can tell you about the issue: The plugs/ wires have been replaced, fuel relay module replaced, fuel pump removed and reinstalled. We have fuel in the fuel rail 100% of the time even first thing in the mornings. The battery is strong and turns the motor over fast.
Sometimes the truck will start right up but after a short drive if you turn it off it will not start back up. After some trying it may start but will not hold an idle so you have to hold your foot on the gas to keep it running and drive like hell to get back home.
It does not appear to be a fuel issue but rather a sensor or electronic issue??? It always has fuel in the rail even when it won't start. Could it be the motor stepper module? The problem seems to occur when its hot. Any help would be appreciated.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old June 22nd, 2012, 06:26 AM
navydevildoc's Avatar
navydevildoc
Status: Offline
Neill Thornton
1984 D90 300 Tdi / 1965 Series IIA
Site Team
 
Join Date: Nov 2010
Location: San Diego, CA
Posts: 1,586
Registry
I don't have one of these engines, but isn't this the Idle Air Control Valve... i.e. the stepper motor?

Is the check engine light coming on?
Reply With Quote
  #3  
Old June 23rd, 2012, 11:36 PM
Architect
Status: Offline
David Crumley
NAS D90
Member
 
Join Date: Jan 2009
Location: Jackson, MS USA
Posts: 9
97 d90

Thanks navydevildoc,

I'll look at the check engine light again in the morning. It has really baffled me.
Thanks for your help.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old June 23rd, 2012, 11:49 PM
brettm's Avatar
brettm
Status: Offline
Brett
97 D90-SW, Arles +4.6
Member
 
Join Date: Dec 2010
Location: seattle, wa
Posts: 187
this plagued me for a while... the stepper motor replacement (cheap part - see below) made it better for a while, but it came back. eventually turned out to be two simple rubber vacuum hoses:

http://www.defendersource.com/forum/...ad.php?t=36316

pull them off and inspect them for gunk / ageing rubber - if either, replace them.

for the Stepper/IACV, I used this cheap Napa part:

http://www.napaonline.com/Catalog/Ca...856_0169845638
Part #: CRB 21856, about $60.

If neither of those work, there are a LOT of other threads here that go into other possible conditions...
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
90, 97, 97 d90, d90, problems, start, starting

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
97 D90 Owners tallest1 Misc. Chit-Chat 1 July 28th, 2009 12:34 AM
97 d90 hummer16 Defender Technical Discussions 4 November 24th, 2005 06:25 PM
D90 won't start! rover4x4 Defender Technical Discussions 32 June 13th, 2005 08:42 AM
headers for '97 D90 mdmccallum Defender Technical Discussions 43 April 25th, 2005 10:23 AM
For Sale: '97 D90 ST-1791 Alpine White jwebster For Sale - Vehicles 0 September 30th, 2003 12:36 AM


All times are GMT -5. The time now is 01:53 PM.


Copyright