94 D90 ST starting to die? - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old February 5th, 2011, 02:28 PM
discoinjapan's Avatar
discoinjapan
Status: Offline
Michael Bruzga
93 D1/ 94 D90 ST/96 D1
Member
 
Join Date: Mar 2009
Location: Yokosuka, Japan VIA PA
Posts: 149
94 D90 ST starting to die?

Well the 90 wouldnt start for me this morning. I think the injectors are leaking and it sounded as if it were flooded. Finally started after about 8 tries. Then, went to open the hood and the cable isnt catching and it wont release the hood lock. So I went to do my chores and it ran fine but the speedo stopped and it is just clicking!!

Soooo... How can I get the hood opened when the cable is not unlatching it? And how do I check the speedo?
I have some yellow top ford injectors I can throw in there for the the first problem.

As always thanks in advance!
Mike
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old February 5th, 2011, 04:32 PM
cgalpin's Avatar
cgalpin
Status: Offline
Charles Galpin
'94 D90 ST, '63 SeriesIIA
Site Team
 
Join Date: Jan 2004
Location: South Riding, VA
Posts: 11,625
Registry
Remove the black plastic grill and you can get to the latch mechanism, or at the very least trigger it by pulling on the cable (look to the left of the latch when looking at the radiator).

The speedo can be checked by undoing the instrument cluster and carefully pulling it out a bit so you can see behind the speedo. The cable should be connected to the back of the speedo. If it is connected, you can disconnect and drive and check the inner cable is turning. If not, it's a two piece unit and could be either one. One goes from the transfer case to the vss (vehicle speed sensor), the other from the vss up to the speedo. The vcc is on the inner side of the frame below the driver.

Make sure the injectors are the right ones (right pressure).

hth
charles
__________________
Quote:
Originally Posted by pendy
I'm here for the D's
Reply With Quote
  #3  
Old February 5th, 2011, 05:01 PM
discoinjapan's Avatar
discoinjapan
Status: Offline
Michael Bruzga
93 D1/ 94 D90 ST/96 D1
Member
 
Join Date: Mar 2009
Location: Yokosuka, Japan VIA PA
Posts: 149
Thank you! much appreciated!
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old February 5th, 2011, 05:09 PM
James Pierce's Avatar
James Pierce
Status: Offline
James Pierce Jr.
1995 D90 SW #314, 59 SII 88 HT
Member
 
Join Date: Nov 2003
Location: Oklahoma
Posts: 797
^^^ good advice. Before you pull the grill you might have someone pull and hold the hood release cable out while you try pushing down and lifting up on the hood. If that doesn't work you'll have to pull the grill.

If the speedo is clicking it probably has a stripped gear. You can get a new one from RDS for $195 or have yours repaired. When you pull the cable off the back of the speedometer try turning it with your fingers. If it spins freely chances are its just a broken cable. There are two as described ^^^

When it rains it pours
Reply With Quote
  #5  
Old February 6th, 2011, 08:06 AM
discoinjapan's Avatar
discoinjapan
Status: Offline
Michael Bruzga
93 D1/ 94 D90 ST/96 D1
Member
 
Join Date: Mar 2009
Location: Yokosuka, Japan VIA PA
Posts: 149
Quote:
Originally Posted by jamespierce View Post
^^^ good advice. Before you pull the grill you might have someone pull and hold the hood release cable out while you try pushing down and lifting up on the hood. If that doesn't work you'll have to pull the grill.

If the speedo is clicking it probably has a stripped gear. You can get a new one from RDS for $195 or have yours repaired. When you pull the cable off the back of the speedometer try turning it with your fingers. If it spins freely chances are its just a broken cable. There are two as described ^^^

When it rains it pours

The screw that secures the cable end to the latch is loose so pulling on the cable wont work. Im just going to have to pull the grill. The speedo, its clicking in sync with the truck speed so the cable is working, must be a gear inside.

funny, it was raining yesterday....
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
90, d90, start, starting

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
94 D90 not starting - New post / poster Kilgore503 Say Hello! New Member Intros. 17 January 29th, 2009 02:38 AM
94 d90 st krisp For Sale - Vehicles 11 April 8th, 2005 07:08 PM
Help With Starting My D90! Davis Defender Technical Discussions 0 September 7th, 2004 05:13 PM
94' D90 ST, 55k miles LOWERED to 21.7k or BEST OFFER in CT. PIX link januconn92 For Sale - Vehicles 1 March 15th, 2004 09:46 PM
94' D90 ST, 55k miles, 23.5k or Best Offer in CT. januconn92 For Sale - Vehicles 0 February 22nd, 2004 04:16 PM


All times are GMT -5. The time now is 03:37 AM.


Copyright