300TDi won't start - Page 2 - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #21  
Old February 19th, 2014, 12:37 PM
IvanKV's Avatar
IvanKV
Status: Offline
Ivan
'89 110 County - 200TDi
Member
 
Join Date: Aug 2013
Location: Durham, NC
Posts: 227
Registry
Well she started today.
I moved a weird metal stick thing that was on the rear of the radiator, I doubt they are related.
Reply With Quote
Sponsored Links
Advertisement
 
  #22  
Old February 19th, 2014, 02:02 PM
TDI Guy's Avatar
TDI Guy
Status: Offline
Randy
2015 LR4
D-90 Source Vendor
 
Join Date: Sep 2003
Location: NJ
Posts: 4,573
Registry
Could be the relay on the starter sticking as well.
__________________
Legend in My Own Mind.
Reply With Quote
  #23  
Old February 19th, 2014, 02:17 PM
IvanKV's Avatar
IvanKV
Status: Offline
Ivan
'89 110 County - 200TDi
Member
 
Join Date: Aug 2013
Location: Durham, NC
Posts: 227
Registry
Annnd we are back to not starting...
I try the key, the lights dim, radio goes off, there is a click sound from the passenger foot well and nothing from the engine.
Going to push start it tomorrow after classes and take it too my local LR shop, he said he would diagnosis the problem. Then I can fix it this weekend
Reply With Quote
Sponsored Links
Advertisement
 
  #24  
Old February 19th, 2014, 02:23 PM
Red90's Avatar
Red90
Status: Offline
John B.
1991 Defender 90, 200TDI
Site Team
 
Join Date: Sep 2003
Location: Calgary
Posts: 9,231
Registry
You should be parking facing downhill....
__________________
Pissing people off on the "net" since 1983.

Land Rover. Turning owners into mechanics since 1948.
Reply With Quote
  #25  
Old February 19th, 2014, 02:25 PM
down_shift's Avatar
down_shift
Status: Offline
Russell
94' D90 ST & 06' LR3
Member
 
Join Date: Sep 2011
Location: Leesburg, VA
Posts: 4,118
Registry
When the motor does not turn over, is it noticeably colder at that time.
Reply With Quote
  #26  
Old February 19th, 2014, 02:30 PM
Gren_T's Avatar
Gren_T
Status: Offline
Gren Thomas
1985 90 300tdi auto
Member
 
Join Date: Feb 2005
Location: bridgend, wales , UK
Posts: 413
Hi Ivan,
I'm assuming its a manual trans, if when you turn the key you get nothing I would try holding the starter relay you should feel it bump slightly as it engages if it don't try pulling it and re-seating it in case the contacts are corroded, if you can feel it bump try removing and reconnecting the starter cables at the starter solenoid - dis-connect the battery 1st.!!

to test the earth connection when it is not starting clamp a jump lead to the engine and then to battery -ve then try starting.

a quick check see if it's a bad connection in the starter solenoid is to put headlights on and try to start it, if the lights dim then current is getting to the starter but the contacts are bad - easy to clean with basic toolkit and some common sense.

still problems - buy a cheap test lamp and we can go from there.

regards all
Gren
Reply With Quote
  #27  
Old February 19th, 2014, 02:31 PM
IvanKV's Avatar
IvanKV
Status: Offline
Ivan
'89 110 County - 200TDi
Member
 
Join Date: Aug 2013
Location: Durham, NC
Posts: 227
Registry
Quote:
Originally Posted by Red90 View Post
You should be parking facing downhill....
This is Oklahoma...what is a hill?
Reply With Quote
  #28  
Old February 19th, 2014, 02:34 PM
Gren_T's Avatar
Gren_T
Status: Offline
Gren Thomas
1985 90 300tdi auto
Member
 
Join Date: Feb 2005
Location: bridgend, wales , UK
Posts: 413
Ivan you've covered some of my points while i was 1 finger typing my diatribe.. looks like bad starter solenoid.. about 14 replacement here

regards
Gren
Reply With Quote
  #29  
Old February 19th, 2014, 02:45 PM
IvanKV's Avatar
IvanKV
Status: Offline
Ivan
'89 110 County - 200TDi
Member
 
Join Date: Aug 2013
Location: Durham, NC
Posts: 227
Registry
Quote:
Originally Posted by Gren_T View Post
Ivan you've covered some of my points while i was 1 finger typing my diatribe.. looks like bad starter solenoid.. about 14 replacement here

regards
Gren
Cheers! Will order one
Reply With Quote
  #30  
Old February 21st, 2014, 10:30 PM
IvanKV's Avatar
IvanKV
Status: Offline
Ivan
'89 110 County - 200TDi
Member
 
Join Date: Aug 2013
Location: Durham, NC
Posts: 227
Registry
It was a bad relay, all sorted.
Thanks for the help and suggestions.

Cheers!
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
300tdi, start, tdi

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
300TDI smoking on start up graham Defender Technical Discussions 7 February 2nd, 2017 04:50 PM
300Tdi intermittent start issue - starter or main chassis ground? nathanwind Defender Technical Discussions 30 February 21st, 2015 10:04 PM
HELP 94 d90 will not start ripp2002 Defender Technical Discussions 64 August 25th, 2005 08:43 AM
Rats! Now my D90 won't start. No power to fuel pump jcasteel Defender Technical Discussions 8 March 15th, 2005 09:42 AM
Mounting 3-Link Crossmember on 300tdi chassis Chris Cox Defender Technical Discussions 4 March 10th, 2004 02:12 PM


All times are GMT -5. The time now is 01:32 PM.


Copyright