300TDI stalls, then cable restarted in a minute - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old December 6th, 2013, 05:47 PM
Earlclue's Avatar
Earlclue
Status: Offline
Jim cook
2005 defender 110
Member
 
Join Date: Jun 2013
Location: Costa Rica
Posts: 1
300TDI stalls, then cable restarted in a minute

Ok this is makin me nuts! My 2005 TDI all of a sudden, and for no apparent reason shuts down, usually when slowing down. Shut the ignition off and wait a minute and it starts as if nothing happened. All of the relevant sensors have been removed and cleaned and the fuel filter replaced. Diagnostic showed 4 injectors as bad! Any ideas?
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
300tdi, start, tdi

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kickdown cable for 300tdi ZF gearbox Davin Wanted 0 March 2nd, 2013 09:14 AM
NAS D90 300tdi exhaust? Chris Cox Defender Technical Discussions 19 June 13th, 2006 04:59 PM
speedo cable scoloco Defender Technical Discussions 7 November 3rd, 2005 07:54 AM
?????? jimmy salmon Defender Technical Discussions 8 October 13th, 2005 11:54 AM
Mounting 3-Link Crossmember on 300tdi chassis Chris Cox Defender Technical Discussions 4 March 10th, 2004 02:12 PM


All times are GMT -5. The time now is 10:25 AM.


Copyright