200tdi not starting - Page 2 - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #21  
Old April 3rd, 2014, 01:05 PM
meatblanket's Avatar
meatblanket
Status: Offline
Mike Simpson
1955 86 1986 ExMOD 110
Member
 
Join Date: Apr 2010
Location: Golden CO USA
Posts: 582
Registry
Thought they could change an o-ring. My bad.

I would never pay $819.00 (including tax) for this (or any) shop to rebuild one when you can get a new one shipped for about a grand.
Reply With Quote
Sponsored Links
Advertisement
 
  #22  
Old April 3rd, 2014, 08:57 PM
meatblanket's Avatar
meatblanket
Status: Offline
Mike Simpson
1955 86 1986 ExMOD 110
Member
 
Join Date: Apr 2010
Location: Golden CO USA
Posts: 582
Registry
Pump back in now, the third time, and it's running. Lots of nasty white smoke but its running smooth. A little timing advance and I'll have that little drip from the o-ring resolved.
Reply With Quote
  #23  
Old April 3rd, 2014, 09:41 PM
rdavisinva's Avatar
rdavisinva
Status: Offline
Robert Davis
N/A
Member
 
Join Date: Oct 2004
Location: USA
Posts: 6,779
Great news.
The white smoke is not unusual for condensate and unburnt cold fuel that has piled up inside your exhaust system.
When it gets sufficiently hot and blown out with pressure, the exhaust should return to normal.

Glad it finally started and runs... another challenge behind you Mike.
__________________
RDavisinVA

Uncle "Richard" Douglas has a Land Rover with big wheels that never gets stuck... until he breaks something so it won't go. Uncle Douglas always breaks something. - Anna Crowther at the Conclave 2012 (AKA Carburetor Neck)

"What's with this death wobble, Uncle Douglas, I can't keep it in 1 lane?"
UD: "Just Power through it man!"
Reply With Quote
Sponsored Links
Advertisement
 
  #24  
Old April 3rd, 2014, 11:39 PM
meatblanket's Avatar
meatblanket
Status: Offline
Mike Simpson
1955 86 1986 ExMOD 110
Member
 
Join Date: Apr 2010
Location: Golden CO USA
Posts: 582
Registry
Ok I spoke too soon. Yes it runs. But, it's really sluggish, doesn't want to build boost or accelerate. I advanced the timing a bit, then backed it off when I was getting a bit too much clatter. This cleared up the white smoke. I'm not seeing any smoke of any color at this point. I suspect the fuel settings were set randomly, rather like the timing. It is REALLY sluggish off idle. Seems like the fuel needs to be turned up.


I'm going to call tomorrow and see if he will admit to me that it was done "eeny meeny miney moe" or whether he used some incorrect specification.


Ultimately I will probably have to learn how to do the necessary adjustments myself.
Reply With Quote
  #25  
Old April 7th, 2014, 03:03 PM
meatblanket's Avatar
meatblanket
Status: Offline
Mike Simpson
1955 86 1986 ExMOD 110
Member
 
Join Date: Apr 2010
Location: Golden CO USA
Posts: 582
Registry
Closure on this finally. Just had to turn the fuel screw in, runs great now. Had to install the pump 3 times. and also had a Disco pump in and out before getting this figured out.
Reply With Quote
  #26  
Old April 7th, 2014, 03:14 PM
rdavisinva's Avatar
rdavisinva
Status: Offline
Robert Davis
N/A
Member
 
Join Date: Oct 2004
Location: USA
Posts: 6,779
Quote:
Originally Posted by meatblanket View Post
Closure on this finally. Just had to turn the fuel screw in, runs great now. Had to install the pump 3 times. and also had a Disco pump in and out before getting this figured out.
Glad you were able to sort it out.
__________________
RDavisinVA

Uncle "Richard" Douglas has a Land Rover with big wheels that never gets stuck... until he breaks something so it won't go. Uncle Douglas always breaks something. - Anna Crowther at the Conclave 2012 (AKA Carburetor Neck)

"What's with this death wobble, Uncle Douglas, I can't keep it in 1 lane?"
UD: "Just Power through it man!"
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
200tdi, start, starting, tdi

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New to me D90 love it but need help...not starting Coug D90 Defender Technical Discussions 0 June 18th, 2010 06:31 PM
94 D90 not starting - New post / poster Kilgore503 Say Hello! New Member Intros. 17 January 29th, 2009 02:38 AM
Not Starting...Again jdempsey Defender Technical Discussions 8 July 5th, 2007 12:09 PM
Not starting '95 what to check next. jcasteel Defender Technical Discussions 17 June 10th, 2005 02:38 PM
Help with engine not starting cbass Defender Technical Discussions 4 April 5th, 2005 12:12 PM


All times are GMT -5. The time now is 01:25 AM.


Copyright