200tdi losing power - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old July 16th, 2013, 12:43 PM
mightymo's Avatar
mightymo
Status: Offline
matthew m
'95 Disco 300TDI
Member
 
Join Date: Mar 2011
Location: Charlottesville, VA
Posts: 287
Registry
200tdi losing power

Hi all. My 200tdi 130 (only had a couple of weeks now) is losing power while driving more than about 50mph. It almost seems as if it is not sucking enough fuel. I'm guessing its a bad fuel filter of maybe a bunch of gunk in the lines as the truck was poorly cared for before I purchased it. This is my first diesel so any insight is greatly appreciated. Thoughts?
__________________
--------------------------
1995 Disco 300TDI
1991 D130 (SOLD)
1997 D90 NAS (SOLD)
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old July 16th, 2013, 12:46 PM
Red90's Avatar
Red90
Status: Offline
John B.
1991 Defender 90, 200TDI
Site Team
 
Join Date: Sep 2003
Location: Calgary
Posts: 9,231
Registry
Change the fuel filter and check that the lift pump is working. Remove the electrical lead from the injection pump and the inlet line from the fuel filter. Crank the engine and see if the lift pump pumps fuel.
__________________
Pissing people off on the "net" since 1983.

Land Rover. Turning owners into mechanics since 1948.
Reply With Quote
  #3  
Old July 16th, 2013, 12:51 PM
Ben01
Status: Offline
Ben
Defender
Member
 
Join Date: Mar 2011
Location: New York, NY
Posts: 1,226
Also check the fuel line for a leak.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old July 16th, 2013, 03:54 PM
D90user's Avatar
D90user
Status: Offline
steve
109/110 ambulance-55 series I
Member
 
Join Date: Oct 2004
Location: Nevada
Posts: 1,447
Good suggestions above. I'd change the fuel filter and air filter (if there is a question) then go from there.
Reply With Quote
  #5  
Old July 16th, 2013, 05:28 PM
mikeslandrover's Avatar
mikeslandrover
Status: Offline
Mike Hammond
110 200Tdi and a 2005 Scorpa SY250
Member
 
Join Date: Oct 2003
Location: Oxted, Surrey, England, U.K
Posts: 1,756
Registry
Almost certainly the fuel filter, changing it will probably fix things. If it doesn't check there is no obstruction in the fuel pick-up line. there might possibly be a fuel filter on the end of the pick-up pipe.
One dirty jerry can of fuel is enough to cause problems - been there and a new main filter fixed it. Don't run too long with a blocked filter or the mechanical fuel pump will die. This won't necessarily stop the engine though, my 90 ran with a completely FUBARed pick-up pump for a while. (Don't worry ED I put a new one on)
__________________
Mike Hammond
Diesels.....great when they're going and so easy to work on.
Reply With Quote
  #6  
Old July 17th, 2013, 06:40 AM
mightymo's Avatar
mightymo
Status: Offline
matthew m
'95 Disco 300TDI
Member
 
Join Date: Mar 2011
Location: Charlottesville, VA
Posts: 287
Registry
Awesome, thanks guys. Fortunately I DO have a new fuel filter on hand AND just ordered all new fuel lines to go with the new fuel tank that just came in. Sounds like I'll be good soon.
__________________
--------------------------
1995 Disco 300TDI
1991 D130 (SOLD)
1997 D90 NAS (SOLD)
Reply With Quote
  #7  
Old July 17th, 2013, 09:15 AM
sonoronos's Avatar
sonoronos
Status: Offline
Ed
None
Member
 
Join Date: May 2010
Location: Arlington, VA
Posts: 5,529
Registry
Quote:
Originally Posted by mikeslandrover View Post
(Don't worry ED I put a new one on)
No worries, lol! Thanks again, Mike

To the original poster: Remove your fuel pickup line from your fuel tank. At the tip of it, you will see a little fuel filter screen (it's a small white plastic cylinder). Check to see if you have anything on the screen. Clean the filter off completely and put the sender back in the tank. What should happen is that the performance of your vehicle will be restored, but the power loss will come back when the filter becomes clogged again.

Algae bio-film in diesel fuel tanks can grow over time and this stuff will clog everything in your fuel system.

The most successful way of removing a bad case of algae in your diesel is to drop the tank, fill with Purple Power cleaner (watch out - it's nasty, lye-based stuff - it will burn your skin without protection), and let keep overnight. Fill the tank with water to dilute the cleaner and pour the contents of the fuel tank out. The algae and brown crud will come out of the tank in a big brown sheet, leaving a clean fuel tank inside.
Reply With Quote
  #8  
Old September 22nd, 2013, 11:26 AM
mightymo's Avatar
mightymo
Status: Offline
matthew m
'95 Disco 300TDI
Member
 
Join Date: Mar 2011
Location: Charlottesville, VA
Posts: 287
Registry
After installing a new fuel pump and pick up lines she's up and running. Getting her back to being road worthy took longer than expected...too busy changing diapers

Thanks again fellas for offering all your advice!!
__________________
--------------------------
1995 Disco 300TDI
1991 D130 (SOLD)
1997 D90 NAS (SOLD)
Reply With Quote
  #9  
Old September 22nd, 2013, 12:31 PM
mikeslandrover's Avatar
mikeslandrover
Status: Offline
Mike Hammond
110 200Tdi and a 2005 Scorpa SY250
Member
 
Join Date: Oct 2003
Location: Oxted, Surrey, England, U.K
Posts: 1,756
Registry
Good to know you sorted it.
__________________
Mike Hammond
Diesels.....great when they're going and so easy to work on.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
200tdi

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
200tdi low on power and smoking Sun Traveler Defender Technical Discussions 32 June 10th, 2014 06:59 AM
200tdi power steering belt tomaco1 Defender Technical Discussions 7 March 18th, 2010 01:50 PM
200TDI LHD power steering hoses RiftRover Defender Technical Discussions 10 June 15th, 2009 06:40 AM
200tdi power steering pump tomaco1 Defender Technical Discussions 1 August 25th, 2008 10:43 AM
losing power Ray Bone Defender Technical Discussions 6 September 21st, 2005 08:53 AM


All times are GMT -5. The time now is 03:31 PM.


Copyright