2.8 charging issue - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old July 19th, 2014, 09:19 PM
Overlander's Avatar
Overlander
Status: Offline
mark kellgren
in between D's in an 04 D2
Member
 
Join Date: Mar 2006
Location: Charlotte, NC
Posts: 6,531
Registry
2.8 charging issue

So here's a recent electrickery issue that's I'm stumbling through. a few weeks ago my alternator started acting up. when I start my truck, there is no movement in the voltage, and my tach is dead. It stays that way when I start driving til I get about 2500 rpm or so, then it comes alive, as well as the tach. it'll stay that way til I shut down. When I start back up, same thing. it's consistent.

Any idea? I just replaced the regulator with a fresh one. no change.
__________________
Mark Kellgren
KM4BOR

ISIL and al qaeda can go F*ck themselves...
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old July 19th, 2014, 10:14 PM
LuisC's Avatar
LuisC
Status: Offline
Luis Constantin
98 Disvovery 1 LE
Member
 
Join Date: Dec 2012
Location: Austin,Texas USA
Posts: 1,899
Registry
Loose connection or shorted wire? Just guessing. I don't like messing with wires.
__________________
Black Rhino Lives Matter
Reply With Quote
  #3  
Old July 20th, 2014, 12:20 AM
Scottyoh's Avatar
Scottyoh
Status: Offline
Enigma RnR
'87 127"
D-90 Source Vendor
 
Join Date: Jul 2013
Location: Orlando, FL
Posts: 416
Sounds like an internal diode failure or too much resistance in the power cable. What voltage are you seeing before 2500 rpm? After?
__________________
Pres - Florida Land Rover Club
Rovers 'n' Racing
407-720-9450

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old July 20th, 2014, 10:17 AM
Overlander's Avatar
Overlander
Status: Offline
mark kellgren
in between D's in an 04 D2
Member
 
Join Date: Mar 2006
Location: Charlotte, NC
Posts: 6,531
Registry
just battery voltage. 12.4-5 volt. then it pups right up to 14. doing research it sounds like there is an issue with the exciter curcuit for the low voltage lamp, and I dont think my warning lamp has ever worked. Im goung to trace it down today.
__________________
Mark Kellgren
KM4BOR

ISIL and al qaeda can go F*ck themselves...
Reply With Quote
  #5  
Old July 20th, 2014, 05:35 PM
Overlander's Avatar
Overlander
Status: Offline
mark kellgren
in between D's in an 04 D2
Member
 
Join Date: Mar 2006
Location: Charlotte, NC
Posts: 6,531
Registry
Resolved! Got a great self education on how an alternator works in the charging system. Turns out my D+ connection from alternator to Low Voltage Warning Light broke at the connector on the alternator. So no warning lamp illumination when you turn ignition to position II, and then no immediate jump in voltage after start combined with warning lamp extinguishing is the symptom for loss of continuity to D+.

Quick replacement of the female connector and I'm good to go. (it's a beeyoch to get to D+ on a 2.8 btw with that vacuum pump in the way).

Another symptom-resolution combo in my tool chest.
__________________
Mark Kellgren
KM4BOR

ISIL and al qaeda can go F*ck themselves...
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery charging solutions Treuwer Defender Technical Discussions 3 January 13th, 2010 03:52 PM
Charging AC in a 97 artm Defender Technical Discussions 2 August 18th, 2009 11:33 PM
UPS charging customs duties and brokerage charges cgalpin Misc. Chit-Chat 7 November 26th, 2008 09:09 AM
Dual Battery Charging RBees Defender Technical Discussions 5 January 4th, 2007 08:51 AM
Battery Charging chris snell Defender Technical Discussions 3 November 29th, 2006 12:20 PM


All times are GMT -5. The time now is 05:41 AM.


Copyright