2.5NA won't start... - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old August 20th, 2016, 11:43 PM
smkdds2015
Status: Offline
Matthew Kelly
1984 Tithonus 110
Member
 
Join Date: Jun 2016
Location: Bethesda, MD
Posts: 10
Registry
2.5NA won't start...

Oh boy. Just finished telling my brother that we could count on the Defender, and it decided to strand me.

1984 Tithonus 110 with 2.5NA, shipped it to Vegas from Maryland where it had just been checked over and issued a clean bill of health. I picked it up, it started just fine, everything seemed normal and I started driving up to St. George when I stopped to fill up the tank. The weather was not excessively hot, and the truck was running with normal temps. The dash lit up when I turned the key, but the starter didn't engage/no clicks or turning over. Some kind truckers came over to help. We checked the battery, just seeing if it would spark, and it wouldn't, so we figured the battery was low. We tried charging it with three different batteries, and nothing changed. The lights were bright and the dash lights up.

Any advice that can be given would be great! I'm currently in the truck towing it to St. George...and if I can troubleshoot it myself that would be helpful for me and stress-reducing for my wife!
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old August 20th, 2016, 11:48 PM
Daddymow's Avatar
Daddymow
Status: Online
Raub A.
1987 D110 Tithonus
Member
 
Join Date: Oct 2011
Location: Stuart, FL / Boone, NC
Posts: 3,975
Registry
Did you try jump starting it?
__________________
You can't polish a turd but you can roll it in glitter - eBay.uk ad for Freelander.
Reply With Quote
  #3  
Old August 20th, 2016, 11:48 PM
javelinadave
Status: Offline
-
-
Member
 
Join Date: Sep 2003
Location: -
Posts: 5,394
Whack the starter with a hammer and I bet it starts.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old August 20th, 2016, 11:50 PM
smkdds2015
Status: Offline
Matthew Kelly
1984 Tithonus 110
Member
 
Join Date: Jun 2016
Location: Bethesda, MD
Posts: 10
Registry
Quote:
Originally Posted by Daddymow View Post
Did you try jump starting it?
We tried jump starting it from a car and then from two semi-truck batteries, with no change!

------ Follow up post added August 20th, 2016 11:51 PM ------

Quote:
Originally Posted by javelinadave View Post
Whack the starter with a hammer and I bet it starts.
Seriously?
Reply With Quote
  #5  
Old August 20th, 2016, 11:51 PM
javelinadave
Status: Offline
-
-
Member
 
Join Date: Sep 2003
Location: -
Posts: 5,394
Seriously. Dead spot on the armature or a stuck solenoid are common problems.
Reply With Quote
  #6  
Old August 20th, 2016, 11:54 PM
smkdds2015
Status: Offline
Matthew Kelly
1984 Tithonus 110
Member
 
Join Date: Jun 2016
Location: Bethesda, MD
Posts: 10
Registry
Quote:
Originally Posted by javelinadave View Post
Seriously. Dead spot on the armature or a stuck solenoid are common problems.
Sounds good! Do you know of any diagrams for where I should be hitting it? And how hard are we talking?
Reply With Quote
  #7  
Old August 20th, 2016, 11:56 PM
javelinadave
Status: Offline
-
-
Member
 
Join Date: Sep 2003
Location: -
Posts: 5,394
Obviously you don't want to beat the crap out of it but tap it a few times and give it another try.
http://www.defendersource.com/forum/...mer-54667.html
Reply With Quote
  #8  
Old August 21st, 2016, 12:07 AM
smkdds2015
Status: Offline
Matthew Kelly
1984 Tithonus 110
Member
 
Join Date: Jun 2016
Location: Bethesda, MD
Posts: 10
Registry
You guys rock. It's running. Thank you, thank you, thank you!
Reply With Quote
  #9  
Old August 21st, 2016, 12:15 AM
javelinadave
Status: Offline
-
-
Member
 
Join Date: Sep 2003
Location: -
Posts: 5,394
That's what the Birmabright Brotherhood is all about.
Reply With Quote
  #10  
Old August 21st, 2016, 01:00 AM
GuamPilot's Avatar
GuamPilot
Status: Offline
Mike & Carrie Wendt
1986 90 2.5NA
Member
 
Join Date: Mar 2013
Location: Guam & San Bruno
Posts: 605
Registry
Glad you got it going. The first thing we do when our 2.5 won't crank over is push/wiggle the wire/connector to the solenoid.

Mike & Carrie
__________________
Defenders draw attention. Don't buy one if you're shy!
Reply With Quote
  #11  
Old August 21st, 2016, 10:41 AM
carlosz's Avatar
carlosz
Status: Online
Carlos
frank stein "frankie" in action RIP
Member
 
Join Date: Jun 2006
Location: east coast
Posts: 964
Registry
in the words of Jeremy Clarkson "the most unreliable car in the world is the most reliable to be able to take you to the most remote places on earth" or so he said along those lines ......
__________________
the truck ran like a "raped ape"
A fussy warm weather creature...
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
start

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
parked uphill 2.5na cranks no start redline_r Defender Technical Discussions 36 January 8th, 2016 05:43 PM
No start only click 2.5na redline_r Defender Technical Discussions 23 October 21st, 2015 02:13 AM
Won't crank, Won't start. revor Misc. Chit-Chat 4 September 16th, 2010 09:48 PM
D-90 stuck in Park, Won't start. HELP!!! brianosaurus Defender Technical Discussions 9 December 12th, 2007 09:45 AM
D90 won't start! rover4x4 Defender Technical Discussions 32 June 13th, 2005 08:42 AM


All times are GMT -5. The time now is 05:50 PM.


Copyright