2.5NA Wiring - Help Needed - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old May 4th, 2016, 04:52 PM
ben little's Avatar
ben little
Status: Offline
ben little
1986 ex-MOD 110
Member
 
Join Date: Jun 2009
Location: salt lake city
Posts: 104
2.5NA Wiring - Help Needed

Nearing the end of my 110 restoration and I cannot seem to figure something out.

There is a single 'green' wire coming off the inside of the injector pump - Where does this connect to?

Can someone possibly post a pic of the loom that it plugs into?

Thanks in advance.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old May 4th, 2016, 04:59 PM
Red90's Avatar
Red90
Status: Online
John B.
1991 Defender 90, 200TDI
Site Team
 
Join Date: Sep 2003
Location: Calgary
Posts: 9,242
Registry
The only connection to the injection pump should be for the fuel solenoid and it should be white with black stripe which is direct from the ignition switch. Green is switched and fused power.

You can download the factory manual here: pdf Land Rover Manuals | Landroverweb.com Wiring schematics are in there.
__________________
Pissing people off on the "net" since 1983.

Land Rover. Turning owners into mechanics since 1948.
Reply With Quote
  #3  
Old May 4th, 2016, 06:11 PM
ben little's Avatar
ben little
Status: Offline
ben little
1986 ex-MOD 110
Member
 
Join Date: Jun 2009
Location: salt lake city
Posts: 104
Quote:
Originally Posted by Red90 View Post
The only connection to the injection pump should be for the fuel solenoid and it should be white with black stripe which is direct from the ignition switch. Green is switched and fused power.

You can download the factory manual here: pdf Land Rover Manuals | Landroverweb.com Wiring schematics are in there.
Thanks... Yea I've looked through the manuals and my truck seems to have different colors than what the manual suggests. Could be the ex-MOD... Not sure.

The wire is definitely green (solid green IIRC).
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old May 4th, 2016, 06:27 PM
Ash's Avatar
Ash
Status: Offline
Ash Heller
OM606 110 Frankenstein
D-90 Source Vendor
 
Join Date: Dec 2005
Location: Orlando, FL
Posts: 665
Can you post a picture of it? Hard to say what you've got going on without seeing it. As John said, there should only be a single connection on the pump.

-Ash
__________________
Geared Restoration Co.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

352-572-3236

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
  #5  
Old May 4th, 2016, 06:55 PM
Red90's Avatar
Red90
Status: Online
John B.
1991 Defender 90, 200TDI
Site Team
 
Join Date: Sep 2003
Location: Calgary
Posts: 9,242
Registry
Quote:
Originally Posted by ben little View Post
Thanks... Yea I've looked through the manuals and my truck seems to have different colors than what the manual suggests. Could be the ex-MOD... Not sure. The wire is definitely green (solid green IIRC).
I have the MOD wiring schematic and the colors should be the same.

As Ash says a picture might help. Show where it goes.
__________________
Pissing people off on the "net" since 1983.

Land Rover. Turning owners into mechanics since 1948.
Reply With Quote
  #6  
Old May 4th, 2016, 07:00 PM
Red90's Avatar
Red90
Status: Online
John B.
1991 Defender 90, 200TDI
Site Team
 
Join Date: Sep 2003
Location: Calgary
Posts: 9,242
Registry
Maybe oil temp sensor. It is supposed to be light green with green stripe.
__________________
Pissing people off on the "net" since 1983.

Land Rover. Turning owners into mechanics since 1948.
Reply With Quote
  #7  
Old May 4th, 2016, 07:02 PM
Red90's Avatar
Red90
Status: Online
John B.
1991 Defender 90, 200TDI
Site Team
 
Join Date: Sep 2003
Location: Calgary
Posts: 9,242
Registry
Here is the MOD wiring diagram.
Attached Files
File Type: pdf Defender FFR Wiring diagram.pdf (958.5 KB, 81 views)
__________________
Pissing people off on the "net" since 1983.

Land Rover. Turning owners into mechanics since 1948.
Reply With Quote
  #8  
Old May 4th, 2016, 09:36 PM
ben little's Avatar
ben little
Status: Offline
ben little
1986 ex-MOD 110
Member
 
Join Date: Jun 2009
Location: salt lake city
Posts: 104
Ugh... Thanks guys. Good news, I'm just a dumbass - looked closer at this again and figured it out.

The green wire is actually for the oil temp sensor.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
wiring

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2.5NA Wiring Harness steinhnj Wanted 0 February 8th, 2016 07:51 PM
ignition wiring help needed spartan Defender Technical Discussions 3 June 26th, 2013 02:13 PM
Crankshaft Damper 2.5na Needed edh Wanted 2 January 25th, 2012 07:22 AM
Speaker Wiring Help Needed NoVaKevin Defender Technical Discussions 10 February 14th, 2011 02:49 PM
Radio install/wiring help needed. Firefighter2904 Defender Technical Discussions 5 August 8th, 2007 09:39 PM


All times are GMT -5. The time now is 09:18 AM.


Copyright