1997 Sporadic Idle / Stall issue - fixed - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Join the Defender Source Community Today

Thread Tools
Old March 7th, 2012, 12:47 AM
brettm's Avatar
Status: Offline
97 D90-SW, Arles +4.6
Join Date: Dec 2010
Location: seattle, wa
Posts: 165
1997 Sporadic Idle / Stall issue - fixed

I've been chasing a hard-to-reproduce erratic idle / stalling issue.

Never cut out when cold, only after it got warm from a short-trip and started up again. Would often just start then when I took my foot off gas to shift out of park (97), idle would drop, gasp for air and die. Happened often coming to a stop at a light.

Sometimes would happen for days in a row, then nothing for a week. Sometimes died at 20 mph when I took my foot of the gas.

Tried the usual suspects, new Stepper, new VSS, new TPS etc.

Turned out to be a really easy fix in the end. Replaced both the hoses shown in green in the image. I believe the primary culprit was the one that runs from near the oil filler cap to the plenum (on right in picture), it was lined with thick oily gunk. Flushing it made a considerable difference - replacing it solved the problem all together.

Been running great for a month now with no dips in idle or stalls in sight. Fingers crossed.

(Picture is a GEMS sample I found online - not my actual engine - obviously )
Attached Thumbnails
Click image for larger version

Name:	hoses.jpg
Views:	153
Size:	59.8 KB
ID:	48659  

Reply With Quote
Old March 7th, 2012, 08:22 AM
MAX711's Avatar
Status: Offline
Andrew Dance
1994 D-90 ST
Join Date: Jun 2009
Location: Las Vegas, NV
Posts: 114
Might want to check your throttle body too. If there's that much gunk in the hose then some of it will have gotten into the throttle body and butterfly assembly?

Reply With Quote
Old March 7th, 2012, 04:59 PM
Status: Offline
Nick Vogel
1997 D-90 / 2012 LR4
Join Date: May 2009
Location: Houston, Texas
Posts: 509
My driver's side tube had a super small crack in it and did the exact same thing. Huge PITA to figure out, but a 13 dollar fix in the end.
Reply With Quote

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

1997, 97, idle

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
1997 Defender Issue...Need some advice NDRover Defender Technical Discussions 19 June 30th, 2011 11:46 AM
1997 D-90 Idle Speed ndhlp Defender Technical Discussions 4 October 11th, 2006 10:43 AM
Fault Code 48/fast engine idle speed arbik Defender Technical Discussions 9 June 2nd, 2006 06:02 AM
Idle Issue saber6 Defender Technical Discussions 2 April 19th, 2006 12:25 PM
Headlight Switch Issue, any ideas? januconn92 Defender Technical Discussions 1 July 24th, 2005 10:53 AM

All times are GMT -5. The time now is 07:56 PM.