1994 land rover defender shuts off randomly - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old September 22nd, 2015, 06:45 PM
marsik's Avatar
marsik
Status: Offline
Sergey
1994/90
Member
 
Join Date: May 2015
Location: hawthorne,nj,usa
Posts: 60
Registry
1994 land rover defender shuts off randomly

Hi everybody! please help
i got 1994 land rover defender
it is shuts off while i was driving and then i was able to start it up in about 45 min.
is anyone have any idea what is going on?
it is happened to me already 2nd time
thank you
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old September 22nd, 2015, 07:16 PM
Angus's Avatar
Angus
Status: Offline
Mike Ferguson
1994 Defender 90
Member
 
Join Date: Nov 2013
Location: Philly Area
Posts: 173
Registry
Sergey,

Welcome to the board and welcome to the often bewildering world of Land Rover ownership. There are some very experienced folks on this board who can help, but they will need details about your problem. You can also do a little troubleshooting first. When it quits, does it still have spark? Can you hear the fuel pump when you turn the key on? Does it sputter to a stop or just quit all together?

Try those few things first, then add any additional info you can to help the folks help you. Good luck.
__________________
Angus
Reply With Quote
  #3  
Old September 23rd, 2015, 09:33 AM
Roverchef's Avatar
Roverchef
Status: Offline
Jake K.
95 D90 SW
Member
 
Join Date: Jan 2010
Location: Deep in the Dirty South
Posts: 341
Ignition amplifier is on it's way out. Buy the relocation kit and you won't have this issue again…@ least not coming from this part. Good luck!
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old September 23rd, 2015, 04:51 PM
sloanfiske's Avatar
sloanfiske
Status: Offline
Anthony Nelson
97 D90 SW
Member
 
Join Date: Mar 2008
Location: New York
Posts: 435
Registry
http://www.roverparts.com/Parts/STC1856
Reply With Quote
  #5  
Old September 23rd, 2015, 04:59 PM
rijosho's Avatar
rijosho
Status: Offline
Joshua
1995 Black ST - Rhinolined edition
Research Assistant/Eagle Eyes
 
Join Date: Apr 2009
Location: NYC
Posts: 16,557
Registry
Quote:
Originally Posted by marsik View Post
Hi everybody! please help
i got 1994 land rover defender
it is shuts off while i was driving and then i was able to start it up in about 45 min.
is anyone have any idea what is going on?
it is happened to me already 2nd time
thank you
Also remove your IACV (it's at the rear of the plenum on the passenger side...white arrow in the pic) and hit it with some carb cleaner spray and re-install. It may just be sticky from carbon build-up.
Attached Thumbnails
Click image for larger version

Name:	idlervalve.jpg
Views:	146
Size:	102.0 KB
ID:	130453  
__________________
Quote:
I am talking purely from an aesthetics standpoint.
Reply With Quote
  #6  
Old October 2nd, 2015, 08:55 AM
marsik's Avatar
marsik
Status: Offline
Sergey
1994/90
Member
 
Join Date: May 2015
Location: hawthorne,nj,usa
Posts: 60
Registry
i am really appreciate your advice and definitely going to try that
thank you so much
I will reply with feed back
Reply With Quote
  #7  
Old October 2nd, 2015, 09:09 AM
Davis's Avatar
Davis
Status: Offline
Chris Davis
94 NAS D90 6.2LS
Member
 
Join Date: Nov 2003
Location: Colorado
Posts: 2,504
I second the amplifier. The ignition switch can also be at fault and has shut off while I drove before-- that is super easy to diagnose when you can't restart by checking if your coil is getting 12v. But if you haven't relocated amplifier (or swapped to Mallory distributor), then that is most likely. Even if it isn't, you should still relocate it.

The IACV really only affects start up and idle at stopped-- if your issue is while driving then not as likely a cause. Super easy to clean if dirty, though, and can affect start up.
Reply With Quote
  #8  
Old October 2nd, 2015, 01:19 PM
marsik's Avatar
marsik
Status: Offline
Sergey
1994/90
Member
 
Join Date: May 2015
Location: hawthorne,nj,usa
Posts: 60
Registry
i didn't do anything yet... truck is just standing in my garage
It is idle for approximately 3 min , then shuts off
i can start it right away and it runs for another minute, then shuts of
i can start it again and it shuts of right away
Reply With Quote
  #9  
Old October 5th, 2015, 05:06 AM
marsik's Avatar
marsik
Status: Offline
Sergey
1994/90
Member
 
Join Date: May 2015
Location: hawthorne,nj,usa
Posts: 60
Registry
Quote:
Originally Posted by marsik View Post
i didn't do anything yet... truck is just standing in my garage It is idle for approximately 3 min , then shuts off i can start it right away and it runs for another minute, then shuts of i can start it again and it shuts of right away

Click image for larger version

Name:	image-596484473.jpg
Views:	124
Size:	593.8 KB
ID:	131551





Click image for larger version

Name:	image-2467975639.jpg
Views:	144
Size:	536.4 KB
ID:	131552



Click image for larger version

Name:	image-1865672615.jpg
Views:	106
Size:	563.3 KB
ID:	131553



Click image for larger version

Name:	image-2101425153.jpg
Views:	114
Size:	590.2 KB
ID:	131554

here is my ignition set up
please advise? how do I connect ignition amplifier
i just ordered ignition amplifier relocation kit
thank you
Reply With Quote
  #10  
Old October 5th, 2015, 05:12 AM
marsik's Avatar
marsik
Status: Offline
Sergey
1994/90
Member
 
Join Date: May 2015
Location: hawthorne,nj,usa
Posts: 60
Registry
Hi folks !
i just ordered ignition amplifier relocation kit
and now i am looking at my distributor-ignition set up and i am getting pretty confused
1 i cant really see ignition amplifier
here is my ignition set up

Click image for larger version

Name:	image-1012965498.jpg
Views:	96
Size:	588.3 KB
ID:	131555



Click image for larger version

Name:	image-3197995775.jpg
Views:	99
Size:	528.0 KB
ID:	131556

please advise me
may be I don't even have this thing IA on my truck
Reply With Quote
  #11  
Old October 5th, 2015, 07:46 AM
leastonce's Avatar
leastonce
Status: Offline
Jason England
D-90 White 95 SW #65
Site Team
 
Join Date: Jul 2009
Location: NYC
Posts: 6,078
Registry
Someone has previously replaced it with a Mallory setup. Josh had the same problems that caused him to stall out for years. if you are experiencing the same issue it was because the coil sends a 12v signal to the ECU on your setup and the standard coil sends 9v.

I created a workaround which used two resistor chicklets in series to lower the current to the ECU which appears to have fixed it.

one me and I can walk you through it.
__________________
Quote:
Soapy water / KY jelly, etc. is is basically a must. Yes, good idea to remove trim panels - only takes 5 more minutes to do so.
Car Camping Collective founding member and Chief Executive Officer
Cat Camping Collective founding member and Chief Executive Officer
Reply With Quote
  #12  
Old October 5th, 2015, 01:29 PM
marsik's Avatar
marsik
Status: Offline
Sergey
1994/90
Member
 
Join Date: May 2015
Location: hawthorne,nj,usa
Posts: 60
Registry
Thanks for your reply and please walk me trough,
the ignition amp will arrive tomorrow or Wednesday
Should i get some other parts?
thanks again for you time
Reply With Quote
  #13  
Old October 5th, 2015, 01:57 PM
rijosho's Avatar
rijosho
Status: Offline
Joshua
1995 Black ST - Rhinolined edition
Research Assistant/Eagle Eyes
 
Join Date: Apr 2009
Location: NYC
Posts: 16,557
Registry
take that little black mallory box out of there with the 3 wires in and out of it. Mine was bad and it's just one more thing to break.
__________________
Quote:
I am talking purely from an aesthetics standpoint.
Reply With Quote
  #14  
Old October 5th, 2015, 02:21 PM
down_shift's Avatar
down_shift
Status: Offline
Russell
94' D90 ST & 06' LR3
Member
 
Join Date: Sep 2011
Location: Leesburg, VA
Posts: 4,118
Registry
Or go full Mallory. I don't have that black box either.
https://youtu.be/4vyFJFWG4oE
Reply With Quote
  #15  
Old October 5th, 2015, 02:51 PM
leastonce's Avatar
leastonce
Status: Offline
Jason England
D-90 White 95 SW #65
Site Team
 
Join Date: Jul 2009
Location: NYC
Posts: 6,078
Registry
Quote:
Originally Posted by marsik View Post
Thanks for your reply and please walk me trough,
the ignition amp will arrive tomorrow or Wednesday
Should i get some other parts?
thanks again for you time
The standard amp is no longer used on your vehicle ...
__________________
Quote:
Soapy water / KY jelly, etc. is is basically a must. Yes, good idea to remove trim panels - only takes 5 more minutes to do so.
Car Camping Collective founding member and Chief Executive Officer
Cat Camping Collective founding member and Chief Executive Officer
Reply With Quote
  #16  
Old October 5th, 2015, 02:53 PM
marsik's Avatar
marsik
Status: Offline
Sergey
1994/90
Member
 
Join Date: May 2015
Location: hawthorne,nj,usa
Posts: 60
Registry
I just disconnected small mallory box
the truck acting the same running for couple of minutes and then shuts of

I noticed that white box getting pretty hot fast

Click image for larger version

Name:	image-4041117838.jpg
Views:	124
Size:	527.7 KB
ID:	131591
Reply With Quote
  #17  
Old October 5th, 2015, 03:02 PM
leastonce's Avatar
leastonce
Status: Offline
Jason England
D-90 White 95 SW #65
Site Team
 
Join Date: Jul 2009
Location: NYC
Posts: 6,078
Registry
Take this one step at a time to avoid getting confused about what works and what doesn't.

Get an led test light and test the signal in the highlighted wire. It will flash every time the engine sparks. The signal tells the ECU that the engine is running and therefore it can turn on the fuel pump.

If you have no signal here then the ECU wont turn on the fuel pump.
Attached Thumbnails
Click image for larger version

Name:	image-3197995775.jpg
Views:	88
Size:	198.5 KB
ID:	131593  
__________________
Quote:
Soapy water / KY jelly, etc. is is basically a must. Yes, good idea to remove trim panels - only takes 5 more minutes to do so.
Car Camping Collective founding member and Chief Executive Officer
Cat Camping Collective founding member and Chief Executive Officer
Reply With Quote
  #18  
Old October 5th, 2015, 03:02 PM
marsik's Avatar
marsik
Status: Offline
Sergey
1994/90
Member
 
Join Date: May 2015
Location: hawthorne,nj,usa
Posts: 60
Registry
should i cancel my order of ignition amplifier relocation kit and just order mallory ignition coil?
which one should i get ?
thank you

------ Follow up post added October 5th, 2015 01:06 PM ------

could you please send me a few pictures of how it is done on yours truck
Reply With Quote
  #19  
Old October 5th, 2015, 03:13 PM
down_shift's Avatar
down_shift
Status: Offline
Russell
94' D90 ST & 06' LR3
Member
 
Join Date: Sep 2011
Location: Leesburg, VA
Posts: 4,118
Registry
Quote:
Originally Posted by marsik View Post
...could you please send me a few pictures of how it is done on yours truck
Do you have any type of alarm system installed?
Here you go. Mine is a 94' as well.
Attached Thumbnails
Click image for larger version

Name:	IMG_0879.jpg
Views:	80
Size:	93.0 KB
ID:	131595   Click image for larger version

Name:	IMG_0880.jpg
Views:	85
Size:	64.6 KB
ID:	131596  

Click image for larger version

Name:	IMG_0881.jpg
Views:	71
Size:	82.8 KB
ID:	131597  
Reply With Quote
  #20  
Old October 5th, 2015, 03:18 PM
marsik's Avatar
marsik
Status: Offline
Sergey
1994/90
Member
 
Join Date: May 2015
Location: hawthorne,nj,usa
Posts: 60
Registry
none of I know about
i got this truck about a year ago and i dont know what previous owners had there
thank you

------ Follow up post added October 5th, 2015 01:25 PM ------

what is the part number for ignition coil and where can i get it
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
1994, defender, land rover, land rover defender

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Part 2 of troubleshooting. Engine randomly dies sflash868 Defender Technical Discussions 10 February 24th, 2015 12:35 AM
200tdi cutting out randomly BRAB Defender Technical Discussions 5 September 2nd, 2014 02:06 PM
Land Rover Defender 90 :: 1994 Land Rover Defender 90 KCROVERMAN Defender & Series Truck Registry 2 January 14th, 2014 08:37 PM
Truck randomly dies... dlane Defender Technical Discussions 12 July 20th, 2011 12:23 PM
D90 randomly stalls when placed to neutral danb.taylor Defender Technical Discussions 2 May 9th, 2007 09:03 AM


All times are GMT -5. The time now is 12:25 PM.


Copyright