110 electical problems - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old November 21st, 2013, 06:54 PM
js110's Avatar
js110
Status: Offline
Jerry
1984/110
Member
 
Join Date: Oct 2012
Location: Vancouver, BC
Posts: 7
110 electical problems

Hi everyone,
I have a 1984 110 with a 300 tdi.

At the moment the brake lights & reverse light stopped working but the taillights & signals still work.
At the same time the battery is slowly draining & I need to put it on charge once a week or so.

I'm not sure if they are linked to the same problem.

Thank you in advance.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old November 21st, 2013, 07:31 PM
BlackField's Avatar
BlackField
Status: Offline
Oscar
D110
Member
 
Join Date: Mar 2012
Location: NYC
Posts: 1,640
Have you been cutting any wires? Uninstalling items? Is the electrical system stock or has it been butchered previously? Is your hazard switch working?
__________________
Lemmings as you know them are a Disney fabricated lie. The truth is out there.
Reply With Quote
  #3  
Old November 21st, 2013, 09:58 PM
Uncle Douglas's Avatar
Uncle Douglas
Status: Offline
Doug Crowther
A defender in every driveway-motto
D-90 Source Vendor
 
Join Date: Dec 2007
Location: Gods Country- Central Virginia
Posts: 11,839
Registry
Quote:
Originally Posted by js110 View Post
Hi everyone,
I have a 1984 110 with a 300 tdi.

At the moment the brake lights & reverse light stopped working but the taillights & signals still work.
At the same time the battery is slowly draining & I need to put it on charge once a week or so.

I'm not sure if they are linked to the same problem.

Thank you in advance.
Have you checked sockets with a meter ?
__________________
Good judgement comes from experience,experience comes from bad judgement.

Dividing Creek Imports
Worldwide Vehicle Shipment and Importation Service
Restoration & Modification work


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

410.693.1391


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old November 21st, 2013, 10:28 PM
javelinadave
Status: Offline
-
-
Member
 
Join Date: Sep 2003
Location: -
Posts: 5,394
Check that the fuse isn't blown or the contacts aren't corroded and/or replace the hazard switch.
Reply With Quote
  #5  
Old November 22nd, 2013, 04:16 PM
js110's Avatar
js110
Status: Offline
Jerry
1984/110
Member
 
Join Date: Oct 2012
Location: Vancouver, BC
Posts: 7
The hazard lights work, I haven't done anything to the wiring.
I'm guessing I have power to the taillights since the signals work all around.
Reply With Quote
  #6  
Old November 24th, 2013, 08:59 PM
Capt Milks's Avatar
Capt Milks
Status: Offline
Mike
Defender V-8, Defender 2.25
Member
 
Join Date: Oct 2004
Location: United States
Posts: 1,801
I would also check the rubber connectors at the rear. Also always check t he grounds. The chassis harness should be coming out the right rear frame and going up into the area above the fender well at the rear inside the tub. You can take a test light and see what is working and what is not. Trace it back from there. You may also have a bad light switch so I would also test that.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NAS 110 Rear Bumper Reefminis Wanted 3 October 2nd, 2006 04:54 PM
1986 Land Rover 110 Soft-Top Tdi Lurker For Sale - Vehicles 3 June 7th, 2006 11:03 AM
Importing a 110 to the States mfreeman17 Misc. Chit-Chat 18 April 14th, 2005 02:02 PM
110 Rock Sliders tobit3 For Sale - Parts 4 March 24th, 2005 05:17 PM
Defender 110 and 90 tool kit mpodgorski For Sale - Parts 5 May 4th, 2004 09:17 PM


All times are GMT -5. The time now is 08:17 AM.


Copyright