110 Died - Your Thoughts? - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old February 10th, 2008, 12:11 AM
3rovers's Avatar
3rovers
Status: Offline
Dennis Yard
1993 NAS D-110 #55
Member
 
Join Date: Sep 2003
Location: San Diego, CA
Posts: 125
Unhappy 110 Died - Your Thoughts?

Gentlemen and Ladies,

As if by magic, my 110 died a block from home the other night. It just suddenly stopped running and I had barely enough momentum to get through the traffic light.
The engine turns over fine, but does not catch.

I have done several troubleshooting items as follows, to see if I have fire and fuel.

1. Checked that I had gas. I do.
2. Checked that I could hear the fuel pump was "whirring/buzzing". It was.
3. Checked all the fuses in the dash fuse panel. All were good, including F20 fuel pump relay.
4. Checked the Maxi fuse in the engine compartment for the Ignition. It was intact.
5. Cracked the connection of the fuel line to the fuel injection rail. Gas spit out when the ignition key was turned. i,e, good pump.
6. Checked the two relays in the footwell. Seem OK but jumpered the Main (Black) one to eliminate the relay. No change, still didn't start.
7. I pulled the coil wire from dist cap - wire sparks to ground when turned over.
8. I pulled a plug with its wire. Sparks across the plug gap.
9. I pulled a plug after turning engine over, but it appears dry. Does look wet with gas.
10. Swapped the ECU with a spare. No difference.
11. I pressed the accident reset switch by the fuse box. It was not popped and did not need re-setting.
12. I used a test light to see if there was power to the fuel injector pins in the mating connector. There was a fairly steady light on one pin and slightly waivering light on the other pin.

So.... any suggestions on what to check next?

Cheers,
__________________
Dennis Yard
Land Rover Club of San Diego
1993 NAS D-110 #55 (GNUTRUK)
2004 Disco II (DSCO DOG)
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old February 10th, 2008, 12:40 AM
Hans's Avatar
Hans
Status: Offline
Hans Haase
The D-90.com Lab Rat
Member
 
Join Date: Oct 2003
Location: Long Island, NY
Posts: 2,381
Everything I would suggest to check, you've already checked. Only other thing I can think of is maybe the ignition switch went, and the "Start" circuit is still good in it, but the "Run" circuit isn't.

-Hans
__________________
My oil line fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
My 100k stopped odometer fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Brace for impact, I'm in a "modifying mood". Massive thread count inbound.
Reply With Quote
  #3  
Old February 10th, 2008, 12:48 AM
3rovers's Avatar
3rovers
Status: Offline
Dennis Yard
1993 NAS D-110 #55
Member
 
Join Date: Sep 2003
Location: San Diego, CA
Posts: 125
Hans,

Thanks for that thought. The ignition switch was replaced a year ago or so as something was loose inside and it would drop out on occasion.

I will take a look at that tomorrow, could be similar failure on the new switch too. Never know with English electrics.
__________________
Dennis Yard
Land Rover Club of San Diego
1993 NAS D-110 #55 (GNUTRUK)
2004 Disco II (DSCO DOG)
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
110, ht

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
90 & 110 Parts Sale Extravaganza Wolf Fabrication For Sale - Parts 57 October 16th, 2012 09:35 AM
1983 110 import report - Long grnrvrs Defender Technical Discussions 28 October 22nd, 2010 11:52 AM
Best way across the US Mike Hippert Defender Technical Discussions 173 April 29th, 2010 04:56 PM
Build a 110? Chaucer Misc. Chit-Chat 36 March 19th, 2008 08:27 PM
D90 withdrawl :( 110 build :) evilfij Defender Technical Discussions 6 October 23rd, 2004 01:04 AM


All times are GMT -5. The time now is 06:51 AM.


Copyright