Weird Indicator Fault - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Series Technical Discussions


Reply
 
Thread Tools
  #1  
Old October 27th, 2014, 05:28 PM
Hache
Status: Offline
Henry Lambert
1983 Ex-MOD 90 2.5N/A
Member
 
Join Date: Feb 2014
Location: Portland, or
Posts: 227
Weird Indicator Fault

On my ex-mod 90 my indicators/turn signals are behaving strangely.

The front right signal and repeater aren't working at all.

So when turning right, only the rear right signals flash. If I have the sidelights illuminated then the right sidelight flashes too (which is odd but suggests a bad earth).

When turning left, the two rear (right AND left) and front left signal and repeater flash.

I've checked the front two earthing points inside the wing and they look ok - no corrosion of dirt build up.

Tried replacing the flasher unit.

Also tested the repeater bulbs.

One of the rear fogs is missing a bulb but didn't think they'd be on the same circuit.

Any help greatly appreciated.

Thanks.
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Series Technical Discussions

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Indicator fault Peachy Support & Suggestions 4 October 22nd, 2013 02:20 PM
WTB: AT Shift Indicator fleabus Wanted 3 August 4th, 2006 04:46 PM
DX Indicator on Radio tron Defender Technical Discussions 5 April 20th, 2005 04:34 PM
Dash Indicator? DJ Menasco Defender Technical Discussions 9 September 11th, 2004 04:07 PM
indicator's rover4x4 Defender Technical Discussions 0 October 27th, 2003 03:02 PM


All times are GMT -5. The time now is 05:04 AM.


Copyright