gas in engine 1967 2A - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Series Technical Discussions


Reply
 
Thread Tools
  #1  
Old February 11th, 2011, 10:38 PM
kjva
Status: Offline
Ken Jackson
1985 110 Wagon
Member
 
Join Date: Mar 2007
Location: Dillwyn VA USA
Posts: 352
gas in engine 1967 2A

My 2A wagon was running very rough, I took of the hose on top of the carb to check the choke was not stuck, is was not but then engine oil squirted from the breather tube on top of the rocker cover. The oil smelt of gas and the oil on the dip stick was very thin also smelling of gas. Any ideas before I tear it down
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old February 11th, 2011, 11:42 PM
floatflyer
Status: Offline
Bryan Krill
'95 D90 wagon
Member
 
Join Date: Aug 2009
Location: Sagle, Idaho
Posts: 42
check your mechanical fuel pump, it may have ruptured its diaphargm and is pumping gas into the crankcase.
Reply With Quote
  #3  
Old February 12th, 2011, 07:25 AM
kjva
Status: Offline
Ken Jackson
1985 110 Wagon
Member
 
Join Date: Mar 2007
Location: Dillwyn VA USA
Posts: 352
Thanks I will check, would never have thought of that. Did a compression test and it was on the low side but all cylinders the same. The Rover smokes heavily which is why I thought the choke was stuck
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old February 12th, 2011, 10:52 PM
Ren Ching's Avatar
Ren Ching
Status: Offline
Skinny Pete
'84 90 "Yamelo"/'88 RRC "Chewbacca"
Member
 
Join Date: Mar 2007
Location: Downtown
Posts: 4,696
Registry
running rich. check the carb float isn't leaking.
Reply With Quote
  #5  
Old February 13th, 2011, 09:14 AM
kjva
Status: Offline
Ken Jackson
1985 110 Wagon
Member
 
Join Date: Mar 2007
Location: Dillwyn VA USA
Posts: 352
It smokes like a train rather than running rich. If the float was stuck that would not explain the gas in the engine oil. Hoping to pull the fuel pump off today
Reply With Quote
  #6  
Old February 20th, 2011, 07:52 AM
kjva
Status: Offline
Ken Jackson
1985 110 Wagon
Member
 
Join Date: Mar 2007
Location: Dillwyn VA USA
Posts: 352
Just put in a new fuel pump and the problem was solved. Cost of the pump from Atlantic British was the same as one from the Uk.
Reply With Quote
  #7  
Old February 20th, 2011, 10:16 AM
floatflyer
Status: Offline
Bryan Krill
'95 D90 wagon
Member
 
Join Date: Aug 2009
Location: Sagle, Idaho
Posts: 42
glad that solved your problem!
Reply With Quote
  #8  
Old February 20th, 2011, 11:16 AM
evilfij's Avatar
evilfij
Status: Offline
evilfij
I have never seen a rover in person
Member
 
Join Date: Oct 2003
Location: on the internet
Posts: 14,688
BTW the smoke was because the gas increased the oil level so it started burning oil. Happens on my 1994 NAS D90 when the computer gets wet and sticks on the injectors. Some things never change.
__________________
*not legal advice*
Reply With Quote
  #9  
Old February 21st, 2011, 03:03 PM
mikeslandrover's Avatar
mikeslandrover
Status: Offline
Mike Hammond
110 200Tdi and a 2005 Scorpa SY250
Member
 
Join Date: Oct 2003
Location: Oxted, Surrey, England, U.K
Posts: 1,756
Registry
You'll be wanting to change your engine oil pretty quickly.
__________________
Mike Hammond
Diesels.....great when they're going and so easy to work on.
Reply With Quote
  #10  
Old February 23rd, 2011, 07:14 PM
kjva
Status: Offline
Ken Jackson
1985 110 Wagon
Member
 
Join Date: Mar 2007
Location: Dillwyn VA USA
Posts: 352
Changed the oil when I put the new pump in, will do it again after a few miles, waiting for it to warm up, the suirrel cage heater renders the 2A Wagon a mild weather vehicle
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Series Technical Discussions

Tags
engine, gas

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
300 Tdi Egt Q?????? Buckon37s Defender Technical Discussions 37 July 11th, 2012 11:26 AM
2.25 / 2.5 gas engine for 110 kjva Wanted 6 February 3rd, 2011 07:01 PM
Best way across the US Mike Hippert Defender Technical Discussions 173 April 29th, 2010 04:56 PM
service engine VS. check engine scubadanster Defender Technical Discussions 18 June 23rd, 2009 11:18 AM
Oil Info XD90 Defender Technical Discussions 5 September 7th, 2004 10:07 PM


All times are GMT -5. The time now is 05:18 AM.


Copyright