D1 to D90 - Page 6 - Defender Source
Defender Source  

Go Back   Defender Source > Build-up's, Projects & Registry Profiles > Truck Build-up's & Restores

Join the Defender Source Community Today
Reply
 
Thread Tools
  #101  
Old May 18th, 2015, 04:31 PM
Rocky's Avatar
Rocky
Status: Offline
Chris
72 + D1 drivetrain
Member
 
Join Date: Sep 2006
Location: Colonies
Posts: 7,989
Well the pesky no start scenario that started (!) at WR may well have been due to the remote mounted GM amplifier that simply isn't up the job in the Rover environment. We now have a good consistent start, but it now when warm stalls out at idle after the revs get lower and lower. IAC valve seems ok.
Of course when you get to spend quality time under the hood, you notice other things. Wasn't too happy with the cooling last summer and the noises from the water pump put that on the next order list. Looks like ABP has the the closest thing to genuine possible. So that's up next.
Reply With Quote
Sponsored Links
Advertisement
 
  #102  
Old June 2nd, 2015, 10:18 PM
Rocky's Avatar
Rocky
Status: Offline
Chris
72 + D1 drivetrain
Member
 
Join Date: Sep 2006
Location: Colonies
Posts: 7,989
New Starter check, I'm going to put the rebuilt but whiny alternator into my parts bin.

Decided to rename it. Originally Nigel, it became Nigella and now its just Ella. Has to be a woman, because she only hints at whats wrong, so you fix it and discover that's not really the solution.
Reply With Quote
Sponsored Links
Advertisement
 
  #103  
Old July 3rd, 2016, 07:37 AM
Rocky's Avatar
Rocky
Status: Offline
Chris
72 + D1 drivetrain
Member
 
Join Date: Sep 2006
Location: Colonies
Posts: 7,989
A year or so later and alls well. With one exception. I've been slacking and need to work on the truck. Done a few little jobs like seat box lids, tire carrier, started trunk space bed mat etc.

Last night I tripped over some tie downs I'd bought for my D1 long ago.

Your question to start the day, should I use Aluminum bolts to secure them to the rear tub rather than SS or galvy bolts? Or am I overthinking the dread galvanic corrosion curse?
Reply With Quote
Sponsored Links
Advertisement
 
  #104  
Old July 3rd, 2016, 07:56 AM
1of40's Avatar
1of40
Status: Offline
1of40
NAS 97SW & 83 One Ten Tdi
Member
 
Join Date: Dec 2003
Location: Potomac Falls & Wintergreen, Virginia
Posts: 5,351
Registry
The early ROWs I've seen don't seem to have the problems the NAS trucks do. I think if you prep the surfaces the SS will be fine.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
  #105  
Old October 1st, 2016, 02:13 PM
Rocky's Avatar
Rocky
Status: Offline
Chris
72 + D1 drivetrain
Member
 
Join Date: Sep 2006
Location: Colonies
Posts: 7,989
A tad inconvenient when you are driving along in the rain and the entire wiper arm flies off. Fortunately, after walking the street and not finding it, (thinking its time to order another from RovahFarm) I spotted it caught between the hood and raised heater intake. Looking at the other one, it's pretty clear I hadn't properly secured with of them on the shaft. A quick tap with a SFH (small frigging hammer) makes this the easiest repair in a while.
Reply With Quote
  #106  
Old October 3rd, 2016, 09:35 AM
FlyersFan76
Status: Offline
Chris
1987 110 Convertible
Member
 
Join Date: Sep 2014
Location: Glen Mills, PA USA
Posts: 283
Registry
Quote:
Originally Posted by Rocky View Post
A tad inconvenient when you are driving along in the rain and the entire wiper arm flies off. Fortunately, after walking the street and not finding it, (thinking its time to order another from RovahFarm) I spotted it caught between the hood and raised heater intake. Looking at the other one, it's pretty clear I hadn't properly secured with of them on the shaft. A quick tap with a SFH (small frigging hammer) makes this the easiest repair in a while.
That happened to me once or twice. Fortunately I had RainX and could still see.
__________________
2011 Range Rover Sport
1987 Land Rover 110 Cabriolet

1997 Defender 90- AA Yellow #1701- Wrecked
1997 Defender 90- AA Yellow #?- Sold
2000 AM General Hummer- Sold
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Lower Navigation
Go Back   Defender Source > Build-up's, Projects & Registry Profiles > Truck Build-up's & Restores

Tags
90, d90

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Multiple D90 Parts discojosh2000 For Sale - Parts 13 November 2nd, 2010 06:35 PM
Wolf wheels, D1, D2, D90 parts (free) Tom B For Sale - Parts 10 August 13th, 2008 12:11 AM
1997, D90 50,000 miles or less JMPDIV82 Defender Technical Discussions 8 October 25th, 2005 09:34 PM
D90 won't start! rover4x4 Defender Technical Discussions 32 June 13th, 2005 07:42 AM
Looking for a wrecked D90 or D90 frame & body mdb77 Defender Technical Discussions 17 January 11th, 2005 08:54 PM


All times are GMT -5. The time now is 04:41 PM.


Copyright