Indicator fault - Defender Source
Defender Source  

Go Back   Defender Source > Community Announcements & Support > Support & Suggestions


Reply
 
Thread Tools
  #1  
Old October 21st, 2013, 05:13 PM
Peachy
Status: Offline
Jason
1984 defender
Member
 
Join Date: Oct 2013
Location: Leicester
Posts: 3
Registry
Smile Indicator fault

Hi can anyone help me? I hAve a 84 110 defender with an intermittent indicator fault,some days it works others it doesn't! I have replace the relay and steering column switch with new components and it still plays up! Should I check anything else. Cheers.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old October 21st, 2013, 06:00 PM
Rocky's Avatar
Rocky
Status: Offline
Chris
72 + D1 drivetrain
Member
 
Join Date: Sep 2006
Location: Colonies Aka Boston
Posts: 8,762
Check the connectors to the bulbs for corrosion and other reasons bulbs don't get juice
__________________
A friend of mine runs a land rover / range rover specialty repair shop. Based on his experience, they are capable of stopping anywhere, anytime, at any cost.

I don't know about the brakes, only their unreliability.
Reply With Quote
  #3  
Old October 21st, 2013, 06:12 PM
leastonce's Avatar
leastonce
Status: Offline
Jason England
D-90 White 95 SW #65
Site Team
 
Join Date: Jul 2009
Location: NYC
Posts: 6,078
Registry
pull the hazzard switch ... if it's slightly depressed the indicators don't work ... assuming you have a square hazzard switch like a NAS truck.
__________________
Quote:
Soapy water / KY jelly, etc. is is basically a must. Yes, good idea to remove trim panels - only takes 5 more minutes to do so.
Car Camping Collective founding member and Chief Executive Officer
Cat Camping Collective founding member and Chief Executive Officer
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old October 21st, 2013, 07:57 PM
Landyman1's Avatar
Landyman1
Status: Offline
Landyman
1983 land rover 110 county
Member
 
Join Date: Apr 2013
Location: Florida, USA
Posts: 205
I tackled this problem in my landy. You have a problem with the hazard switch. This problems is pretty infamous with defenders. The hazard switch routes the power to the indicators as well. First check if any bulbs are burned out. If all is working, then that just means you have a faulty hazard switch. You can just buy one on eBay. Good luck!
Also check out this website, it helped me (one)tons. :D haha get it, one tons (110).....sorry

http://forums.lr4x4.com/index.php?showtopic=25376

Click image for larger version

Name:	image-3647344714.jpg
Views:	93
Size:	437.0 KB
ID:	82585 Click image for larger version

Name:	image-3433921990.jpg
Views:	87
Size:	292.6 KB
ID:	82586
Reply With Quote
  #5  
Old October 22nd, 2013, 02:20 PM
Peachy
Status: Offline
Jason
1984 defender
Member
 
Join Date: Oct 2013
Location: Leicester
Posts: 3
Registry
Thanks for replies I will try it 2 moro.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Community Announcements & Support > Support & Suggestions

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 07:39 PM.


Copyright