d-90.com - Defender Source
Defender Source  

Go Back   Defender Source > Community Announcements & Support > Support & Suggestions


Reply
 
Thread Tools
  #1  
Old April 17th, 2014, 10:10 PM
chris snell's Avatar
chris snell
Status: Offline
Chris Snell
87 Ex-MOD 110
Member
 
Join Date: Aug 2005
Location: Kansas
Posts: 2,439
d-90.com

Looks like you guys made a change to your varnish/apache config recently whereby d-90.com no longer gives a 3xx redirect to defendersource.com:

Code:
% curl -IL http://www.d-90.com
HTTP/1.1 200 OK
Server: Apache/2.2.15
Last-Modified: Fri, 11 Jan 2013 14:38:23 GMT
ETag: "86153b-521-4d3043f5975c0"
Content-Type: text/html; charset=UTF-8
Content-Length: 1313
Date: Fri, 18 Apr 2014 02:06:51 GMT
X-Varnish: 1061232821 1061230122
Age: 69
Via: 1.1 varnish
Connection: keep-alive
X-Cache: HIT
This results in a broken page with broken images--I'm guessing varnish gets 404s on origin fetches.

I like to use d-90.com because it's quicker to type for me when using Chrome's auto-filling address bar. Oh, and it has that awesome old-school feel.
__________________
1987 Ex-MOD 110 Tithonus LHD
2013 LR4


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
/
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
/
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
/
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
/
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old April 17th, 2014, 10:26 PM
ArmyRover's Avatar
ArmyRover
Status: Offline
Bill Ski
83 110 "Frankenstein"
Member
 
Join Date: Jan 2010
Location: Augusta, GA
Posts: 1,617
I still go d-90.com and it works just fine for me.
__________________
"If you can't stand behind our Soldiers, than by all means feel free to stand in front of them"

Unknown Author


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
716-898-8153
Reply With Quote
  #3  
Old April 17th, 2014, 10:29 PM
chris snell's Avatar
chris snell
Status: Offline
Chris Snell
87 Ex-MOD 110
Member
 
Join Date: Aug 2005
Location: Kansas
Posts: 2,439
Quote:
Originally Posted by ArmyRover View Post
I still go d-90.com and it works just fine for me.
You must be behind a caching proxy that's caching the old images. Here's what it looks like for me:



When I fetch the direct link to the image, I get a 404:

Code:
% curl -IL http://d-90.com/forum/images/misc/tag.png
HTTP/1.1 404 Not Found
Server: Apache/2.2.15
Content-Type: text/html; charset=iso-8859-1
Content-Length: 223
Date: Fri, 18 Apr 2014 02:29:07 GMT
X-Varnish: 1061292218 1060167338
Age: 30155
Via: 1.1 varnish
Connection: keep-alive
X-Cache: HIT
__________________
1987 Ex-MOD 110 Tithonus LHD
2013 LR4


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
/
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
/
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
/
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
/
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old April 17th, 2014, 10:57 PM
ArmyRover's Avatar
ArmyRover
Status: Offline
Bill Ski
83 110 "Frankenstein"
Member
 
Join Date: Jan 2010
Location: Augusta, GA
Posts: 1,617
Don't know, I think it forwards me on to defendersource.com
__________________
"If you can't stand behind our Soldiers, than by all means feel free to stand in front of them"

Unknown Author


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
716-898-8153
Reply With Quote
  #5  
Old April 17th, 2014, 11:44 PM
C391HAT's Avatar
C391HAT
Status: Offline
Zach
86 110
Member
 
Join Date: Jul 2013
Location: New Jersey
Posts: 239
Quote:
Originally Posted by JSBriggs View Post
I use d-90.com/forum Not having any redirect issues.

-Jeff
same
Reply With Quote
  #6  
Old April 18th, 2014, 06:43 AM
cellulararrest's Avatar
cellulararrest
Status: Offline
Chris Snyder
1994 D90 #614 | '07 L322 SC
Member
 
Join Date: Feb 2006
Location: Newburyport, MA
Posts: 1,544
I can confirm you're no longer returning a 301.
Code:
curl -I www.d-90.com
HTTP/1.1 200 OK
Server: Apache/2.2.15
Last-Modified: Fri, 11 Jan 2013 14:38:23 GMT
ETag: "86153b-521-4d3043f5975c0"
Content-Type: text/html; charset=UTF-8
Content-Length: 1313
Date: Fri, 18 Apr 2014 10:42:05 GMT
X-Varnish: 1061952586 1061950257
Age: 93
Via: 1.1 varnish
Connection: keep-alive
X-Cache: HIT
Browsers cache 301's pretty heavily. It probably hasn't been like this for very long.
Reply With Quote
  #7  
Old April 18th, 2014, 01:23 PM
C391HAT's Avatar
C391HAT
Status: Offline
Zach
86 110
Member
 
Join Date: Jul 2013
Location: New Jersey
Posts: 239
Quote:
Originally Posted by chris snell View Post
You must be behind a caching proxy that's caching the old images. Here's what it looks like for me:



When I fetch the direct link to the image, I get a 404:

Code:
% curl -IL http://d-90.com/forum/images/misc/tag.png
HTTP/1.1 404 Not Found
Server: Apache/2.2.15
Content-Type: text/html; charset=iso-8859-1
Content-Length: 223
Date: Fri, 18 Apr 2014 02:29:07 GMT
X-Varnish: 1061292218 1060167338
Age: 30155
Via: 1.1 varnish
Connection: keep-alive
X-Cache: HIT
I'm actually having this problem only while browsing on my mobile phone. Same address on the PC doesn't give any issues
Reply With Quote
  #8  
Old April 18th, 2014, 01:58 PM
chris snell's Avatar
chris snell
Status: Offline
Chris Snell
87 Ex-MOD 110
Member
 
Join Date: Aug 2005
Location: Kansas
Posts: 2,439
Quote:
Originally Posted by cellulararrest View Post
I can confirm you're no longer returning a 301.

Browsers cache 301's pretty heavily. It probably hasn't been like this for very long.
Yep. I suspect that the site people recently stood up a varnish cache in front of the app servers.

I'm pretty sure that everyone else will start seeing the problem if they clear their browser cache and cookies and restart their browsers.
__________________
1987 Ex-MOD 110 Tithonus LHD
2013 LR4


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
/
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
/
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
/
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
/
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
  #9  
Old April 18th, 2014, 03:36 PM
smob's Avatar
smob
Status: Offline
Steve
'97 Arles Blue SW #2131
Member
 
Join Date: Aug 2008
Location: Mclean, VA
Posts: 1,619
Registry
Quote:
Originally Posted by chris snell View Post
Yep. I suspect that the site people recently stood up a varnish cache in front of the app servers.

I'm pretty sure that everyone else will start seeing the problem if they clear their browser cache and cookies and restart their browsers.
Seeing it. Mildly annoying.
__________________
"Land Rover = rolling mechanical failure. it is failing even as it sits in the driveway. get used to it. My 90 just had a failure as I was typing this."
-Ren Ching
Reply With Quote
  #10  
Old April 18th, 2014, 06:31 PM
Janet H's Avatar
Janet H
Status: Offline
Janet H
Still Looking....
Site Team
 
Join Date: Aug 2011
Location: Eastern WA, USA
Posts: 827
Thanks for posting about this - you should see some improvement
__________________
,

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
  #11  
Old April 18th, 2014, 10:50 PM
chris snell's Avatar
chris snell
Status: Offline
Chris Snell
87 Ex-MOD 110
Member
 
Join Date: Aug 2005
Location: Kansas
Posts: 2,439
Thanks, works as expected now.
__________________
1987 Ex-MOD 110 Tithonus LHD
2013 LR4


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
/
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
/
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
/
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
/
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
  #12  
Old April 19th, 2014, 09:32 AM
Baldewin's Avatar
Baldewin
Status: Offline
Chris Baldewin
Bastard 90
Member
 
Join Date: Aug 2006
Location: Republican Sanctuary of CA
Posts: 877
Not sure if this is related but every time I refresh I have to relog in now?
__________________
Chris
“Don't judge a man until you have walked a mile in his shoes”
Reply With Quote
  #13  
Old April 19th, 2014, 10:21 AM
Rocky's Avatar
Rocky
Status: Offline
Chris
72 + D1 drivetrain
Member
 
Join Date: Sep 2006
Location: Colonies Aka Boston
Posts: 8,762
Had that happen for a day after I looked at d-90.com.
Coincidence?
__________________
A friend of mine runs a land rover / range rover specialty repair shop. Based on his experience, they are capable of stopping anywhere, anytime, at any cost.

I don't know about the brakes, only their unreliability.
Reply With Quote
  #14  
Old April 19th, 2014, 12:03 PM
chris snell's Avatar
chris snell
Status: Offline
Chris Snell
87 Ex-MOD 110
Member
 
Join Date: Aug 2005
Location: Kansas
Posts: 2,439
What browser, guys? I've had this happen periodically on a number of vbulletin sites but I believe it to be a regression in Chrome for iOS, not a VB problem. I reported it as a Chrome bug and it's gotten a little better.
__________________
1987 Ex-MOD 110 Tithonus LHD
2013 LR4


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
/
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
/
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
/
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
/
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
  #15  
Old April 19th, 2014, 02:01 PM
Baldewin's Avatar
Baldewin
Status: Offline
Chris Baldewin
Bastard 90
Member
 
Join Date: Aug 2006
Location: Republican Sanctuary of CA
Posts: 877
Mac, Safari V6.1 and I do have the box checked for remember me.

------ Follow up post added April 19th, 2014 11:09 AM ------

And now it's back to normal. The other thing I noticed when it was happening is the forum Icon on the top of the page wasn't in it's normal location of top left. It was 2nd from the left in the middle row.
__________________
Chris
“Don't judge a man until you have walked a mile in his shoes”
Reply With Quote
  #16  
Old April 19th, 2014, 02:15 PM
Rocky's Avatar
Rocky
Status: Offline
Chris
72 + D1 drivetrain
Member
 
Join Date: Sep 2006
Location: Colonies Aka Boston
Posts: 8,762
Chrome on PC. Tapatalk on iPhone.
__________________
A friend of mine runs a land rover / range rover specialty repair shop. Based on his experience, they are capable of stopping anywhere, anytime, at any cost.

I don't know about the brakes, only their unreliability.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Community Announcements & Support > Support & Suggestions

Tags
90, d-90

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Defender Registry

Coyote

Ray_G

26.2

laurentv1
Add your Defender

All times are GMT -5. The time now is 04:38 AM.


Copyright