Starting issues - Defender Source
Defender Source  

Go Back   Defender Source > Non-Technical Discussions > Misc. Chit-Chat


Reply
 
Thread Tools
  #1  
Old January 19th, 2014, 07:52 PM
usmcxd's Avatar
usmcxd
Status: Offline
Matt George
97 disco-Sold :(
Member
 
Join Date: Nov 2011
Location: CPEN, CA.
Posts: 92
Registry
Starting issues

So...the back story.... Went out today with a buddy and I got 'delayed' in a mud pit. After getting out I had to jump start my disco(97). Started and ran just fine, got home and parked it. I just tried to start it and it turned over, didn't start. I tried again and nothing. No clicking, lights didn't dim. Just nothing. Any suggestions?

Thanks in advance.


--Matt--
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old January 19th, 2014, 08:03 PM
Ray_G's Avatar
Ray_G
Status: Offline
Ray Gerber
54 S1 86", 96 D1 (Coyote), 06 D3
Member
 
Join Date: Dec 2007
Location: NoVA
Posts: 2,636
Registry
Quote:
Originally Posted by usmcxd View Post
So...the back story.... Went out today with a buddy and I got 'delayed' in a mud pit. After getting out I had to jump start my disco(97). Started and ran just fine, got home and parked it. I just tried to start it and it turned over, didn't start. I tried again and nothing. No clicking, lights didn't dim. Just nothing. Any suggestions?

Thanks in advance.

--Matt--
Check the wires connected to the starter.
Reply With Quote
  #3  
Old January 19th, 2014, 08:24 PM
usmcxd's Avatar
usmcxd
Status: Offline
Matt George
97 disco-Sold :(
Member
 
Join Date: Nov 2011
Location: CPEN, CA.
Posts: 92
Registry
They look ok. But its a bit dark, ill look at them better in the light.

I went back out to try starting again, once again turned over, then nothing.
Could it be the ecu?
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old January 19th, 2014, 08:38 PM
Wolf Fabrication's Avatar
Wolf Fabrication
Status: Offline
Sterling Archer
'08 D3
D-90 Source Vendor
 
Join Date: Sep 2007
Location: Oahu, HI
Posts: 7,453
Registry
Quote:
Originally Posted by usmcxd View Post
So...the back story.... Went out today with a buddy and I got 'delayed' in a mud pit.
Pics or it didn't happen.
__________________
"The most unreliable car in the world is the most reliable car in the world." -Jeremy Clarkson refering to the Range Rover


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Semper Fi!
Reply With Quote
  #5  
Old January 19th, 2014, 08:59 PM
usmcxd's Avatar
usmcxd
Status: Offline
Matt George
97 disco-Sold :(
Member
 
Join Date: Nov 2011
Location: CPEN, CA.
Posts: 92
Registry
I also noticed that the locking system is on tje fritz. And there is a clicking near the glove box...

Ill post the pics and video when i get them...
Reply With Quote
  #6  
Old January 19th, 2014, 09:29 PM
Wolf Fabrication's Avatar
Wolf Fabrication
Status: Offline
Sterling Archer
'08 D3
D-90 Source Vendor
 
Join Date: Sep 2007
Location: Oahu, HI
Posts: 7,453
Registry
Quote:
Originally Posted by usmcxd View Post
I also noticed that the locking system is on tje fritz. And there is a clicking near the glove box... Ill post the pics and video when i get them...
How deep was the water/mud? Did any water enter the cabin? Sounds like you might just have some wet/corroded connections IVO the starter. What the voltage at the battery?
__________________
"The most unreliable car in the world is the most reliable car in the world." -Jeremy Clarkson refering to the Range Rover


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Semper Fi!
Reply With Quote
  #7  
Old January 22nd, 2014, 04:29 AM
Wolf Fabrication's Avatar
Wolf Fabrication
Status: Offline
Sterling Archer
'08 D3
D-90 Source Vendor
 
Join Date: Sep 2007
Location: Oahu, HI
Posts: 7,453
Registry
How's your truck?
Attached Thumbnails
Click image for larger version

Name:	image-3837550698.jpg
Views:	47
Size:	433.5 KB
ID:	88347   Click image for larger version

Name:	image-2033664680.jpg
Views:	52
Size:	439.1 KB
ID:	88348  

__________________
"The most unreliable car in the world is the most reliable car in the world." -Jeremy Clarkson refering to the Range Rover


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Semper Fi!
Reply With Quote
  #8  
Old January 22nd, 2014, 11:11 AM
usmcxd's Avatar
usmcxd
Status: Offline
Matt George
97 disco-Sold :(
Member
 
Join Date: Nov 2011
Location: CPEN, CA.
Posts: 92
Registry
Its good now, just need to waterproof everything.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Non-Technical Discussions > Misc. Chit-Chat

Tags
start, starting

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting Issues with my D90 2.5td couga861900 Defender Technical Discussions 13 March 20th, 2013 12:39 AM
300 Tdi Starting Issues discotdi Defender Technical Discussions 12 January 20th, 2009 11:04 PM
D90 starting issues - could it be Snorkel related? pmd Defender Technical Discussions 7 January 9th, 2009 12:47 PM
Just an FYI on starting & fueling issues Doug Defender Technical Discussions 1 November 4th, 2004 05:34 PM

» Defender Registry

'94 D90

cbcarlino

110

Mes788
Add your Defender

All times are GMT -5. The time now is 08:30 PM.


Copyright