Over temp indications??? - Defender Source
Defender Source  

Go Back   Defender Source > Non-Technical Discussions > Misc. Chit-Chat


Reply
 
Thread Tools
  #1  
Old August 14th, 2013, 05:09 AM
GuamPilot's Avatar
GuamPilot
Status: Offline
Mike & Carrie Wendt
1986 90 2.5NA
Member
 
Join Date: Mar 2013
Location: Guam & San Bruno
Posts: 605
Registry
Over temp indications???

This is on my '97 D1.

The temp gage is pegged. Using an infrared thermometer the thermostat housing shows 250 while the top hose shows 170, mid-length to the radiator.

Ergo, I need a new thermostat. Correct?

Thanks,

Mike
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old August 14th, 2013, 07:56 AM
Antichrist's Avatar
Antichrist
Status: Offline
Tom Rowe
Defender/Disco/Series/MoD
Member
 
Join Date: Feb 2006
Location: Atlanta, GA USA
Posts: 1,280
I don't know what they sell in Guam, but be sure you get the 88c OE or a 180f if it's a thermostat from the US.
All the books list a 195 in the US which is too hot. US thermostat temps are when they start to open, not when they are fully open, like the 88 OE is.
__________________
Tom Rowe
Atlanta, GA

Four wheel drive allows you to get stuck
in places even more inaccessible.

62 88 Regular
67 109 6cyl NADA x2
74 Lightweight - The Antichrist
95 DI 5-speed
95 D90 5-speed
97 D1 Automatic
Reply With Quote
  #3  
Old August 14th, 2013, 09:48 AM
GuamPilot's Avatar
GuamPilot
Status: Offline
Mike & Carrie Wendt
1986 90 2.5NA
Member
 
Join Date: Mar 2013
Location: Guam & San Bruno
Posts: 605
Registry
Everything in Guam is U.S. standard.

If the local Rover dealer has one, I will assume they have the correct one. If I have to buy from NAPA, I will ask for the 180.

Mike

Quote:
Originally Posted by Antichrist View Post
I don't know what they sell in Guam, but be sure you get the 88c OE or a 180f if it's a thermostat from the US.
All the books list a 195 in the US which is too hot. US thermostat temps are when they start to open, not when they are fully open, like the 88 OE is.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Non-Technical Discussions > Misc. Chit-Chat

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wont run at temp Neo Defender Technical Discussions 12 February 24th, 2006 06:54 PM
Thread size for temp sender mgrgpg Defender Technical Discussions 3 July 1st, 2004 12:00 PM
water temp stabilizer switch david jenson Defender Technical Discussions 1 June 16th, 2004 08:50 PM
LR Glow Plug relay temp? dmarchand Defender Technical Discussions 0 June 9th, 2004 01:42 PM
ZF trans temp? dmarchand Defender Technical Discussions 2 May 17th, 2004 10:45 AM


All times are GMT -5. The time now is 07:10 PM.


Copyright