man this is bad timing - Page 4 - Defender Source
Defender Source  

Go Back   Defender Source > Non-Technical Discussions > Misc. Chit-Chat

Join the Defender Source Community Today

Thread Tools
Old December 20th, 2012, 04:23 PM
koltonstanley's Avatar
Status: Offline
Kolton Stanley
defender 130 hi cap
Join Date: Sep 2012
Location: Ocean,NJ
Posts: 401
thats what i though although they said there was grease on the bolt like he was having a hard time with it and then i guess never got it right.......but even if only the other two bolts where tight id think it would be fine.

either way i was happy when they told me only needed a new starter.....

Reply With Quote

Lower Navigation
Go Back   Defender Source > Non-Technical Discussions > Misc. Chit-Chat

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Symptoms of a bad axle CV joint? Hans Defender Technical Discussions 16 April 6th, 2007 12:20 PM
Need Help For Bad Handling...(I mean BAD!) Cube II Defender Technical Discussions 18 July 7th, 2006 08:07 AM
Cams, lifters, timing chains vesparover For Sale - Parts 11 March 10th, 2006 11:20 PM
Timing and Overheating mkerr2112 Defender Technical Discussions 10 July 6th, 2005 08:31 AM
bad bad BAD noise rover4x4 Defender Technical Discussions 11 December 12th, 2003 12:44 AM

All times are GMT -5. The time now is 08:57 PM.