Fuel Pump Prime? - Defender Source
Defender Source  

Go Back   Defender Source > Non-Technical Discussions > Misc. Chit-Chat

Join the Defender Source Community Today

Thread Tools
Old October 26th, 2015, 05:13 PM
RhinoRover's Avatar
Status: Offline
1986 D110
Join Date: Sep 2014
Location: Palmer Lake, CO USA
Posts: 190
Fuel Pump Prime?

Just installed a new gas tank and fuel pump into my 110 and a few gallons of gas. Pump comes on for a few seconds in the ignition "on" position and then turns off. However, it sounds like it's running dry and I'm not receiving fuel at the fuel rails. Do I need to prime the pump??

Reply With Quote
Old October 26th, 2015, 06:06 PM
rover2a's Avatar
Status: Offline
Gar Hendry
1967 series2a
Join Date: Aug 2015
Location: Salt Lake City
Posts: 23
If it is like my Disco it primes the system and shuts off the engine has to be running for it to run continuously, this will help when trying to measure the fuel pressure at the rail.
Reply With Quote

Lower Navigation
Go Back   Defender Source > Non-Technical Discussions > Misc. Chit-Chat


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil Pump Prime??? Nigel Defender Technical Discussions 8 March 28th, 2011 03:23 PM
Fuel pump no prime? Check the connectors! Neil McCauley Defender Technical Discussions 2 January 12th, 2010 12:53 PM
Dropping gas tank on 110 again, fuel pump does not prime Neil McCauley Defender Technical Discussions 7 October 14th, 2009 09:25 PM
How do you Prime the oil pump?? redrockrover Defender Technical Discussions 2 June 8th, 2009 08:47 AM
Oil pump will not prime... greend90SW Defender Technical Discussions 8 April 13th, 2006 07:46 PM

All times are GMT -5. The time now is 03:47 PM.