NoVa Happy Hour - 3rd Thurs Monthly - Page 315 - Defender Source
Defender Source  

Go Back   Defender Source > Non-Technical Discussions > Trips, Trails and Events

Join the Defender Source Community Today
Reply
 
Thread Tools
  #6281  
Old May 21st, 2016, 03:29 PM
85Red110's Avatar
85Red110
Status: Offline
Kent
1985 110 3-door
Member
 
Join Date: Apr 2012
Location: Springfield, VA USA
Posts: 641
Registry
Quote:
Originally Posted by carlosz View Post

Lack there of or failure of speed sensor will cause the odd bank to go into Rev limiter mode, thus emulating your simptoms. This should be located as a box with wires coming out of the t case and speedometer cable.
If you have cats and you continue to drive you will kill them, if all you have is 02 sensors you're a step ahead of the game as there is no fear of damaged cats....
I have no speed sensor. Was told I didn't require it.

It's the odd bank that's getting fuel, and burning rich. The even bank may not be getting fuel at all.
__________________
1985 Land Rover 110 3-door ST
Reply With Quote
Sponsored Links
Advertisement
 
  #6282  
Old May 21st, 2016, 03:52 PM
down_shift's Avatar
down_shift
Status: Online
Russell
94' D90 ST & 06' LR3
Member
 
Join Date: Sep 2011
Location: Leesburg, VA
Posts: 3,816
Registry
Quote:
Originally Posted by 85Red110 View Post
Temp difference between the two sides is significant. Even # cylinders are still hot though, so they are definitely firing, but just running really clean.
How significant?
Reply With Quote
Sponsored Links
Advertisement
 
  #6283  
Old May 21st, 2016, 04:37 PM
85Red110's Avatar
85Red110
Status: Offline
Kent
1985 110 3-door
Member
 
Join Date: Apr 2012
Location: Springfield, VA USA
Posts: 641
Registry
Problem solved! Lav brought the ECU from his 90 over, and BAM! Truck runs perfect. Now to source a new ECU. Anybody have one that you know works? AMR3947R is the serial on Lavs.

Thanks to everyone for their input and help. Gotta love this community. You guys are great! Let's go wheeling, gentlemen.

Kent
__________________
1985 Land Rover 110 3-door ST
Reply With Quote
  #6284  
Old May 21st, 2016, 05:07 PM
Rover Lover's Avatar
Rover Lover
Status: Offline
Ron Dade
97/D90 Soft Top
Member
 
Join Date: Apr 2013
Location: Washington, DC
Posts: 233
Quote:
Originally Posted by 85Red110 View Post
Problem solved! Lav brought the ECU from his 90 over, and BAM! Truck runs perfect. Now to source a new ECU. Anybody have one that you know works? AMR3947R is the serial on Lavs.

Thanks to everyone for their input and help. Gotta love this community. You guys are great! Let's go wheeling, gentlemen.

Kent
Glad you got it sorted, Kent!
Reply With Quote
  #6285  
Old May 21st, 2016, 06:34 PM
Jymmiejamz's Avatar
Jymmiejamz
Status: Offline
Jimmy
1995 D90 SW #365
Member
 
Join Date: Sep 2010
Location: Brooklyn, NY
Posts: 3,455
Registry
Quote:
Originally Posted by 85Red110 View Post
Problem solved! Lav brought the ECU from his 90 over, and BAM! Truck runs perfect. Now to source a new ECU. Anybody have one that you know works? AMR3947R is the serial on Lavs.

Thanks to everyone for their input and help. Gotta love this community. You guys are great! Let's go wheeling, gentlemen.

Kent
Open yours up and see if it is full of corrosion.
__________________
Car Camping Collective founding member and Treasurer
Reply With Quote
  #6286  
Old May 21st, 2016, 06:47 PM
nathanwind's Avatar
nathanwind
Status: Online
Jason Lavender
88-90-127-LR3
D-90 Source Vendor
 
Join Date: Jan 2008
Location: Alexandria VA/Bolton NY
Posts: 8,499
Registry
Quote:
Originally Posted by Jymmiejamz View Post
Open yours up and see if it is full of corrosion.
Jimmy - he's thinking his ECU is from a 4.2 RRC, would that be "compatible" with his 3.9 setup? Or would corrosion be the more likely cause?
__________________
Jason Lavender
'71 Series IIA
'88 127 #F96 DKN
'94 90 NAS #324
'06 LR3 HSE

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

(10% discount for DSource members, use coupon code "D90")

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
  #6287  
Old May 21st, 2016, 06:49 PM
Jymmiejamz's Avatar
Jymmiejamz
Status: Offline
Jimmy
1995 D90 SW #365
Member
 
Join Date: Sep 2010
Location: Brooklyn, NY
Posts: 3,455
Registry
Quote:
Originally Posted by nathanwind View Post
Jimmy - he's thinking his ECU is from a 4.2 RRC, would that be "compatible" with his 3.9 setup? Or would corrosion be the more likely cause?
It should run fine with the 4.2 ECU. I've only ever seen corrosion cause issues with those as far as I can remember, but I'm no 14CUX guru.
__________________
Car Camping Collective founding member and Treasurer
Reply With Quote
  #6288  
Old May 21st, 2016, 07:12 PM
85Red110's Avatar
85Red110
Status: Offline
Kent
1985 110 3-door
Member
 
Join Date: Apr 2012
Location: Springfield, VA USA
Posts: 641
Registry
Quote:
Originally Posted by Jymmiejamz View Post

Open yours up and see if it is full of corrosion.
I'll crack it open tomorrow
__________________
1985 Land Rover 110 3-door ST
Reply With Quote
  #6289  
Old May 21st, 2016, 07:14 PM
carlosz's Avatar
carlosz
Status: Offline
Carlos
frank stein "frankie" in action RIP
Member
 
Join Date: Jun 2006
Location: east coast
Posts: 872
Registry
Quote:
Originally Posted by 85Red110 View Post

I have no speed sensor. Was told I didn't require it.

It's the odd bank that's getting fuel, and burning rich. The even bank may not be getting fuel at all.
Kent, glad to read you got it going...14 cux box is very stout it's only the second I hear has failed in many years.
As per speed sensor it is supposed to help keep idle and it is possible someone fooled the system by using some kind of potentiometer or resistor...In any manner if it runs don't hunt for ghosts.
This ecu are very cheap on ebay as just about any English v8 running efi uses them.
At one time I had about 6 of them collecting dust...all are gone now...damn, sorry I cannot offer better...
On my 87 rr I tucked the ecu under the dash after a failed deep water crossing...it never failed again due to wetness, or you could seal it with silicone and a zip lock baggie.
Many tricks to keep it dry if that was the cause of your failure.
__________________
[I][/Ithe truck ran like a "raped ape"
Reply With Quote
  #6290  
Old May 21st, 2016, 07:54 PM
cgalpin's Avatar
cgalpin
Status: Offline
Charles Galpin
'94 D90 ST, '63 SeriesIIA
Site Team
 
Join Date: Jan 2004
Location: South Riding, VA
Posts: 11,565
Registry
I thought I told you earlier I have an ecu here you can have. The ecu is the last thing I work have suspected though! First thing I would check is corrosion on the pins, but they are easy to open and see.
__________________
Quote:
Originally Posted by pendy
I'm here for the D's
Reply With Quote
  #6291  
Old May 21st, 2016, 08:19 PM
Nomar's Avatar
Nomar
Status: Offline
Jeff B
RR HNTR,RR LWB Tdi
Member
 
Join Date: Aug 2004
Location: Central,Virginia
Posts: 3,827
Registry
Just an FYI, some 14CUX( pronounced SUCKS) boxes had an inherent solder flaw from the factory when new.

I had one.

Otherwise, there isnt an issue running a 4.2 ECU with a 3.9; I've done it plenty---gave me an extra .008% horsepower!


.
__________________


Real Rovers have round headlights!
Rent my
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
!
Just a few miles from 4x4 access!
Reply With Quote
  #6292  
Old May 21st, 2016, 08:29 PM
85Red110's Avatar
85Red110
Status: Offline
Kent
1985 110 3-door
Member
 
Join Date: Apr 2012
Location: Springfield, VA USA
Posts: 641
Registry
Yea, I'm glad any of the 14cux ecu's will work. Mine is likely corroded pretty bad, as it looks a bit nasty even on the outside. Charles, I'd be happy to buy your spare off you if mine is totally F'ed.

By the way, in your exact words, the truck ran like a "raped ape" with Lavs good ECU in it. I couldn't believe it.
__________________
1985 Land Rover 110 3-door ST
Reply With Quote
  #6293  
Old May 21st, 2016, 08:56 PM
nathanwind's Avatar
nathanwind
Status: Online
Jason Lavender
88-90-127-LR3
D-90 Source Vendor
 
Join Date: Jan 2008
Location: Alexandria VA/Bolton NY
Posts: 8,499
Registry
Quote:
Originally Posted by 85Red110 View Post
Yea, I'm glad any of the 14cux ecu's will work. Mine is likely corroded pretty bad, as it looks a bit nasty even on the outside. Charles, I'd be happy to buy your spare off you if mine is totally F'ed.

By the way, in your exact words, the truck ran like a "raped ape" with Lavs good ECU in it. I couldn't believe it.
True dat. You came back with a huge smile on your face!
__________________
Jason Lavender
'71 Series IIA
'88 127 #F96 DKN
'94 90 NAS #324
'06 LR3 HSE

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

(10% discount for DSource members, use coupon code "D90")

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
  #6294  
Old May 21st, 2016, 10:17 PM
Ray_G's Avatar
Ray_G
Status: Offline
Ray Gerber
96 D1 (Coyote), 06 D3
Member
 
Join Date: Dec 2007
Location: NoVA
Posts: 2,553
Registry
Quote:
Originally Posted by o2batsea View Post
Is known good. O2 sensors not in play in this It does appear that the right bank is not fueling
Sometimes known good ends up being not good; I suggested it because I have seen when a known good ECU that had previously worked fine end up being the culprit. As these things age, corrode, etc it happens.

Glad the truck got sorted.
Reply With Quote
  #6295  
Old May 22nd, 2016, 10:11 AM
Uncle Douglas's Avatar
Uncle Douglas
Status: Offline
Doug Crowther
A defender in every driveway-motto
D-90 Source Vendor
 
Join Date: Dec 2007
Location: Gods Country- Central Virginia
Posts: 11,267
Registry
4.2 ecu is plug and play for a 3.9
__________________
Good judgement comes from experience,experience comes from bad judgement.

Dividing Creek Imports
Worldwide Land Rover Shipment and Importation Service
Bespoke Restoration & Modification work


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

410.693.1391


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
  #6296  
Old May 22nd, 2016, 10:17 AM
85Red110's Avatar
85Red110
Status: Offline
Kent
1985 110 3-door
Member
 
Join Date: Apr 2012
Location: Springfield, VA USA
Posts: 641
Registry
Quote:
Originally Posted by Uncle Douglas View Post
4.2 ecu is plug and play for a 3.9
Other that being a little dirty on the outside, this thing looks perfect. Inside, the board looks brand new. No corrosion, burnt or broken connections, that I can tell. Maybe a chip is bad somewhere.



Click image for larger version

Name:	ForumRunner_20160522_101623.png
Views:	49
Size:	459.1 KB
ID:	150008



Click image for larger version

Name:	ForumRunner_20160522_101635.png
Views:	44
Size:	513.5 KB
ID:	150009



Click image for larger version

Name:	ForumRunner_20160522_101646.png
Views:	46
Size:	638.5 KB
ID:	150010



Click image for larger version

Name:	ForumRunner_20160522_101654.png
Views:	55
Size:	653.6 KB
ID:	150011
__________________
1985 Land Rover 110 3-door ST
Reply With Quote
  #6297  
Old May 22nd, 2016, 10:37 AM
carlosz's Avatar
carlosz
Status: Offline
Carlos
frank stein "frankie" in action RIP
Member
 
Join Date: Jun 2006
Location: east coast
Posts: 872
Registry
the truck ran like a "raped ape"

I love that phrase...lol.
Reply With Quote
  #6298  
Old May 22nd, 2016, 11:45 AM
Kevin88RRC's Avatar
Kevin88RRC
Status: Offline
Kevin Keith
1988 RRC
Member
 
Join Date: Dec 2014
Location: Portland, Maine
Posts: 758
You can check the eprom chip under the black Lucas box. It should have a a sticker noting which fuel map it is and it should match the sticker on the case stating 3361.... "Range Rover Classic 4.2 Desensitized OBD 95 MY Tune".

I have two 14cux. Both supposedly from RR 4.2s. The AMR2941 has map 3102 "Range Rover Classic 4.2 High CR Low Reed Vapor Pressure fuel tune" and the other AMR2943 has map 3100 for a 3.9. I had been running the first but tried the 3.9 map yesterday. It seemed to run my 3.5 better. Would be interested to try one of 92rrrandall's remapped chips for a 4.6.

There's a 52 page thread over on Pistonheads about remapping a 14cux. Way over my head though.
Reply With Quote
  #6299  
Old May 22nd, 2016, 05:14 PM
85Red110's Avatar
85Red110
Status: Offline
Kent
1985 110 3-door
Member
 
Join Date: Apr 2012
Location: Springfield, VA USA
Posts: 641
Registry
For the record, Galpin has a spare ECU with the same serial # as mine (AMR1423). He tested it in his 90, and it ran like s#!%. I don't think this is a compatible ECU for a 3.9 v8
__________________
1985 Land Rover 110 3-door ST
Reply With Quote
  #6300  
Old June 2nd, 2016, 10:35 AM
Rover Lover's Avatar
Rover Lover
Status: Offline
Ron Dade
97/D90 Soft Top
Member
 
Join Date: Apr 2013
Location: Washington, DC
Posts: 233
Rover Porn Alert!!! Check this out!!!
https://www.instagram.com/independentllc/
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Lower Navigation
Go Back   Defender Source > Non-Technical Discussions > Trips, Trails and Events

Tags
dementia, disturbing, dood, gay nachos, happy hour, nova, pathetic, third thursday monthly, virginia is for lovers

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New & Improved NOVA Happy Hour Thread Wolf Fabrication Trips, Trails and Events 103 May 1st, 2008 08:41 AM
Happy Hour in Nova? Bozman Trips, Trails and Events 125 June 25th, 2007 04:17 PM
Happy Hour in NoVa? Eric N Trips, Trails and Events 40 November 8th, 2006 03:44 PM
Happy Hour in NoVA loykd Trips, Trails and Events 163 September 14th, 2006 08:28 AM
Happy Hour in NoVA loykd Trips, Trails and Events 6 August 12th, 2004 04:09 PM


All times are GMT -5. The time now is 03:07 PM.


Copyright