NoVa Happy Hour - 3rd Thurs Monthly - Page 311 - Defender Source
Defender Source  

Go Back   Defender Source > Non-Technical Discussions > Trips, Trails and Events


Reply
 
Thread Tools
  #6201  
Old May 21st, 2016, 01:23 PM
o2batsea's Avatar
o2batsea
Status: Offline
Bill Adams
66 109 sw 94 lwb
Member
 
Join Date: Jul 2009
Location: kensington md
Posts: 6,478
Registry
Is known good. O2 sensors not in play in this
It does appear that the right bank is not fueling
__________________
Bill Adams

1966 109 5 door wagon 300Tdi "spermaceti fueled"
1994 RRC LeWiB "ruining the air behind me"
1968 2A 88

All my troubles are Rover
Reply With Quote
Sponsored Links
Advertisement
 
  #6202  
Old May 21st, 2016, 03:08 PM
carlosz's Avatar
carlosz
Status: Offline
Carlos
frank stein "frankie" in action RIP
Member
 
Join Date: Jun 2006
Location: east coast
Posts: 952
Registry
Quote:
Originally Posted by 85Red110 View Post

I switched the O2 sensors, and the results were the same.
Lack there of or failure of speed sensor will cause the odd bank to go into Rev limiter mode, thus emulating your simptoms. This should be located as a box with wires coming out of the t case and speedometer cable.
If you have cats and you continue to drive you will kill them, if all you have is 02 sensors you're a step ahead of the game as there is no fear of damaged cats....
__________________
the truck ran like a "raped ape"
A fussy warm weather creature...
Reply With Quote
  #6203  
Old May 21st, 2016, 03:29 PM
85Red110's Avatar
85Red110
Status: Offline
Kent
1985 110 3-door
Member
 
Join Date: Apr 2012
Location: Springfield, VA USA
Posts: 710
Registry
Quote:
Originally Posted by carlosz View Post

Lack there of or failure of speed sensor will cause the odd bank to go into Rev limiter mode, thus emulating your simptoms. This should be located as a box with wires coming out of the t case and speedometer cable.
If you have cats and you continue to drive you will kill them, if all you have is 02 sensors you're a step ahead of the game as there is no fear of damaged cats....
I have no speed sensor. Was told I didn't require it.

It's the odd bank that's getting fuel, and burning rich. The even bank may not be getting fuel at all.
__________________
1985 Land Rover 110 3-door ST
Reply With Quote
Sponsored Links
Advertisement
 
  #6204  
Old May 21st, 2016, 03:52 PM
down_shift's Avatar
down_shift
Status: Offline
Russell
94' D90 ST & 06' LR3
Member
 
Join Date: Sep 2011
Location: Leesburg, VA
Posts: 4,114
Registry
Quote:
Originally Posted by 85Red110 View Post
Temp difference between the two sides is significant. Even # cylinders are still hot though, so they are definitely firing, but just running really clean.
How significant?
Reply With Quote
  #6205  
Old May 21st, 2016, 04:37 PM
85Red110's Avatar
85Red110
Status: Offline
Kent
1985 110 3-door
Member
 
Join Date: Apr 2012
Location: Springfield, VA USA
Posts: 710
Registry
Problem solved! Lav brought the ECU from his 90 over, and BAM! Truck runs perfect. Now to source a new ECU. Anybody have one that you know works? AMR3947R is the serial on Lavs.

Thanks to everyone for their input and help. Gotta love this community. You guys are great! Let's go wheeling, gentlemen.

Kent
__________________
1985 Land Rover 110 3-door ST
Reply With Quote
  #6206  
Old May 21st, 2016, 05:07 PM
Rover Lover's Avatar
Rover Lover
Status: Offline
Ron Dade
97/D90 Soft Top
Member
 
Join Date: Apr 2013
Location: Washington, DC
Posts: 305
Quote:
Originally Posted by 85Red110 View Post
Problem solved! Lav brought the ECU from his 90 over, and BAM! Truck runs perfect. Now to source a new ECU. Anybody have one that you know works? AMR3947R is the serial on Lavs.

Thanks to everyone for their input and help. Gotta love this community. You guys are great! Let's go wheeling, gentlemen.

Kent
Glad you got it sorted, Kent!
Reply With Quote
  #6207  
Old May 21st, 2016, 06:34 PM
Jymmiejamz's Avatar
Jymmiejamz
Status: Offline
Jimmy
1995 D90 SW #365
Member
 
Join Date: Sep 2010
Location: Brooklyn, NY
Posts: 3,468
Registry
Quote:
Originally Posted by 85Red110 View Post
Problem solved! Lav brought the ECU from his 90 over, and BAM! Truck runs perfect. Now to source a new ECU. Anybody have one that you know works? AMR3947R is the serial on Lavs.

Thanks to everyone for their input and help. Gotta love this community. You guys are great! Let's go wheeling, gentlemen.

Kent
Open yours up and see if it is full of corrosion.
__________________
Car Camping Collective founding member and Treasurer
Reply With Quote
  #6208  
Old May 21st, 2016, 06:47 PM
nathanwind's Avatar
nathanwind
Status: Offline
Jason Lavender
88-90-127-LR3
D-90 Source Vendor
 
Join Date: Jan 2008
Location: Saratoga NY
Posts: 8,736
Registry
Quote:
Originally Posted by Jymmiejamz View Post
Open yours up and see if it is full of corrosion.
Jimmy - he's thinking his ECU is from a 4.2 RRC, would that be "compatible" with his 3.9 setup? Or would corrosion be the more likely cause?
__________________
Jason Lavender
'71 Series IIA
'88 127 #F96 DKN
'94 90 NAS #324
'06 LR3 HSE

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

(10% discount for DSource members, use coupon code "D90")

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
  #6209  
Old May 21st, 2016, 06:49 PM
Jymmiejamz's Avatar
Jymmiejamz
Status: Offline
Jimmy
1995 D90 SW #365
Member
 
Join Date: Sep 2010
Location: Brooklyn, NY
Posts: 3,468
Registry
Quote:
Originally Posted by nathanwind View Post
Jimmy - he's thinking his ECU is from a 4.2 RRC, would that be "compatible" with his 3.9 setup? Or would corrosion be the more likely cause?
It should run fine with the 4.2 ECU. I've only ever seen corrosion cause issues with those as far as I can remember, but I'm no 14CUX guru.
__________________
Car Camping Collective founding member and Treasurer
Reply With Quote
  #6210  
Old May 21st, 2016, 07:12 PM
85Red110's Avatar
85Red110
Status: Offline
Kent
1985 110 3-door
Member
 
Join Date: Apr 2012
Location: Springfield, VA USA
Posts: 710
Registry
Quote:
Originally Posted by Jymmiejamz View Post

Open yours up and see if it is full of corrosion.
I'll crack it open tomorrow
__________________
1985 Land Rover 110 3-door ST
Reply With Quote
  #6211  
Old May 21st, 2016, 07:14 PM
carlosz's Avatar
carlosz
Status: Offline
Carlos
frank stein "frankie" in action RIP
Member
 
Join Date: Jun 2006
Location: east coast
Posts: 952
Registry
Quote:
Originally Posted by 85Red110 View Post

I have no speed sensor. Was told I didn't require it.

It's the odd bank that's getting fuel, and burning rich. The even bank may not be getting fuel at all.
Kent, glad to read you got it going...14 cux box is very stout it's only the second I hear has failed in many years.
As per speed sensor it is supposed to help keep idle and it is possible someone fooled the system by using some kind of potentiometer or resistor...In any manner if it runs don't hunt for ghosts.
This ecu are very cheap on ebay as just about any English v8 running efi uses them.
At one time I had about 6 of them collecting dust...all are gone now...damn, sorry I cannot offer better...
On my 87 rr I tucked the ecu under the dash after a failed deep water crossing...it never failed again due to wetness, or you could seal it with silicone and a zip lock baggie.
Many tricks to keep it dry if that was the cause of your failure.
__________________
the truck ran like a "raped ape"
A fussy warm weather creature...
Reply With Quote
  #6212  
Old May 21st, 2016, 07:54 PM
cgalpin's Avatar
cgalpin
Status: Offline
Charles Galpin
'94 D90 ST, '63 SeriesIIA
Site Team
 
Join Date: Jan 2004
Location: South Riding, VA
Posts: 11,623
Registry
I thought I told you earlier I have an ecu here you can have. The ecu is the last thing I work have suspected though! First thing I would check is corrosion on the pins, but they are easy to open and see.
__________________
Quote:
Originally Posted by pendy
I'm here for the D's
Reply With Quote
  #6213  
Old May 21st, 2016, 08:19 PM
Nomar's Avatar
Nomar
Status: Offline
Jeff B
RR HNTR,RR LWB Tdi
Member
 
Join Date: Aug 2004
Location: Central,Virginia
Posts: 4,266
Registry
Just an FYI, some 14CUX( pronounced SUCKS) boxes had an inherent solder flaw from the factory when new.

I had one.

Otherwise, there isnt an issue running a 4.2 ECU with a 3.9; I've done it plenty---gave me an extra .008% horsepower!


.
__________________


Real Rovers have round headlights!
Rent my
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
!
Just a few miles from 4x4 access!
Reply With Quote
  #6214  
Old May 21st, 2016, 08:29 PM
85Red110's Avatar
85Red110
Status: Offline
Kent
1985 110 3-door
Member
 
Join Date: Apr 2012
Location: Springfield, VA USA
Posts: 710
Registry
Yea, I'm glad any of the 14cux ecu's will work. Mine is likely corroded pretty bad, as it looks a bit nasty even on the outside. Charles, I'd be happy to buy your spare off you if mine is totally F'ed.

By the way, in your exact words, the truck ran like a "raped ape" with Lavs good ECU in it. I couldn't believe it.
__________________
1985 Land Rover 110 3-door ST
Reply With Quote
  #6215  
Old May 21st, 2016, 08:56 PM
nathanwind's Avatar
nathanwind
Status: Offline
Jason Lavender
88-90-127-LR3
D-90 Source Vendor
 
Join Date: Jan 2008
Location: Saratoga NY
Posts: 8,736
Registry
Quote:
Originally Posted by 85Red110 View Post
Yea, I'm glad any of the 14cux ecu's will work. Mine is likely corroded pretty bad, as it looks a bit nasty even on the outside. Charles, I'd be happy to buy your spare off you if mine is totally F'ed.

By the way, in your exact words, the truck ran like a "raped ape" with Lavs good ECU in it. I couldn't believe it.
True dat. You came back with a huge smile on your face!
__________________
Jason Lavender
'71 Series IIA
'88 127 #F96 DKN
'94 90 NAS #324
'06 LR3 HSE

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

(10% discount for DSource members, use coupon code "D90")

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
  #6216  
Old May 21st, 2016, 10:17 PM
Ray_G's Avatar
Ray_G
Status: Offline
Ray Gerber
54 S1 86", 96 D1 (Coyote), 06 D3
Member
 
Join Date: Dec 2007
Location: NoVA
Posts: 2,635
Registry
Quote:
Originally Posted by o2batsea View Post
Is known good. O2 sensors not in play in this It does appear that the right bank is not fueling
Sometimes known good ends up being not good; I suggested it because I have seen when a known good ECU that had previously worked fine end up being the culprit. As these things age, corrode, etc it happens.

Glad the truck got sorted.
Reply With Quote
  #6217  
Old May 22nd, 2016, 10:11 AM
Uncle Douglas's Avatar
Uncle Douglas
Status: Offline
Doug Crowther
A defender in every driveway-motto
D-90 Source Vendor
 
Join Date: Dec 2007
Location: Gods Country- Central Virginia
Posts: 11,761
Registry
4.2 ecu is plug and play for a 3.9
__________________
Good judgement comes from experience,experience comes from bad judgement.

Dividing Creek Imports
Worldwide Vehicle Shipment and Importation Service
Restoration & Modification work


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

410.693.1391


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
  #6218  
Old May 22nd, 2016, 10:17 AM
85Red110's Avatar
85Red110
Status: Offline
Kent
1985 110 3-door
Member
 
Join Date: Apr 2012
Location: Springfield, VA USA
Posts: 710
Registry
Quote:
Originally Posted by Uncle Douglas View Post
4.2 ecu is plug and play for a 3.9
Other that being a little dirty on the outside, this thing looks perfect. Inside, the board looks brand new. No corrosion, burnt or broken connections, that I can tell. Maybe a chip is bad somewhere.



Click image for larger version

Name:	ForumRunner_20160522_101623.png
Views:	56
Size:	459.1 KB
ID:	150008



Click image for larger version

Name:	ForumRunner_20160522_101635.png
Views:	55
Size:	513.5 KB
ID:	150009



Click image for larger version

Name:	ForumRunner_20160522_101646.png
Views:	51
Size:	638.5 KB
ID:	150010



Click image for larger version

Name:	ForumRunner_20160522_101654.png
Views:	61
Size:	653.6 KB
ID:	150011
__________________
1985 Land Rover 110 3-door ST
Reply With Quote
  #6219  
Old May 22nd, 2016, 10:37 AM
carlosz's Avatar
carlosz
Status: Offline
Carlos
frank stein "frankie" in action RIP
Member
 
Join Date: Jun 2006
Location: east coast
Posts: 952
Registry
the truck ran like a "raped ape"

I love that phrase...lol.
Reply With Quote
  #6220  
Old May 22nd, 2016, 11:45 AM
Kevin88RRC's Avatar
Kevin88RRC
Status: Offline
Kevin Keith
1988 RRC
Member
 
Join Date: Dec 2014
Location: Portland, Maine
Posts: 1,037
You can check the eprom chip under the black Lucas box. It should have a a sticker noting which fuel map it is and it should match the sticker on the case stating 3361.... "Range Rover Classic 4.2 Desensitized OBD 95 MY Tune".

I have two 14cux. Both supposedly from RR 4.2s. The AMR2941 has map 3102 "Range Rover Classic 4.2 High CR Low Reed Vapor Pressure fuel tune" and the other AMR2943 has map 3100 for a 3.9. I had been running the first but tried the 3.9 map yesterday. It seemed to run my 3.5 better. Would be interested to try one of 92rrrandall's remapped chips for a 4.6.

There's a 52 page thread over on Pistonheads about remapping a 14cux. Way over my head though.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Non-Technical Discussions > Trips, Trails and Events

Tags
dementia, disturbing, dood, gay nachos, happy hour, nova, pathetic, third thursday monthly, virginia is for lovers

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New & Improved NOVA Happy Hour Thread Wolf Fabrication Trips, Trails and Events 103 May 1st, 2008 08:41 AM
Happy Hour in Nova? Bozman Trips, Trails and Events 125 June 25th, 2007 04:17 PM
Happy Hour in NoVa? Eric N Trips, Trails and Events 40 November 8th, 2006 03:44 PM
Happy Hour in NoVA loykd Trips, Trails and Events 163 September 14th, 2006 08:28 AM
Happy Hour in NoVA loykd Trips, Trails and Events 6 August 12th, 2004 04:09 PM


All times are GMT -5. The time now is 11:34 PM.


Copyright